summaryrefslogtreecommitdiffstats
path: root/abs/core/curl
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/curl
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/curl')
-rw-r--r--abs/core/curl/ChangeLog45
-rw-r--r--abs/core/curl/PKGBUILD32
2 files changed, 68 insertions, 9 deletions
diff --git a/abs/core/curl/ChangeLog b/abs/core/curl/ChangeLog
index a508322..02635bf 100644
--- a/abs/core/curl/ChangeLog
+++ b/abs/core/curl/ChangeLog
@@ -1,3 +1,48 @@
+2009-11-04 Eric Belanger <eric@archlinux.org>
+
+ * curl 7.19.7-1
+ * Upstream update
+
+2009-10-03 Robson Peixoto <robsonpeixoto@gmail.com>
+
+ * curl 7.19.6-2
+ * Compile with ca-path like Debian and Gentoo
+
+2009-08-12 Eric Belanger <eric@archlinux.org>
+
+ * curl 7.19.6-1
+ * Upstream update
+
+2009-05-18 Eric Belanger <eric@archlinux.org>
+
+ * curl 7.19.5-1
+ * Upstream update
+
+2009-03-03 Eric Belanger <eric@archlinux.org>
+
+ * curl 7.19.4-1
+ * Upstream update
+
+2009-01-21 Eric Belanger <eric@archlinux.org>
+
+ * curl 7.19.3-1
+ * Upstream update
+
+2008-11-14 Eric Belanger <eric@archlinux.org>
+
+ * curl 7.19.2-1
+ * Upstream update
+
+2008-11-08 Eric Belanger <eric@archlinux.org>
+
+ * curl 7.19.1-1
+ * Upstream update
+
+2008-09-20 Eric Belanger <eric@archlinux.org>
+
+ * curl 7.19.0-1
+ * Upstream update
+
2008-06-04 Eric Belanger <eric@archlinux.org>
* curl 7.18.2-1
diff --git a/abs/core/curl/PKGBUILD b/abs/core/curl/PKGBUILD
index cfac1fe..bee1fcb 100644
--- a/abs/core/curl/PKGBUILD
+++ b/abs/core/curl/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 2514 2008-06-05 23:10:19Z eric $
+# $Id: PKGBUILD 58157 2009-11-05 05:13:33Z eric $
# Maintainer: Eric Belanger <eric@archlinux.org>
# Contributor: Lucien Immink <l.immink@student.fnt.hvu.nl>
pkgname=curl
-pkgver=7.18.2
+pkgver=7.19.7
pkgrel=1
pkgdesc="An URL retrival utility and library"
arch=('i686' 'x86_64')
@@ -12,14 +12,28 @@ license=('MIT')
depends=('zlib' 'openssl>=0.9.8b' 'bash' 'ca-certificates')
options=('!libtool')
source=(http://curl.haxx.se/download/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('c389be5b0525276e58865956b7465562')
-sha1sums=('0a4d6878d6be22bb2d701a6cf9bf665f66fc8b87')
+md5sums=('79a8fbb2eed5464b97bdf94bee109380')
+sha1sums=('c306ebf0f65fb90df3c9c9a12fb04fb77cc29e2c')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr --without-libidn --disable-ldap \
- --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Thanks Debian and Gentoo =)
+ ./configure \
+ --with-random=/dev/urandom \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-dependency-tracking \
+ --enable-ipv6 \
+ --disable-ldaps \
+ --disable-ldap \
+ --enable-manual \
+ --enable-versioned-symbols \
+ --with-ca-path=/etc/ssl/certs \
+ --without-libidn || return 1
+
make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
- install -D -m644 COPYING ${startdir}/pkg/usr/share/licenses/${pkgname}/COPYING || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING" || return 1
+ install -D -m644 docs/libcurl/libcurl.m4 "${pkgdir}/usr/share/aclocal/libcurl.m4" || return 1
}