summaryrefslogtreecommitdiffstats
path: root/abs/core/cython/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-10-25 14:58:41 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-10-25 14:58:41 (GMT)
commit8d29737682e67ca7276fae0b1e8e69578ce61428 (patch)
tree4cc01d92c820214a4e5249575eb7f5ccd6c142bb /abs/core/cython/PKGBUILD
parentdb8bcbe3926e77c0144204beda14dee25a388d39 (diff)
parent927a8f226e532ba2187e8a9c9292453c3896f571 (diff)
downloadlinhes_pkgbuild-8d29737682e67ca7276fae0b1e8e69578ce61428.zip
linhes_pkgbuild-8d29737682e67ca7276fae0b1e8e69578ce61428.tar.gz
linhes_pkgbuild-8d29737682e67ca7276fae0b1e8e69578ce61428.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/cython/PKGBUILD')
-rw-r--r--abs/core/cython/PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/abs/core/cython/PKGBUILD b/abs/core/cython/PKGBUILD
index 3665abe..1952091 100644
--- a/abs/core/cython/PKGBUILD
+++ b/abs/core/cython/PKGBUILD
@@ -1,36 +1,35 @@
-# $Id: PKGBUILD 69975 2012-04-27 16:14:15Z spupykin $
+# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Igor Scabini <furester @ gmail.com>
-pkgname=( 'cython2')
+pkgname=('cython2')
pkgbase=cython
-pkgver=0.16
+pkgver=0.24
pkgrel=1
pkgdesc="C-Extensions for Python "
arch=(i686 x86_64)
url="http://www.cython.org"
license=('APACHE')
-makedepends=( 'python2-distribute')
+makedepends=('python2-setuptools')
source=("http://cython.org/release/Cython-$pkgver.tar.gz")
-md5sums=('7934186ada3552110aba92062fa88b1c')
-
-build() {
- true
-}
+md5sums=('14fbc970f4a856845e633cbc09e61048')
package_cython() {
- depends=('python')
+ depends=('python' 'python-setuptools')
cd $srcdir/Cython-$pkgver
python setup.py install --root=$pkgdir
+
+ sed -i 's|#!.*python|#!/usr/bin/python3|' $pkgdir/usr/bin/*
}
package_cython2() {
- depends=('python2')
+ depends=('python2' 'python2-setuptools')
cd $srcdir/Cython-$pkgver
python2 setup.py install --root=$pkgdir
mv $pkgdir/usr/bin/cygdb $pkgdir/usr/bin/cygdb2
mv $pkgdir/usr/bin/cython $pkgdir/usr/bin/cython2
+ mv $pkgdir/usr/bin/cythonize $pkgdir/usr/bin/cythonize2
}