summaryrefslogtreecommitdiffstats
path: root/abs/core/cython
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-12-07 19:26:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-12-07 19:26:48 (GMT)
commitdea33684bb85a7aebc6383e3fbe5a08d45a85296 (patch)
tree1534c24edce424acf1bf33e8db51b850a1adc710 /abs/core/cython
parent8f9766814d4ac032887c160cd98528c531a97067 (diff)
downloadlinhes_pkgbuild-dea33684bb85a7aebc6383e3fbe5a08d45a85296.zip
linhes_pkgbuild-dea33684bb85a7aebc6383e3fbe5a08d45a85296.tar.gz
linhes_pkgbuild-dea33684bb85a7aebc6383e3fbe5a08d45a85296.tar.bz2
cython: first build
Diffstat (limited to 'abs/core/cython')
-rw-r--r--abs/core/cython/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/cython/PKGBUILD b/abs/core/cython/PKGBUILD
new file mode 100644
index 0000000..9901e43
--- /dev/null
+++ b/abs/core/cython/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=('cython2')
+pkgbase=cython
+pkgver=0.15.1
+pkgrel=2
+pkgdesc="C-Extensions for Python "
+arch=(i686 x86_64)
+url="http://www.cython.org"
+license=('APACHE')
+makedepends=('python2-distribute')
+source=("http://cython.org/release/Cython-$pkgver.tar.gz")
+md5sums=('171021b3845c9ca8bd6d8185b3cde664')
+
+build() {
+ true
+}
+
+
+package_cython2() {
+ depends=('python2')
+
+ cd $srcdir/Cython-$pkgver
+ python2 setup.py install --root=$pkgdir
+
+ mv $pkgdir/usr/bin/cygdb $pkgdir/usr/bin/cygdb2
+ mv $pkgdir/usr/bin/cython $pkgdir/usr/bin/cython2
+}