summaryrefslogtreecommitdiffstats
path: root/abs/core/db/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/db/PKGBUILD
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/db/PKGBUILD')
-rw-r--r--abs/core/db/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/db/PKGBUILD b/abs/core/db/PKGBUILD
new file mode 100644
index 0000000..e41aeac
--- /dev/null
+++ b/abs/core/db/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 3741 2008-06-30 20:07:01Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=db
+pkgver=4.7.25
+pkgrel=10
+pkgdesc="The Berkeley DB embedded database system"
+arch=(i686 x86_64)
+license=('custom')
+url="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
+groups=('base')
+depends=('gcc-libs' 'coreutils')
+options=('!libtool')
+source=(http://download-uk.oracle.com/berkeley-db/db-$pkgver.tar.gz)
+install=(db.install)
+md5sums=('ec2b87e833779681a0c3a814aa71359e')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver/build_unix
+ ../dist/configure --prefix=/usr --enable-compat185 \
+ --enable-shared --enable-static --enable-cxx
+ make LIBSO_LIBS=-lpthread || return 1
+ make DESTDIR=${pkgdir} install
+ rm -rf ${pkgdir}/usr/docs
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}