summaryrefslogtreecommitdiffstats
path: root/abs/core/dbus-core/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-06 22:38:29 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-06 22:38:29 (GMT)
commit6f86cf0e71f5d67cf0f719babdf2ca001a008cc6 (patch)
tree503b444f539fe809de99212845ce23f9f5fb4478 /abs/core/dbus-core/PKGBUILD
parent6e17c873a304c292228a5172c6b0a2a5bd8f3460 (diff)
downloadlinhes_pkgbuild-6f86cf0e71f5d67cf0f719babdf2ca001a008cc6.zip
linhes_pkgbuild-6f86cf0e71f5d67cf0f719babdf2ca001a008cc6.tar.gz
linhes_pkgbuild-6f86cf0e71f5d67cf0f719babdf2ca001a008cc6.tar.bz2
dbus-core 1.6.4
Diffstat (limited to 'abs/core/dbus-core/PKGBUILD')
-rw-r--r--abs/core/dbus-core/PKGBUILD58
1 files changed, 28 insertions, 30 deletions
diff --git a/abs/core/dbus-core/PKGBUILD b/abs/core/dbus-core/PKGBUILD
index 78ac2f8..afca05e 100644
--- a/abs/core/dbus-core/PKGBUILD
+++ b/abs/core/dbus-core/PKGBUILD
@@ -1,56 +1,54 @@
-# $Id: PKGBUILD 90541 2010-09-13 10:46:30Z jgc $
+# $Id: PKGBUILD 163992 2012-07-23 14:58:38Z andyrtr $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Link Dupont <link@subpop.net>
#
pkgname=dbus-core
-pkgver=1.4.0
+pkgver=1.6.4
pkgrel=1
pkgdesc="Freedesktop.org message bus system"
url="http://www.freedesktop.org/Software/dbus"
arch=(i686 x86_64)
license=('GPL' 'custom')
-depends=('expat>=2.0.1' 'coreutils' 'filesystem')
-conflicts=('dbus<1.2.3-2')
+depends=('expat' 'coreutils' 'filesystem' 'libsystemd' 'shadow' 'systemd-tools') # shadow for install scriptlet FS#29341
+makedepends=('libx11')
options=(!libtool)
install=dbus.install
-source=(http://dbus.freedesktop.org/releases/dbus/dbus-${pkgver}.tar.gz
+source=(http://dbus.freedesktop.org/releases/dbus/dbus-$pkgver.tar.gz{,.asc}
dbus)
-md5sums=('f59618b18d2fb2bd1fce9e1c5a2a3282'
- '08f93dd19cffd1b45ab05c1fd4efb560')
+md5sums=('5ec43dc4554cba638917317b2b4f7640'
+ '3d4482ee39b49da334441c76f83bf1cb'
+ 'f0364f3f5dc5f653bb05d39aa36e3264')
build() {
- cd "${srcdir}/dbus-${pkgver}"
+ cd dbus-$pkgver
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
- --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-pid-file=/run/dbus/pid \
+ --with-system-socket=/run/dbus/system_bus_socket \
+ --with-console-auth-dir=/run/console/ \
--enable-inotify --disable-dnotify \
--disable-verbose-mode --disable-static \
- --disable-tests --disable-asserts --without-x
- make || return 1
+ --disable-tests --disable-asserts \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
+ --enable-systemd
+ make
}
-package() {
- cd "${srcdir}/dbus-${pkgver}"
- make DESTDIR="${pkgdir}" install
- rm -f "${pkgdir}/usr/bin/dbus-launch"
- rm -f "${pkgdir}/usr/share/man/man1/dbus-launch.1"
+package(){
+ cd dbus-$pkgver
+ make DESTDIR="$pkgdir" install
- chown 81:81 "${pkgdir}/var/run/dbus"
+ rm -f "$pkgdir/usr/bin/dbus-launch"
+ rm -f "$pkgdir/usr/share/man/man1/dbus-launch.1"
+ rm -rf "$pkgdir/var/run"
- install -m755 -d "${pkgdir}/etc/rc.d"
- install -m755 "${srcdir}/dbus" "${pkgdir}/etc/rc.d/"
+ install -m755 -d "$pkgdir/etc/rc.d"
+ install -m755 ../dbus "$pkgdir/etc/rc.d/"
#Fix configuration file
- sed -i -e 's|<user>81</user>|<user>dbus</user>|' "${pkgdir}/etc/dbus-1/system.conf"
+ sed -i -e 's|<user>81</user>|<user>dbus</user>|' "$pkgdir/etc/dbus-1/system.conf"
- #install .keep files so pacman doesn't delete empty dirs
- touch "${pkgdir}/usr/share/dbus-1/services/.keep"
- touch "${pkgdir}/usr/share/dbus-1/system-services/.keep"
- touch "${pkgdir}/etc/dbus-1/session.d/.keep"
- touch "${pkgdir}/etc/dbus-1/system.d/.keep"
-
- rmdir "${pkgdir}/usr/lib/dbus-1.0/dbus-1"
-
- install -d -m755 "${pkgdir}/usr/share/licenses/dbus-core"
- install -m644 COPYING "${pkgdir}/usr/share/licenses/dbus-core/"
+ install -dm755 "$pkgdir/usr/share/licenses/dbus-core"
+ install -m644 COPYING "$pkgdir/usr/share/licenses/dbus-core/"
}
+