summaryrefslogtreecommitdiffstats
path: root/abs/core/dbus-core/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/dbus-core/PKGBUILD
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/dbus-core/PKGBUILD')
-rw-r--r--abs/core/dbus-core/PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/abs/core/dbus-core/PKGBUILD b/abs/core/dbus-core/PKGBUILD
index 7a1bc6e..b57829f 100644
--- a/abs/core/dbus-core/PKGBUILD
+++ b/abs/core/dbus-core/PKGBUILD
@@ -1,36 +1,36 @@
-# $Id: PKGBUILD 19084 2008-11-14 21:36:59Z jgc $
+# $Id: PKGBUILD 73272 2010-03-24 11:36:47Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Link Dupont <link@subpop.net>
#
pkgname=dbus-core
-pkgver=1.2.4
+pkgver=1.2.24
pkgrel=1
pkgdesc="Freedesktop.org message bus system"
url="http://www.freedesktop.org/Software/dbus"
arch=(i686 x86_64)
license=('GPL' 'custom')
-depends=('expat>=2.0')
+depends=('expat>=2.0.1' 'coreutils' 'filesystem')
conflicts=('dbus<1.2.3-2')
options=(!libtool)
install=dbus.install
source=(http://dbus.freedesktop.org/releases/dbus/dbus-${pkgver}.tar.gz
- dbus)
-md5sums=('2e643910a09f44b000a0d76038637999'
- 'f3fd196cc278bd7b45a4ca01fb8f7894')
+ dbus)
+md5sums=('565346cecd9cfecf1463540c6086cc2c'
+ '08f93dd19cffd1b45ab05c1fd4efb560')
build() {
cd "${srcdir}/dbus-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
- --with-system-pid-file=/var/run/dbus.pid \
- --enable-inotify --disable-dnotify \
- --disable-verbose-mode --disable-static \
- --disable-tests --disable-asserts --without-x || return 1
+ --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --enable-inotify --disable-dnotify \
+ --disable-verbose-mode --disable-static \
+ --disable-tests --disable-asserts --without-x || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
- rm -f ${pkgdir}/usr/bin/dbus-launch
- rm -f ${pkgdir}/usr/share/man/man1/dbus-launch.1
+ rm -f "${pkgdir}/usr/bin/dbus-launch"
+ rm -f "${pkgdir}/usr/share/man/man1/dbus-launch.1"
chown 81:81 "${pkgdir}/var/run/dbus" || return 1