summaryrefslogtreecommitdiffstats
path: root/abs/core/dbus-core
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/dbus-core
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/dbus-core')
-rw-r--r--abs/core/dbus-core/PKGBUILD53
-rw-r--r--abs/core/dbus-core/dbus57
-rw-r--r--abs/core/dbus-core/dbus.install21
3 files changed, 131 insertions, 0 deletions
diff --git a/abs/core/dbus-core/PKGBUILD b/abs/core/dbus-core/PKGBUILD
new file mode 100644
index 0000000..7a1bc6e
--- /dev/null
+++ b/abs/core/dbus-core/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id: PKGBUILD 19084 2008-11-14 21:36:59Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Link Dupont <link@subpop.net>
+#
+pkgname=dbus-core
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="Freedesktop.org message bus system"
+url="http://www.freedesktop.org/Software/dbus"
+arch=(i686 x86_64)
+license=('GPL' 'custom')
+depends=('expat>=2.0')
+conflicts=('dbus<1.2.3-2')
+options=(!libtool)
+install=dbus.install
+source=(http://dbus.freedesktop.org/releases/dbus/dbus-${pkgver}.tar.gz
+ dbus)
+md5sums=('2e643910a09f44b000a0d76038637999'
+ 'f3fd196cc278bd7b45a4ca01fb8f7894')
+
+build() {
+ cd "${srcdir}/dbus-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --enable-inotify --disable-dnotify \
+ --disable-verbose-mode --disable-static \
+ --disable-tests --disable-asserts --without-x || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+
+ rm -f ${pkgdir}/usr/bin/dbus-launch
+ rm -f ${pkgdir}/usr/share/man/man1/dbus-launch.1
+
+ chown 81:81 "${pkgdir}/var/run/dbus" || return 1
+
+ install -m755 -d "${pkgdir}/etc/rc.d" || return 1
+ install -m755 "${srcdir}/dbus" "${pkgdir}/etc/rc.d/" || return 1
+
+ #Fix configuration file
+ sed -i -e 's|<user>81</user>|<user>dbus</user>|' "${pkgdir}/etc/dbus-1/system.conf" || return 1
+
+ #install .keep files so pacman doesn't delete empty dirs
+ touch "${pkgdir}/usr/share/dbus-1/services/.keep" || return 1
+ touch "${pkgdir}/usr/share/dbus-1/system-services/.keep" || return 1
+ touch "${pkgdir}/etc/dbus-1/session.d/.keep" || return 1
+ touch "${pkgdir}/etc/dbus-1/system.d/.keep" || return 1
+
+ rmdir "${pkgdir}/usr/lib/dbus-1.0/dbus-1" || return 1
+
+ install -d -m755 "${pkgdir}/usr/share/licenses/dbus-core"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/dbus-core/" || return 1
+}
diff --git a/abs/core/dbus-core/dbus b/abs/core/dbus-core/dbus
new file mode 100644
index 0000000..cd26db8
--- /dev/null
+++ b/abs/core/dbus-core/dbus
@@ -0,0 +1,57 @@
+#!/bin/bash
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+case "$1" in
+ start)
+ stat_busy "Starting D-BUS system messagebus"
+ if [ ! -x /var/run/dbus ] ; then
+ install -m755 -g 81 -o 81 -d /var/run/dbus
+ fi
+ if [ -x /usr/bin/dbus-uuidgen ] ; then
+ /usr/bin/dbus-uuidgen --ensure
+ fi
+
+ /usr/bin/dbus-daemon --system
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon dbus
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping D-BUS system messagebus"
+ [ -f /var/run/dbus.pid ] && kill `cat /var/run/dbus.pid`
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm -f /var/run/dbus.pid
+ rm_daemon dbus
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ reload)
+ stat_busy "Reloading D-BUS configuration"
+ [ -f /var/run/dbus.pid ] && /usr/bin/dbus-send \
+ --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ stat_done
+ fi
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart|reload}"
+ ;;
+esac
+exit 0
diff --git a/abs/core/dbus-core/dbus.install b/abs/core/dbus-core/dbus.install
new file mode 100644
index 0000000..85dd9a7
--- /dev/null
+++ b/abs/core/dbus-core/dbus.install
@@ -0,0 +1,21 @@
+post_install() {
+ getent group dbus >/dev/null || usr/sbin/groupadd -g 81 dbus
+ getent passwd dbus >/dev/null || usr/sbin/useradd -c 'System message bus' -u 81 -g dbus -d '/' -s /bin/false dbus
+ usr/bin/passwd -l dbus &>/dev/null
+ dbus-uuidgen --ensure
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+
+ #Make sure new rc script can shutdown running dbus
+ [ -f var/run/dbus/pid ] && mv var/run/dbus/pid var/run/dbus.pid
+}
+
+# arg 1: the old package version
+pre_remove() {
+ usr/sbin/userdel dbus &>/dev/null
+ usr/sbin/groupdel dbus &>/dev/null
+}