summaryrefslogtreecommitdiffstats
path: root/abs/core/dbus-python/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-16 17:33:40 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-16 17:33:40 (GMT)
commit49bc0e193d6f210bd96e3bc2d6a8a1a3fc311902 (patch)
tree006de6050d2f665de92a588b8d7c81f4a5012477 /abs/core/dbus-python/PKGBUILD
parentfb486c082b04946caae9f6912d2cbbd4604cebca (diff)
downloadlinhes_pkgbuild-49bc0e193d6f210bd96e3bc2d6a8a1a3fc311902.zip
linhes_pkgbuild-49bc0e193d6f210bd96e3bc2d6a8a1a3fc311902.tar.gz
linhes_pkgbuild-49bc0e193d6f210bd96e3bc2d6a8a1a3fc311902.tar.bz2
python-dbus: update to 1.2.6
Diffstat (limited to 'abs/core/dbus-python/PKGBUILD')
-rw-r--r--abs/core/dbus-python/PKGBUILD65
1 files changed, 34 insertions, 31 deletions
diff --git a/abs/core/dbus-python/PKGBUILD b/abs/core/dbus-python/PKGBUILD
index 2e7116d..acaf5e8 100644
--- a/abs/core/dbus-python/PKGBUILD
+++ b/abs/core/dbus-python/PKGBUILD
@@ -2,59 +2,62 @@
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgbase=dbus-python
-pkgname=('python2-dbus' 'python-dbus-common')
-pkgver=1.2.0
-pkgrel=4
+pkgname=('python-dbus' 'python2-dbus' 'python-dbus-common')
+pkgver=1.2.6
+pkgrel=1
pkgdesc="Python bindings for DBUS"
-arch=('i686' 'x86_64')
+url="https://www.freedesktop.org/wiki/Software/DBusBindings"
+arch=(x86_64)
license=('GPL' 'LGPL')
-url="http://www.freedesktop.org/wiki/Software/DBusBindings"
-makedepends=('docutils' 'dbus-glib' 'python2')
-source=(http://dbus.freedesktop.org/releases/${pkgbase}/${pkgbase}-${pkgver}.tar.gz{,.asc})
-md5sums=('b09cd2d1a057cc432ce944de3fc06bf7'
- 'SKIP')
+depends=('dbus' 'glib2')
+makedepends=('docutils' 'python' 'python2' 'autoconf-archive')
+source=(https://dbus.freedesktop.org/releases/${pkgbase}/${pkgbase}-${pkgver}.tar.gz{,.asc})
+sha256sums=('32f29c17172cdb9cb61c68b1f1a71dfe7351506fc830869029c47449bd04faeb'
+ 'SKIP')
+validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90')
prepare() {
- mkdir build-python2
+ mkdir build-python2 build-python3
cd $pkgbase-$pkgver
autoreconf -fi
}
build() {
cd build-python2
- PYTHON=python2 ../${pkgbase}-${pkgver}/configure --prefix=/usr
+ ../${pkgbase}-${pkgver}/configure --prefix=/usr PYTHON_VERSION=2
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
-# cd ../build-python3
-# ../${pkgbase}-${pkgver}/configure --prefix=/usr
-# make
+ cd ../build-python3
+ ../${pkgbase}-${pkgver}/configure --prefix=/usr
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
}
package_python-dbus-common() {
pkgdesc="Common dbus-python files shared between python-dbus and python2-dbus"
+ depends=()
conflicts=('dbus-python<1.1.0')
- cd build-python2
+ cd build-python3
make DESTDIR="${pkgdir}" install-data
- rm -rf "${pkgdir}"/usr/lib/python*
+ rm -r "${pkgdir}"/usr/lib/python*
}
-#package_python-dbus() {
-# depends=('python-dbus-common' 'python' 'dbus')
-# optdepends=('dbus-glib: glib mainloop support')
-# pkgdesc="Python 3.3 bindings for DBUS"
+package_python-dbus() {
+ depends+=('python-dbus-common' 'python')
+ pkgdesc="Python 3.6 bindings for DBUS"
-# cd build-python3
-# make DESTDIR="${pkgdir}" install
+ cd build-python3
+ make DESTDIR="${pkgdir}" install
-# rm -rf "${pkgdir}/usr/share"
-# rm -rf "${pkgdir}/usr/include"
-# rm -rf "${pkgdir}/usr/lib/pkgconfig"
-#}
+ rm -r "${pkgdir}/usr/share"
+ rm -r "${pkgdir}/usr/include"
+ rm -r "${pkgdir}/usr/lib/pkgconfig"
+}
package_python2-dbus() {
- depends=('python-dbus-common' 'python2' 'dbus')
- optdepends=('dbus-glib: glib mainloop support')
+ depends+=('python-dbus-common' 'python2')
pkgdesc="Python 2.7 bindings for DBUS"
replaces=('dbus-python')
conflicts=('dbus-python')
@@ -63,7 +66,7 @@ package_python2-dbus() {
cd build-python2
make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}/usr/share"
- rm -rf "${pkgdir}/usr/include"
- rm -rf "${pkgdir}/usr/lib/pkgconfig"
+ rm -r "${pkgdir}/usr/share"
+ rm -r "${pkgdir}/usr/include"
+ rm -r "${pkgdir}/usr/lib/pkgconfig"
}