summaryrefslogtreecommitdiffstats
path: root/abs/core/dhcpcd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-16 23:45:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:03 (GMT)
commitc4243584e2cc38bca40a9a209bd4582ebdb843f1 (patch)
tree9daaa130587485d6ea5f89a33926ed34e4bd2604 /abs/core/dhcpcd
parent49b76b6cbfd0c4ecfc645cb7ae779dfdbc57e503 (diff)
downloadlinhes_pkgbuild-c4243584e2cc38bca40a9a209bd4582ebdb843f1.zip
linhes_pkgbuild-c4243584e2cc38bca40a9a209bd4582ebdb843f1.tar.gz
linhes_pkgbuild-c4243584e2cc38bca40a9a209bd4582ebdb843f1.tar.bz2
dhcpcd: 6.1
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/core/dhcpcd')
-rw-r--r--abs/core/dhcpcd/PKGBUILD38
-rw-r--r--abs/core/dhcpcd/dhcpcd.service13
-rw-r--r--abs/core/dhcpcd/dhcpcd_.service15
3 files changed, 51 insertions, 15 deletions
diff --git a/abs/core/dhcpcd/PKGBUILD b/abs/core/dhcpcd/PKGBUILD
index 4600940..82a42e8 100644
--- a/abs/core/dhcpcd/PKGBUILD
+++ b/abs/core/dhcpcd/PKGBUILD
@@ -1,28 +1,34 @@
-# $Id: PKGBUILD 155703 2012-04-05 10:02:36Z ronald $
+# $Id: PKGBUILD 199762 2013-11-15 21:24:38Z ronald $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Tom Killian <tom.archlinux.org>
# Contributor: Judd Vinet <jvinet.zeroflux.org>
pkgname=dhcpcd
-pkgver=5.5.6
+pkgver=6.1.0
pkgrel=1
pkgdesc="RFC2131 compliant DHCP client daemon"
-url="http://roy.marples.name/dhcpcd/"
+url="http://roy.marples.name/projects/dhcpcd/"
arch=('i686' 'x86_64')
license=('BSD')
groups=('base')
depends=('glibc' 'sh')
-backup=('etc/conf.d/dhcpcd' 'etc/dhcpcd.conf')
+provides=('dhcp-client')
+backup=('etc/dhcpcd.conf')
options=('emptydirs') # We Need the Empty /var/lib/dhcpcd Directory
-source=("http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2" \
- 'dhcpcd.conf.d')
+source=("http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2"
+ 'dhcpcd_.service'
+ 'dhcpcd.service'
+ 'dhcpcd.conf.d' )
build() {
cd ${srcdir}/${pkgname}-${pkgver}
# configure variables
- ./configure --libexecdir=/usr/lib/dhcpcd --dbdir=/var/lib/dhcpcd \
- --rundir=/run
+ ./configure \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/dhcpcd \
+ --dbdir=/var/lib/dhcpcd \
+ --rundir=/run
# Build
make
@@ -32,20 +38,22 @@ package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
- # Create Binary Symlink
- install -d ${pkgdir}/usr/sbin
- ln -sf /sbin/dhcpcd ${pkgdir}/usr/sbin/dhcpcd
-
# Install Configuration File used in /etc/rc.d/network
install -D -m644 ../dhcpcd.conf.d $pkgdir/etc/conf.d/$pkgname
# Install License
install -d $pkgdir/usr/share/licenses/$pkgname
- awk '{if(FNR<27)print $0}' ${srcdir}/${pkgname}-${pkgver}/configure.h \
- >> ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ sed 26q "$srcdir/$pkgname-$pkgver/control.h" \
+ >>"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# Set Options in /etc/dhcpcd.conf
echo noipv4ll >> ${pkgdir}/etc/dhcpcd.conf # Disable ip4vall
+
+ # install systemd files
+ install -Dm644 ${srcdir}/dhcpcd_.service ${pkgdir}/usr/lib/systemd/system/dhcpcd@.service
+ install -Dm644 ${srcdir}/dhcpcd.service ${pkgdir}/usr/lib/systemd/system/dhcpcd.service # FS#31543
}
-md5sums=('a5c0e43b4e836cfc003437329f6b7982'
+md5sums=('6070040c57492925af9ac6aed980de2a'
+ '98cfea55077ba1680c2e902d669585b3'
+ '75bd063ad699609eb84f09b843f0971f'
'1579b1b17306570078d2d4edfc867983')
diff --git a/abs/core/dhcpcd/dhcpcd.service b/abs/core/dhcpcd/dhcpcd.service
new file mode 100644
index 0000000..489023d
--- /dev/null
+++ b/abs/core/dhcpcd/dhcpcd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=dhcpcd on all interfaces
+Wants=network.target
+Before=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/dhcpcd.pid
+ExecStart=/bin/dhcpcd -q -b
+ExecStop=/bin/dhcpcd -x
+
+[Install]
+WantedBy=multi-user.target
diff --git a/abs/core/dhcpcd/dhcpcd_.service b/abs/core/dhcpcd/dhcpcd_.service
new file mode 100644
index 0000000..e7bc5ca
--- /dev/null
+++ b/abs/core/dhcpcd/dhcpcd_.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=dhcpcd on %I
+Wants=network.target
+Before=network.target
+BindsTo=sys-subsystem-net-devices-%i.device
+After=sys-subsystem-net-devices-%i.device
+
+[Service]
+Type=forking
+PIDFile=/run/dhcpcd-%I.pid
+ExecStart=/usr/bin/dhcpcd -q -w %I
+ExecStop=/usr/bin/dhcpcd -x %I
+
+[Install]
+WantedBy=multi-user.target