summaryrefslogtreecommitdiffstats
path: root/abs/core/dhcpcd
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-10 19:01:30 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-10 19:01:30 (GMT)
commitd8620522693cbf77206b27121f2e68e55f5c6639 (patch)
tree55d123f7cf743bc45c78edac94692004f0e3566f /abs/core/dhcpcd
parentda5bc04aaa40ded396de6030ebc723c4299612a8 (diff)
downloadlinhes_pkgbuild-d8620522693cbf77206b27121f2e68e55f5c6639.zip
linhes_pkgbuild-d8620522693cbf77206b27121f2e68e55f5c6639.tar.gz
linhes_pkgbuild-d8620522693cbf77206b27121f2e68e55f5c6639.tar.bz2
dhcpcd: update to 6.9.1
Diffstat (limited to 'abs/core/dhcpcd')
-rw-r--r--abs/core/dhcpcd/0001-Set-hostname-via-proc-if-file-is-available.patch33
-rw-r--r--abs/core/dhcpcd/0001-set-MTU-via-sysfs-if-file-is-available.patch61
-rw-r--r--abs/core/dhcpcd/PKGBUILD40
-rw-r--r--abs/core/dhcpcd/__changelog8
-rw-r--r--abs/core/dhcpcd/dhcpcd.service4
-rw-r--r--abs/core/dhcpcd/dhcpcd_.service15
-rw-r--r--abs/core/dhcpcd/remove_ifconfig.patch20
7 files changed, 28 insertions, 153 deletions
diff --git a/abs/core/dhcpcd/0001-Set-hostname-via-proc-if-file-is-available.patch b/abs/core/dhcpcd/0001-Set-hostname-via-proc-if-file-is-available.patch
deleted file mode 100644
index 4420d0b..0000000
--- a/abs/core/dhcpcd/0001-Set-hostname-via-proc-if-file-is-available.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d345b36b483fec8fb2def5f3acdc2d3c5faa94eb Mon Sep 17 00:00:00 2001
-From: Dan McGee <dan@archlinux.org>
-Date: Sun, 19 Jun 2011 16:04:25 -0500
-Subject: [PATCH] Set hostname via /proc if file is available
-
-On Linux, the hostname can be set via this file if available, precluding
-the need for a `hostname` binary.
-
-Signed-off-by: Dan McGee <dan@archlinux.org>
----
- dhcpcd-hooks/30-hostname | 6 +++++-
- 1 files changed, 5 insertions(+), 1 deletions(-)
-
-diff --git a/dhcpcd-hooks/30-hostname b/dhcpcd-hooks/30-hostname
-index 65d1a13..af94262 100644
---- a/dhcpcd-hooks/30-hostname
-+++ b/dhcpcd-hooks/30-hostname
-@@ -21,7 +21,11 @@ need_hostname()
- try_hostname()
- {
- if valid_domainname "$1"; then
-- hostname "$1"
-+ if [ -w /proc/sys/kernel/hostname ]; then
-+ echo "$1" > /proc/sys/kernel/hostname
-+ else
-+ hostname "$1"
-+ fi
- else
- syslog err "Invalid hostname: $1"
- fi
---
-1.7.5.4
-
diff --git a/abs/core/dhcpcd/0001-set-MTU-via-sysfs-if-file-is-available.patch b/abs/core/dhcpcd/0001-set-MTU-via-sysfs-if-file-is-available.patch
deleted file mode 100644
index 7e78ecd..0000000
--- a/abs/core/dhcpcd/0001-set-MTU-via-sysfs-if-file-is-available.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 950c00d1b183796034d227ef47a90eb248d79b72 Mon Sep 17 00:00:00 2001
-From: Dave Reisner <d@falconindy.com>
-Date: Tue, 21 Jun 2011 09:32:47 -0400
-Subject: [PATCH] set MTU via sysfs if file is available
-
-On Linux, a network interface's MTU can be set by writing to
-/sys/class/net/$interface/mtu, which removes the dependency on ifconfig.
-
-Signed-off-by: Dave Reisner <d@falconindy.com>
----
- dhcpcd-hooks/10-mtu | 4 ++--
- dhcpcd-run-hooks.in | 11 +++++++++++
- 2 files changed, 13 insertions(+), 2 deletions(-)
-
-diff --git a/dhcpcd-hooks/10-mtu b/dhcpcd-hooks/10-mtu
-index 639697c..8763930 100644
---- a/dhcpcd-hooks/10-mtu
-+++ b/dhcpcd-hooks/10-mtu
-@@ -7,7 +7,7 @@ if [ "$reason" = PREINIT -a -e "$mtu_dir/$interface" ]; then
- elif [ -n "$new_interface_mtu" ] && $if_up; then
- # The smalled MTU dhcpcd can work with is 576
- if [ "$new_interface_mtu" -ge 576 ]; then
-- if ifconfig "$interface" mtu "$new_interface_mtu"; then
-+ if set_mtu "$interface" "$new_interface_mtu"; then
- syslog info "$interface: MTU set to $new_interface_mtu"
- # Save the MTU so we can restore it later
- if [ ! -e "$mtu_dir/$interface" ]; then
-@@ -21,7 +21,7 @@ elif [ -e "$mtu_dir/$interface" ]; then
- # No MTU in this state, so restore the prior MTU
- mtu=$(cat "$mtu_dir/$interface")
- syslog info "$interface: MTU restored to $mtu"
-- ifconfig "$interface" mtu "$mtu"
-+ set_mtu "$interface" "$mtu"
- rm "$mtu_dir/$interface"
- fi
- fi
-diff --git a/dhcpcd-run-hooks.in b/dhcpcd-run-hooks.in
-index 0e60338..843f3ca 100644
---- a/dhcpcd-run-hooks.in
-+++ b/dhcpcd-run-hooks.in
-@@ -215,6 +215,17 @@ service_condcommand()
- service_exists $1 && service_status $1 && service_cmd $1 $2
- }
-
-+# Set MTU for an interface
-+set_mtu() {
-+ local interface=$1 mtu=$2
-+
-+ if [ -e /sys/class/net/$interface/mtu ]; then
-+ echo "$mtu" > /sys/class/net/$interface/mtu
-+ else
-+ ifconfig "$interface" mtu "$mtu"
-+ fi
-+}
-+
- # We source each script into this one so that scripts run earlier can
- # remove variables from the environment so later scripts don't see them.
- # Thus, the user can create their dhcpcd.enter/exit-hook script to configure
---
-1.7.5.4
-
diff --git a/abs/core/dhcpcd/PKGBUILD b/abs/core/dhcpcd/PKGBUILD
index 81ea3be..ede945f 100644
--- a/abs/core/dhcpcd/PKGBUILD
+++ b/abs/core/dhcpcd/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 199762 2013-11-15 21:24:38Z ronald $
+# $Id$
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Tom Killian <tom.archlinux.org>
# Contributor: Judd Vinet <jvinet.zeroflux.org>
pkgname=dhcpcd
-pkgver=6.1.0
-pkgrel=4
+pkgver=6.9.1
+pkgrel=1
pkgdesc="RFC2131 compliant DHCP client daemon"
url="http://roy.marples.name/projects/dhcpcd/"
arch=('i686' 'x86_64')
@@ -15,48 +15,52 @@ depends=('glibc' 'sh')
provides=('dhcp-client')
backup=('etc/dhcpcd.conf')
options=('emptydirs') # We Need the Empty /var/lib/dhcpcd Directory
-source=("http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.bz2"
+source=("http://roy.marples.name/downloads/$pkgname/$pkgname-$pkgver.tar.xz"
'dhcpcd_.service'
- 'dhcpcd.service'
- 'dhcpcd.conf.d' )
+ 'dhcpcd.service'
+ 'dhcpcd.conf.d')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
# configure variables
- ./configure \
+ ./configure \
--sbindir=/usr/bin \
--libexecdir=/usr/lib/dhcpcd \
--libdir=/usr/lib \
--dbdir=/var/lib/dhcpcd \
--rundir=/run
-
-
# Build
make
}
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make test
+}
+
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
# Install Configuration File used in /etc/rc.d/network
install -D -m644 ../dhcpcd.conf.d $pkgdir/etc/conf.d/$pkgname
# Install License
- install -d $pkgdir/usr/share/licenses/$pkgname
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
sed 26q "$srcdir/$pkgname-$pkgver/control.h" \
>>"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# Set Options in /etc/dhcpcd.conf
- echo noipv4ll >> ${pkgdir}/etc/dhcpcd.conf # Disable ip4vall
+ echo noipv4ll >> "${pkgdir}/etc/dhcpcd.conf" # Disable ip4vall
# install systemd files
- install -Dm644 ${srcdir}/dhcpcd_.service ${pkgdir}/usr/lib/systemd/system/dhcpcd@.service
- install -Dm644 ${srcdir}/dhcpcd.service ${pkgdir}/usr/lib/systemd/system/dhcpcd.service # FS#31543
+ install -Dm644 "${srcdir}/dhcpcd_.service" "${pkgdir}/usr/lib/systemd/system/dhcpcd@.service"
+ install -Dm644 "${srcdir}/dhcpcd.service" "${pkgdir}/usr/lib/systemd/system/dhcpcd.service" # FS#31543
}
-md5sums=('6070040c57492925af9ac6aed980de2a'
+md5sums=('42df0ef5f8a4b07c28faa56f42d55bab'
'98cfea55077ba1680c2e902d669585b3'
- '75bd063ad699609eb84f09b843f0971f'
+ '85056d566b3119c02017cfcff768f710'
'1579b1b17306570078d2d4edfc867983')
diff --git a/abs/core/dhcpcd/__changelog b/abs/core/dhcpcd/__changelog
index 0004c0c..24efa35 100644
--- a/abs/core/dhcpcd/__changelog
+++ b/abs/core/dhcpcd/__changelog
@@ -1,4 +1,4 @@
-Added to dhcpcd.conf.d
-DHCPCD_ARGS="-t 30 -h $HOSTNAME"
-
-Added libdir=/usr/lib because /lib conflicts with filesystem pkg
+Added dhcpcd.conf.d
+ DHCPCD_ARGS="-t 30 -h $HOSTNAME"
+PKGBUILD: add dhcpcd.conf.d
+PKGBUILD: add libdir=/usr/lib because /lib conflicts with filesystem pkg
diff --git a/abs/core/dhcpcd/dhcpcd.service b/abs/core/dhcpcd/dhcpcd.service
index 489023d..e7dc289 100644
--- a/abs/core/dhcpcd/dhcpcd.service
+++ b/abs/core/dhcpcd/dhcpcd.service
@@ -6,8 +6,8 @@ Before=network.target
[Service]
Type=forking
PIDFile=/run/dhcpcd.pid
-ExecStart=/bin/dhcpcd -q -b
-ExecStop=/bin/dhcpcd -x
+ExecStart=/usr/bin/dhcpcd -q -b
+ExecStop=/usr/bin/dhcpcd -x
[Install]
WantedBy=multi-user.target
diff --git a/abs/core/dhcpcd/dhcpcd_.service b/abs/core/dhcpcd/dhcpcd_.service
deleted file mode 100644
index e7bc5ca..0000000
--- a/abs/core/dhcpcd/dhcpcd_.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=dhcpcd on %I
-Wants=network.target
-Before=network.target
-BindsTo=sys-subsystem-net-devices-%i.device
-After=sys-subsystem-net-devices-%i.device
-
-[Service]
-Type=forking
-PIDFile=/run/dhcpcd-%I.pid
-ExecStart=/usr/bin/dhcpcd -q -w %I
-ExecStop=/usr/bin/dhcpcd -x %I
-
-[Install]
-WantedBy=multi-user.target
diff --git a/abs/core/dhcpcd/remove_ifconfig.patch b/abs/core/dhcpcd/remove_ifconfig.patch
deleted file mode 100644
index 5bcc4a6..0000000
--- a/abs/core/dhcpcd/remove_ifconfig.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- dhcpcd-hooks/10-mtu.orig 2011-11-04 07:45:46.477712667 +0100
-+++ dhcpcd-hooks/10-mtu 2011-11-04 07:46:38.964379550 +0100
-@@ -7,7 +7,7 @@
- elif [ -n "$new_interface_mtu" ] && $if_up; then
- # The smalled MTU dhcpcd can work with is 576
- if [ "$new_interface_mtu" -ge 576 ]; then
-- if ifconfig "$interface" mtu "$new_interface_mtu"; then
-+ if ip link set "$interface" mtu "$new_interface_mtu"; then
- syslog info "$interface: MTU set to $new_interface_mtu"
- # Save the MTU so we can restore it later
- if [ ! -e "$mtu_dir/$interface" ]; then
-@@ -21,7 +21,7 @@
- # No MTU in this state, so restore the prior MTU
- mtu=$(cat "$mtu_dir/$interface")
- syslog info "$interface: MTU restored to $mtu"
-- ifconfig "$interface" mtu "$mtu"
-+ ip link set "$interface" mtu "$new_interface_mtu"
- rm "$mtu_dir/$interface"
- fi
- fi