summaryrefslogtreecommitdiffstats
path: root/abs/core/dmapi
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/dmapi
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/dmapi')
-rw-r--r--abs/core/dmapi/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/dmapi/PKGBUILD b/abs/core/dmapi/PKGBUILD
new file mode 100644
index 0000000..0f5d015
--- /dev/null
+++ b/abs/core/dmapi/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+pkgname=dmapi
+pkgver=2.2.8
+pkgrel=12
+pkgdesc="Data migration API"
+arch=(i686 x86_64)
+url="http://oss.sgi.com/projects/xfs/"
+license=('GPL')
+groups=('base')
+depends=('glibc')
+makedepends=('xfsprogs')
+provides=('xfsdmapi')
+conflicts=('xfsdmapi')
+replaces=('xfsdmapi')
+options=('!libtool')
+source=(ftp://oss.sgi.com/projects/xfs/cmd_tars/dmapi_$pkgver-1.tar.gz)
+md5sums=('1265828fabc6e3ec4b70696db331fb8a')
+
+build() {
+ cd $startdir/src/dmapi-$pkgver
+ [ "$CARCH" = "x86_64" ] && export CFLAGS="$CLFAGS -fPIC"
+ autoconf
+ ./configure --prefix=$startdir/pkg/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr/ install install-lib install-dev
+ # the static lib
+ install -D -m644 libdm/.libs/libdm.a $startdir/pkg/usr/lib/libdm.a
+ # and the header file, please
+ install -D -m644 include/dmapi.h $startdir/pkg/usr/include/xfs/dmapi.h
+}