summaryrefslogtreecommitdiffstats
path: root/abs/core/dnssec-anchors/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:13:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:13:22 (GMT)
commitec1773c0ec77eca2786df1d50b71d64e48084b09 (patch)
treede78667aa1d8073e0343329d70efa2d488bab1d3 /abs/core/dnssec-anchors/PKGBUILD
parent53b844dc123333ed35920dbc5b77deacd6743eda (diff)
downloadlinhes_pkgbuild-ec1773c0ec77eca2786df1d50b71d64e48084b09.zip
linhes_pkgbuild-ec1773c0ec77eca2786df1d50b71d64e48084b09.tar.gz
linhes_pkgbuild-ec1773c0ec77eca2786df1d50b71d64e48084b09.tar.bz2
dnssec-anchors 20120422
Diffstat (limited to 'abs/core/dnssec-anchors/PKGBUILD')
-rw-r--r--abs/core/dnssec-anchors/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/dnssec-anchors/PKGBUILD b/abs/core/dnssec-anchors/PKGBUILD
new file mode 100644
index 0000000..3546394
--- /dev/null
+++ b/abs/core/dnssec-anchors/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 157121 2012-04-24 08:19:44Z bisson $
+# Contributor: Thomas Mudrunka <harvie@email.cz>
+# Contributor: m4xm4n <max@maxfierke.com>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=dnssec-anchors
+pkgver=20120422
+pkgrel=1
+pkgdesc='DNSSEC trust anchors for the root zone'
+url='http://data.iana.org/root-anchors/'
+license=('custom:NoCopyright')
+arch=('any')
+source=('trusted-key.key')
+sha256sums=('a6e1e5de6d3f26ea74792eab7ac21cc7805e986303bfa270a0120cc8146f881a')
+
+# dig . dnskey +short | sed 's/^/. 172789 IN DNSKEY /' > trusted-key.key
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm644 trusted-key.key "${pkgdir}"/etc/trusted-key.key
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ cat > "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" << EOF
+The contents of this package are inelligible for copyright protection.
+EOF
+}