summaryrefslogtreecommitdiffstats
path: root/abs/core/dnsutils
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/dnsutils
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/dnsutils')
-rw-r--r--abs/core/dnsutils/PKGBUILD45
-rw-r--r--abs/core/dnsutils/tools-only.patch15
2 files changed, 34 insertions, 26 deletions
diff --git a/abs/core/dnsutils/PKGBUILD b/abs/core/dnsutils/PKGBUILD
index 672613e..336f534 100644
--- a/abs/core/dnsutils/PKGBUILD
+++ b/abs/core/dnsutils/PKGBUILD
@@ -1,31 +1,36 @@
-# $Id: PKGBUILD 5888 2008-07-21 19:29:16Z kevin $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 85957 2010-07-22 20:05:06Z kevin $
+# Maintainer: kevin <kevin@archlinux.org>
# Contributor: mario <mario_vazq@hotmail.com>
pkgname=dnsutils
-pkgver=9.5.0
-_pkgver=9.5.0-P1
-pkgrel=4
+# Use a period and not a hyphen before the patch level for proper versioning.
+pkgver=9.7.1.P2
+_pkgver=9.7.1-P2
+pkgrel=1
pkgdesc="Various DNS utilities - dig host nslookup nsupdate"
arch=(i686 x86_64)
-url="http://www.isc.org/index.pl?/sw/bind/"
+url="https://www.isc.org/software/bind"
license=('custom:ISC')
-depends=('openssl>=0.9.8e')
-replaces=('bind-tools')
-source=(ftp://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.gz
+depends=('openssl')
+replaces=('bind-tools' 'host')
+options=('makeflags')
+source=(http://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.gz
bind.so_bsdcompat.diff tools-only.patch)
-md5sums=('a4f9dd6d205d24ec89fa4e44d8188197' '447d58721cfee0e1e377b46f7d50b327'
- '329f7e15b8c45d3efefdf5b559bb878a')
+md5sums=('bd6be63cc910d04da39103d441871596'
+ '447d58721cfee0e1e377b46f7d50b327'
+ 'be0558f70ed81d90e68e6b6003ba12ed')
build() {
- export MAKEFLAGS="-j1"
-
- cd ${startdir}/src/bind-${_pkgver}
- patch -Np0 -i ${startdir}/src/bind.so_bsdcompat.diff || return 1
- patch -Np1 -i ${startdir}/src/tools-only.patch || return 1
+ cd "${srcdir}/bind-${_pkgver}"
+ patch -Np0 -i "${srcdir}/bind.so_bsdcompat.diff" || return 1
+ patch -Np1 -i "${srcdir}/tools-only.patch" || return 1
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --with-openssl=yes --disable-linux-caps --without-libxml2
+ --with-openssl=yes --disable-linux-caps --without-libxml2 || return 1
make || return 1
- cd bin
- make DESTDIR=${startdir}/pkg install || return 1
- install -D -m644 ../COPYRIGHT $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
+}
+
+package() {
+ cd "${srcdir}/bind-${_pkgver}/bin"
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 ../COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
}
diff --git a/abs/core/dnsutils/tools-only.patch b/abs/core/dnsutils/tools-only.patch
index f777282..b46b71f 100644
--- a/abs/core/dnsutils/tools-only.patch
+++ b/abs/core/dnsutils/tools-only.patch
@@ -1,16 +1,19 @@
---- bind-9.3.1/bin/Makefile.in.orig 2005-05-06 01:52:36.000000000 -0400
-+++ bind-9.3.1/bin/Makefile.in 2005-05-06 01:53:24.000000000 -0400
-@@ -19,7 +19,7 @@
+diff -Naur bind-9.7.1-P2.orig/bin/Makefile.in bind-9.7.1-P2/bin/Makefile.in
+--- bind-9.7.1-P2.orig/bin/Makefile.in 2009-10-05 08:07:08.000000000 -0400
++++ bind-9.7.1-P2/bin/Makefile.in 2010-07-22 15:55:00.000000000 -0400
+@@ -19,8 +19,7 @@
VPATH = @srcdir@
top_srcdir = @top_srcdir@
--SUBDIRS = named rndc dig dnssec tests nsupdate check
+-SUBDIRS = named rndc dig dnssec tests tools nsupdate \
+- check confgen @PKCS11_TOOLS@
+SUBDIRS = dig nsupdate
TARGETS =
@BIND9_MAKE_RULES@
---- bind-9.3.1/lib/Makefile.in.orig 2005-05-06 02:05:12.000000000 -0400
-+++ bind-9.3.1/lib/Makefile.in 2005-05-06 02:05:35.000000000 -0400
+diff -Naur bind-9.7.1-P2.orig/lib/Makefile.in bind-9.7.1-P2/lib/Makefile.in
+--- bind-9.7.1-P2.orig/lib/Makefile.in 2007-06-19 19:47:13.000000000 -0400
++++ bind-9.7.1-P2/lib/Makefile.in 2010-07-22 15:56:29.000000000 -0400
@@ -23,7 +23,7 @@
# Attempt to disable parallel processing.
.NOTPARALLEL: