summaryrefslogtreecommitdiffstats
path: root/abs/core/docutils
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/docutils
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/docutils')
-rw-r--r--abs/core/docutils/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core/docutils/PKGBUILD b/abs/core/docutils/PKGBUILD
new file mode 100644
index 0000000..d1240c4
--- /dev/null
+++ b/abs/core/docutils/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 21893 2010-07-18 10:50:27Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: tardo <tardo@nagi-fanboi.net>
+
+pkgname=docutils
+pkgver=0.7
+pkgrel=2
+pkgdesc="Set of tools for processing plaintext docs into formats such as HTML, XML, or LaTeX"
+arch=(any)
+url="http://docutils.sourceforge.net"
+license=('custom')
+depends=('python')
+source=(http://downloads.sourceforge.net/docutils/docutils-$pkgver.tar.gz)
+md5sums=('9aec716baf15d06b5aa57cf8d5591c15')
+
+build() {
+ pacman -Q docutils && { error "You should remove docutils" ; return 1; }
+
+ cd $srcdir/docutils-$pkgver
+ python setup.py install --root=$pkgdir
+
+ for f in $pkgdir/usr/bin/*.py; do
+ mv $f $pkgdir/usr/bin/$(basename $f .py)
+ done
+
+ install -D -m644 COPYING.txt $pkgdir/usr/share/licenses/$pkgname/COPYING.txt
+ install -D -m644 licenses/python* $pkgdir/usr/share/licenses/$pkgname/
+}
+