summaryrefslogtreecommitdiffstats
path: root/abs/core/dosfstools
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/dosfstools
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/dosfstools')
-rw-r--r--abs/core/dosfstools/PKGBUILD20
-rw-r--r--abs/core/dosfstools/linux-2.6.patch64
2 files changed, 84 insertions, 0 deletions
diff --git a/abs/core/dosfstools/PKGBUILD b/abs/core/dosfstools/PKGBUILD
new file mode 100644
index 0000000..488cab5
--- /dev/null
+++ b/abs/core/dosfstools/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 9911 2008-08-21 00:29:06Z eric $
+# Maintainer: dorphell <dorphell@archlinux.org>
+# Committer: Judd Vinet <jvinet@zeroflux.org>
+pkgname=dosfstools
+pkgver=2.11
+pkgrel=2
+pkgdesc="DOS filesystem utilities"
+arch=(i686 x86_64)
+depends=('glibc')
+source=(ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/$pkgname/$pkgname-$pkgver.src.tar.gz linux-2.6.patch)
+md5sums=('407d405ade410f7597d364ab5dc8c9f6' '6689fb7693ed213e6c3289b533b4f66d')
+url="ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/"
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -p1 -i $startdir/src/linux-2.6.patch
+ patch -Np0 -i $startdir/src/dosfstools_$pkgver-1.diff
+ make || return 1
+ make PREFIX=$startdir/pkg install
+}
diff --git a/abs/core/dosfstools/linux-2.6.patch b/abs/core/dosfstools/linux-2.6.patch
new file mode 100644
index 0000000..e21e94c
--- /dev/null
+++ b/abs/core/dosfstools/linux-2.6.patch
@@ -0,0 +1,64 @@
+diff -Nur dosfstools-2.10/dosfsck/boot.c dosfstools-2.10-fixed/dosfsck/boot.c
+--- dosfstools-2.10/dosfsck/boot.c 2003-06-14 22:03:20.000000000 +0200
++++ dosfstools-2.10-fixed/dosfsck/boot.c 2004-02-11 21:15:48.000000000 +0100
+@@ -14,6 +14,9 @@
+ #include "io.h"
+ #include "boot.h"
+
++#ifndef MSDOS_FAT12
++# define MSDOS_FAT12 4084 /* taken from 2.4 linux/msdos_fs.h */
++#endif
+
+ #define ROUND_TO_MULTIPLE(n,m) ((n) && (m) ? (n)+(m)-1-((n)-1)%(m) : 0)
+ /* don't divide by zero */
+diff -Nur dosfstools-2.10/dosfsck/common.h dosfstools-2.10-fixed/dosfsck/common.h
+--- dosfstools-2.10/dosfsck/common.h 1998-04-28 13:14:25.000000000 +0200
++++ dosfstools-2.10-fixed/dosfsck/common.h 2004-02-11 21:15:01.000000000 +0100
+@@ -6,6 +6,9 @@
+ #ifndef _COMMON_H
+ #define _COMMON_H
+
++#include <asm/types.h>
++#include <asm/byteorder.h>
++
+ void die(char *msg,...) __attribute((noreturn));
+
+ /* Displays a prinf-style message and terminates the program. */
+diff -Nur dosfstools-2.10/dosfsck/file.c dosfstools-2.10-fixed/dosfsck/file.c
+--- dosfstools-2.10/dosfsck/file.c 2003-06-14 22:03:20.000000000 +0200
++++ dosfstools-2.10-fixed/dosfsck/file.c 2004-02-11 21:13:53.000000000 +0100
+@@ -15,9 +15,9 @@
+ #define _LINUX_STAT_H /* hack to avoid inclusion of <linux/stat.h> */
+ #define _LINUX_STRING_H_ /* hack to avoid inclusion of <linux/string.h>*/
+ #define _LINUX_FS_H /* hack to avoid inclusion of <linux/fs.h> */
++#include "common.h"
+ #include <linux/msdos_fs.h>
+
+-#include "common.h"
+ #include "file.h"
+
+
+diff -Nur dosfstools-2.10/dosfsck/io.c dosfstools-2.10-fixed/dosfsck/io.c
+--- dosfstools-2.10/dosfsck/io.c 2003-06-14 22:03:20.000000000 +0200
++++ dosfstools-2.10-fixed/dosfsck/io.c 2004-02-11 21:14:24.000000000 +0100
+@@ -21,8 +21,8 @@
+ #include <fcntl.h>
+ #include <linux/fd.h>
+
+-#include "dosfsck.h"
+ #include "common.h"
++#include "dosfsck.h"
+ #include "io.h"
+
+
+diff -Nur dosfstools-2.10/mkdosfs/mkdosfs.c dosfstools-2.10-fixed/mkdosfs/mkdosfs.c
+--- dosfstools-2.10/mkdosfs/mkdosfs.c 2003-06-14 22:07:08.000000000 +0200
++++ dosfstools-2.10-fixed/mkdosfs/mkdosfs.c 2004-02-11 21:13:09.000000000 +0100
+@@ -62,6 +62,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <asm/types.h>
+ #include <unistd.h>
+ #include <time.h>
+ #include <errno.h>