summaryrefslogtreecommitdiffstats
path: root/abs/core/dvd+rw-tools
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-10-24 19:13:41 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-10-24 19:13:41 (GMT)
commite9615db9786ec5d51e2dd4720fb77223192819a4 (patch)
tree05e2f74a66c430d59a90115889928879196e64eb /abs/core/dvd+rw-tools
parent05273a8f4d16f4c4bf13fa86f38a0150b95227b3 (diff)
downloadlinhes_pkgbuild-e9615db9786ec5d51e2dd4720fb77223192819a4.zip
linhes_pkgbuild-e9615db9786ec5d51e2dd4720fb77223192819a4.tar.gz
linhes_pkgbuild-e9615db9786ec5d51e2dd4720fb77223192819a4.tar.bz2
dvd+rw-tools: add shell wrapper for sudo workaround
Diffstat (limited to 'abs/core/dvd+rw-tools')
-rw-r--r--abs/core/dvd+rw-tools/PKGBUILD7
-rw-r--r--abs/core/dvd+rw-tools/__changelog1
-rw-r--r--abs/core/dvd+rw-tools/growisofs.sh5
3 files changed, 12 insertions, 1 deletions
diff --git a/abs/core/dvd+rw-tools/PKGBUILD b/abs/core/dvd+rw-tools/PKGBUILD
index 21ea762..081cd6e 100644
--- a/abs/core/dvd+rw-tools/PKGBUILD
+++ b/abs/core/dvd+rw-tools/PKGBUILD
@@ -3,13 +3,14 @@
pkgname=dvd+rw-tools
pkgver=7.1
-pkgrel=4
+pkgrel=5
pkgdesc="dvd burning tools"
arch=('i686' 'x86_64')
license=('GPL')
url="http://fy.chalmers.se/~appro/linux/DVD+RW"
depends=('cdrkit' 'gcc-libs')
source=("http://fy.chalmers.se/~appro/linux/DVD+RW/tools/${pkgname}-${pkgver}.tar.gz"
+ 'growisofs.sh'
'dvd+rw-tools-7.0-dvddl.patch'
'dvd+rw-tools-7.0-glibc2.6.90.patch'
'dvd+rw-tools-7.0-wctomb.patch'
@@ -35,8 +36,12 @@ package() {
install -m755 growisofs dvd+rw-booktype dvd+rw-format dvd+rw-mediainfo dvd-ram-control "${pkgdir}/usr/bin/"
install -m644 growisofs.1 ${pkgdir}/usr/share/man/man1/growisofs.1
+ mv ${pkgdir}/usr/bin/growisofs ${pkgdir}/usr/bin/growisofs.bin
+ install -m755 ${srcdir}/growisofs.sh "${pkgdir}/usr/bin/growisofs"
+
}
md5sums=('8acb3c885c87f6838704a0025e435871'
+ '8bc0f9438b0ba922260741bf4e6179b2'
'65d30aa98ff314f256d0a1afb9e3edf6'
'1be5401035ca850edb7e522f22aead4b'
'3ba1af063b30f942e1cd2004044702d3'
diff --git a/abs/core/dvd+rw-tools/__changelog b/abs/core/dvd+rw-tools/__changelog
new file mode 100644
index 0000000..93b0cbf
--- /dev/null
+++ b/abs/core/dvd+rw-tools/__changelog
@@ -0,0 +1 @@
+add growisofs shell script to get around sudo
diff --git a/abs/core/dvd+rw-tools/growisofs.sh b/abs/core/dvd+rw-tools/growisofs.sh
new file mode 100644
index 0000000..e0b287c
--- /dev/null
+++ b/abs/core/dvd+rw-tools/growisofs.sh
@@ -0,0 +1,5 @@
+#!/bin/bash
+unset SUDO_COMMAND
+export MKISOFS=/usr/bin/mkisofs
+exec growisofs.bin "$@"
+