summaryrefslogtreecommitdiffstats
path: root/abs/core/dvdauthor
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:15:04 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:15:04 (GMT)
commit8959fc86be9d3d2e811b80b903acda6fdb66e3a2 (patch)
treedd0f6691c2547d2142a010e23818df3fff9c41e9 /abs/core/dvdauthor
parente2a6e3fca7b7e3f57dd2c747374b78e8393f70e4 (diff)
downloadlinhes_pkgbuild-8959fc86be9d3d2e811b80b903acda6fdb66e3a2.zip
linhes_pkgbuild-8959fc86be9d3d2e811b80b903acda6fdb66e3a2.tar.gz
linhes_pkgbuild-8959fc86be9d3d2e811b80b903acda6fdb66e3a2.tar.bz2
dvd author 0.7.0
Diffstat (limited to 'abs/core/dvdauthor')
-rw-r--r--abs/core/dvdauthor/PKGBUILD25
-rw-r--r--abs/core/dvdauthor/dvdauthor-0.7.0-libpng15.patch19
2 files changed, 35 insertions, 9 deletions
diff --git a/abs/core/dvdauthor/PKGBUILD b/abs/core/dvdauthor/PKGBUILD
index 967c9e2..6eda716 100644
--- a/abs/core/dvdauthor/PKGBUILD
+++ b/abs/core/dvdauthor/PKGBUILD
@@ -1,28 +1,35 @@
-# $Id: PKGBUILD 87461 2010-08-13 20:20:49Z giovanni $
+# $Id: PKGBUILD 148702 2012-02-05 11:47:33Z ibiru $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Travis Willard <travisw@wmpub.ca>
# Contributor: Jaroslaw Swierczynski <swiergot@juvepoland.com>
# Contributor: Nicolai Lissner <nlissne@linux01.gwdg.de>
pkgname=dvdauthor
-pkgver=0.6.18
-pkgrel=2
+pkgver=0.7.0
+pkgrel=4
pkgdesc="DVD authoring tools"
arch=('i686' 'x86_64')
url="http://dvdauthor.sourceforge.net/"
license=('GPL')
depends=('libdvdread' 'imagemagick' 'libxml2' 'libpng' 'fribidi')
options=('!makeflags')
-source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('ded5373800ac6448ff044606f5047550')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'dvdauthor-0.7.0-libpng15.patch')
+md5sums=('33a447fb98ab3293ac40f869eedc17ff'
+ '9ea90bbea6adb0469c8c1b2f7d033f11')
build() {
cd "${srcdir}/${pkgname}"
- ./configure --prefix=/usr || return 1
- make || return 1
+
+ patch -Np0 -i "${srcdir}/dvdauthor-0.7.0-libpng15.patch"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
+ make
}
+
package() {
cd "${srcdir}/${pkgname}"
- make DESTDIR="${pkgdir}" install || return 1
-}
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/abs/core/dvdauthor/dvdauthor-0.7.0-libpng15.patch b/abs/core/dvdauthor/dvdauthor-0.7.0-libpng15.patch
new file mode 100644
index 0000000..2bb6363
--- /dev/null
+++ b/abs/core/dvdauthor/dvdauthor-0.7.0-libpng15.patch
@@ -0,0 +1,19 @@
+--- src/spuunmux.c
++++ src/spuunmux.c
+@@ -39,6 +39,7 @@
+ #include <netinet/in.h>
+
+ #include <png.h>
++#include <zlib.h>
+
+ #include "rgb.h"
+ #include "common.h"
+@@ -610,7 +611,7 @@
+ png_destroy_write_struct(&png_ptr, (png_infopp)NULL);
+ return -1;
+ } /*if*/
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);