summaryrefslogtreecommitdiffstats
path: root/abs/core/e2fsprogs
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/e2fsprogs
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/e2fsprogs')
-rw-r--r--abs/core/e2fsprogs/MIT-LICENSE25
-rw-r--r--abs/core/e2fsprogs/PKGBUILD55
-rw-r--r--abs/core/e2fsprogs/e2fsprogs.install23
3 files changed, 66 insertions, 37 deletions
diff --git a/abs/core/e2fsprogs/MIT-LICENSE b/abs/core/e2fsprogs/MIT-LICENSE
new file mode 100644
index 0000000..d849b28
--- /dev/null
+++ b/abs/core/e2fsprogs/MIT-LICENSE
@@ -0,0 +1,25 @@
+Copyright (c) 2003-2007 Theodore Ts'o <tytso@mit.edu>
+Copyright (c) 1997-2003 Yann Dirson <dirson@debian.org>
+Copyright (c) 2001 Alcove <http://www.alcove.com/>
+Copyright (c) 1997 Klee Dienes
+Copyright (c) 1995-1996 Michael Nonweiler <mrn20@cam.ac.uk>
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject
+to the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY
+KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
+WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/abs/core/e2fsprogs/PKGBUILD b/abs/core/e2fsprogs/PKGBUILD
index 6da53ff..730522b 100644
--- a/abs/core/e2fsprogs/PKGBUILD
+++ b/abs/core/e2fsprogs/PKGBUILD
@@ -1,41 +1,46 @@
-# $Id: PKGBUILD 16283 2008-10-21 12:05:45Z ronald $
-# Maintainer:
+# $Id: PKGBUILD 80571 2010-05-19 18:38:36Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=e2fsprogs
-pkgver=1.41.3
-pkgrel=2
+pkgver=1.41.12
+pkgrel=1
pkgdesc="Ext2/3/4 filesystem utilities"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'MIT')
url="http://e2fsprogs.sourceforge.net"
groups=('base')
-depends=('glibc')
+depends=('sh' 'util-linux-ng')
makedepends=('bc')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz
- 'Makefile-fsck.static.patch')
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'MIT-LICENSE')
backup=('etc/mke2fs.conf')
-install=$pkgname.install
-md5sums=('b21d26fc46c584021dc9c444933ee1c2'
- 'ce2b0daf84e17e8c7880ba3d43020ea3')
+install=${pkgname}.install
+sha1sums=('62b002fe507b2ddafc24b89532e472fe4b55a14f'
+ 'f4a0d5b0cdb980e3fedd6f5e7dde0b0ffb7bbdfb')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
# Remove unnecessary init.d directory
- sed -i '/init\.d/s|^|#|' misc/Makefile.in
+ sed -i '/init\.d/s|^|#|' misc/Makefile.in || return 1
+
+ ./configure --prefix=/usr --with-root-prefix="" --enable-elf-shlibs \
+ --disable-fsck --disable-uuidd \
+ --disable-libuuid --disable-libblkid || return 1
+
- ./configure --prefix=/usr --with-root-prefix="" --enable-elf-shlibs
-
- # add fsck.static for mkinitrd use
- patch -Np1 -i ../Makefile-fsck.static.patch || return 1
-
make || return 1
- make DESTDIR=${pkgdir} install install-libs || return 1
- make -C ${srcdir}/${pkgname}-${pkgver}/misc fsck.static || return 1
-
- install -D -m755 ${srcdir}/${pkgname}-${pkgver}/misc/fsck.static \
- ${pkgdir}/sbin/fsck.static || return 1
-
- sed -i -e 's/^AWK=.*/AWK=awk/' ${pkgdir}/usr/bin/compile_et || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install install-libs || return 1
+
+ sed -i -e 's/^AWK=.*/AWK=awk/' "${pkgdir}/usr/bin/compile_et" || return 1
+
+ # install MIT license
+ install -Dm644 "${srcdir}/MIT-LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/MIT-LICENSE" || return 1
+
}
diff --git a/abs/core/e2fsprogs/e2fsprogs.install b/abs/core/e2fsprogs/e2fsprogs.install
index e207eb4..f91d39f 100644
--- a/abs/core/e2fsprogs/e2fsprogs.install
+++ b/abs/core/e2fsprogs/e2fsprogs.install
@@ -1,21 +1,20 @@
- infodir=/usr/share/info
- filelist=(libext2fs.info.gz)
+infodir=/usr/share/info
+filelist=(libext2fs.info.gz)
- post_install() {
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info $infodir/$file $infodir/dir 2> /dev/null
done
+}
- }
+post_upgrade() {
+ post_install $1
+}
- post_upgrade() {
- post_install $1
- }
-
- post_remove() {
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
done
-
- }
-
+}