summaryrefslogtreecommitdiffstats
path: root/abs/core/faad2
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/faad2
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/faad2')
-rw-r--r--abs/core/faad2/ChangeLog14
-rw-r--r--abs/core/faad2/LICENSE28
-rw-r--r--abs/core/faad2/PKGBUILD45
-rw-r--r--abs/core/faad2/faad2-2.6.1-abi_has_changed.patch14
-rw-r--r--abs/core/faad2/faad2-2.6.1-broken-pipe.patch22
-rw-r--r--abs/core/faad2/faad2-2.6.1-implicitdeclar.patch11
-rw-r--r--abs/core/faad2/faad2-2.6.1-libtool22.patch13
7 files changed, 147 insertions, 0 deletions
diff --git a/abs/core/faad2/ChangeLog b/abs/core/faad2/ChangeLog
new file mode 100644
index 0000000..b4073ba
--- /dev/null
+++ b/abs/core/faad2/ChangeLog
@@ -0,0 +1,14 @@
+2008-07-19 Eric Belanger <eric@archlinux.org>
+
+ * faad2 2.6.1-1
+ * Upstream update
+ * Patched to fix libtool build problem :
+ faad2-2.6.1-libtool22.patch
+ * Patched to make faad2 exit if output pipe breaks :
+ faad2-2.6.1-broken-pipe.patch
+ * Patched to fix include file implicit declaration :
+ faad2-2.6.1-implicitdeclar.patch
+ * Patched to bump soname (symbols have been changed) :
+ faad2-2.6.1-abi_has_changed.patch
+ * Updated license
+ * Added ChangeLog
diff --git a/abs/core/faad2/LICENSE b/abs/core/faad2/LICENSE
new file mode 100644
index 0000000..ecb2c75
--- /dev/null
+++ b/abs/core/faad2/LICENSE
@@ -0,0 +1,28 @@
+/*
+** FAAD2 - Freeware Advanced Audio (AAC) Decoder including SBR decoding
+** Copyright (C) 2003-2005 M. Bakker, Nero AG, http://www.nero.com
+**
+** This program is free software; you can redistribute it and/or modify
+** it under the terms of the GNU General Public License as published by
+** the Free Software Foundation; either version 2 of the License, or
+** (at your option) any later version.
+**
+** This program is distributed in the hope that it will be useful,
+** but WITHOUT ANY WARRANTY; without even the implied warranty of
+** MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+** GNU General Public License for more details.
+**
+** You should have received a copy of the GNU General Public License
+** along with this program; if not, write to the Free Software
+** Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+**
+** Any non-GPL usage of this software or parts of this software is strictly
+** forbidden.
+**
+** The "appropriate copyright message" mentioned in section 2c of the GPLv2
+** must read: "Code from FAAD2 is copyright (c) Nero AG, www.nero.com"
+**
+** Commercial non-GPL licensing of this software is possible.
+** For more info contact Nero AG through Mpeg4AAClicense@nero.com.
+**
+*/
diff --git a/abs/core/faad2/PKGBUILD b/abs/core/faad2/PKGBUILD
new file mode 100644
index 0000000..227cc3b
--- /dev/null
+++ b/abs/core/faad2/PKGBUILD
@@ -0,0 +1,45 @@
+# $Id: PKGBUILD 5668 2008-07-20 05:06:05Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Sarah Hay <sarah@archlinux.org>
+
+pkgname=faad2
+pkgver=2.6.1
+pkgrel=1
+pkgdesc="ISO AAC audio decoder"
+arch=('i686' 'x86_64')
+url="http://www.audiocoding.com/"
+license=('custom:GPL')
+depends=('glibc')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/faac/${pkgname}-${pkgver}.tar.gz
+ faad2-2.6.1-libtool22.patch
+ faad2-2.6.1-broken-pipe.patch
+ faad2-2.6.1-implicitdeclar.patch
+ faad2-2.6.1-abi_has_changed.patch
+ LICENSE)
+md5sums=('74e92df40c270f216a8305fc87603c8a' 'ca9515b6617d7fd060d0d172616eb192'\
+ 'bb6a345dd2e6c4df6609e6a374134066' 'bc43fd3f8cd582a8bc092b9b5e611865'\
+ '06e83633c609d20436794b62a382b3dc' 'b6a1c72534807b8a038b71e784f57e32')
+sha1sums=('b4ad33d3c4dfa6dbf3011a3da34c631926cabfad'
+ 'ca4ee04aa1757b8f9deeef52b5bf35dc823da844'
+ '0b03728f40d00e552f738900e2f6215177af5417'
+ 'd4ab5d38c9b75ed6417529c4d1a7ca204293c224'
+ 'f7e9d89fc551e0b61a7b7555749ed7a3129a4ce8'
+ '6225fd997671206f5222c4a86d9e092359552c43')
+
+build() {
+ cd ${srcdir}/${pkgname}
+ patch -p1 < ../faad2-2.6.1-libtool22.patch || return 1
+ patch -p1 < ../faad2-2.6.1-broken-pipe.patch || return 1
+ patch -p1 < ../faad2-2.6.1-implicitdeclar.patch || return 1
+ patch -p1 < ../faad2-2.6.1-abi_has_changed.patch || return 1
+
+ autoreconf -vif || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -m644 ${srcdir}/${pkgname}/common/mp4ff/mp4ff.h ${pkgdir}/usr/include/ || return 1
+ install -m644 ${srcdir}/${pkgname}/common/mp4ff/mp4ff_int_types.h ${pkgdir}/usr/include/ || return 1
+ install -m644 ${srcdir}/${pkgname}/common/mp4ff/.libs/*.a ${pkgdir}/usr/lib/ || return 1
+ install -D -m644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+}
diff --git a/abs/core/faad2/faad2-2.6.1-abi_has_changed.patch b/abs/core/faad2/faad2-2.6.1-abi_has_changed.patch
new file mode 100644
index 0000000..7206e38
--- /dev/null
+++ b/abs/core/faad2/faad2-2.6.1-abi_has_changed.patch
@@ -0,0 +1,14 @@
+Index: faad2/libfaad/Makefile.am
+===================================================================
+--- faad2.orig/libfaad/Makefile.am
++++ faad2/libfaad/Makefile.am
+@@ -3,7 +3,8 @@ lib_LTLIBRARIES = libfaad.la
+ include_HEADERS = $(top_srcdir)/include/faad.h \
+ $(top_srcdir)/include/neaacdec.h
+
+-libfaad_la_LDFLAGS = -lm
++libfaad_la_LDFLAGS = -version-info 1:0:0
++libfaad_la_LIBADD = -lm
+
+ libfaad_la_SOURCES = bits.c cfft.c decoder.c drc.c \
+ drm_dec.c error.c filtbank.c \
diff --git a/abs/core/faad2/faad2-2.6.1-broken-pipe.patch b/abs/core/faad2/faad2-2.6.1-broken-pipe.patch
new file mode 100644
index 0000000..428d7dd
--- /dev/null
+++ b/abs/core/faad2/faad2-2.6.1-broken-pipe.patch
@@ -0,0 +1,22 @@
+--- faad2/frontend/main.c~ 2007-11-01 06:33:29.000000000 -0600
++++ faad2/frontend/main.c 2008-01-03 18:05:10.000000000 -0700
+@@ -640,7 +640,8 @@
+
+ if ((frameInfo.error == 0) && (frameInfo.samples > 0) && (!adts_out))
+ {
+- write_audio_file(aufile, sample_buffer, frameInfo.samples, 0);
++ if (write_audio_file(aufile, sample_buffer, frameInfo.samples, 0) == 0)
++ break;
+ }
+
+ /* fill buffer */
+@@ -976,7 +977,8 @@
+
+ if ((frameInfo.error == 0) && (sample_count > 0) && (!adts_out))
+ {
+- write_audio_file(aufile, sample_buffer, sample_count, delay);
++ if (write_audio_file(aufile, sample_buffer, sample_count, delay) == 0)
++ break;
+ }
+
+ if (frameInfo.error > 0)
diff --git a/abs/core/faad2/faad2-2.6.1-implicitdeclar.patch b/abs/core/faad2/faad2-2.6.1-implicitdeclar.patch
new file mode 100644
index 0000000..9379329
--- /dev/null
+++ b/abs/core/faad2/faad2-2.6.1-implicitdeclar.patch
@@ -0,0 +1,11 @@
+diff -aur faad2-orig/frontend/main.c faad2/frontend/main.c
+--- faad2-orig/frontend/main.c 2007-11-01 08:33:29.000000000 -0400
++++ faad2/frontend/main.c 2008-06-21 19:33:08.000000000 -0400
+@@ -41,6 +41,7 @@
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <getopt.h>
++#include <string.h>
+
+ #include <neaacdec.h>
+ #include <mp4ff.h>
diff --git a/abs/core/faad2/faad2-2.6.1-libtool22.patch b/abs/core/faad2/faad2-2.6.1-libtool22.patch
new file mode 100644
index 0000000..4eab084
--- /dev/null
+++ b/abs/core/faad2/faad2-2.6.1-libtool22.patch
@@ -0,0 +1,13 @@
+Index: faad2/configure.in
+===================================================================
+--- faad2.orig/configure.in
++++ faad2/configure.in
+@@ -18,7 +18,7 @@ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CPP
+ dnl disable for mpeg4ip plugin
+-dnl AC_PROG_CXX
++AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET