summaryrefslogtreecommitdiffstats
path: root/abs/core/fcgi
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-23 01:07:41 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-23 01:07:41 (GMT)
commitab1f74f88e28d997bbccd8ff7f3f02a098e4b226 (patch)
treeccf610e707fece79866e376226c158f1551380cf /abs/core/fcgi
parent0fc101ce380848b03f6109cc808afcb1bad0fe92 (diff)
downloadlinhes_pkgbuild-ab1f74f88e28d997bbccd8ff7f3f02a098e4b226.zip
linhes_pkgbuild-ab1f74f88e28d997bbccd8ff7f3f02a098e4b226.tar.gz
linhes_pkgbuild-ab1f74f88e28d997bbccd8ff7f3f02a098e4b226.tar.bz2
fcgi: recompile
Diffstat (limited to 'abs/core/fcgi')
-rw-r--r--abs/core/fcgi/PKGBUILD34
-rw-r--r--abs/core/fcgi/gcc44-fix-include.patch17
2 files changed, 38 insertions, 13 deletions
diff --git a/abs/core/fcgi/PKGBUILD b/abs/core/fcgi/PKGBUILD
index e7cf3c5..242a270 100644
--- a/abs/core/fcgi/PKGBUILD
+++ b/abs/core/fcgi/PKGBUILD
@@ -1,27 +1,35 @@
-# $Id: PKGBUILD 12749 2008-09-19 13:48:16Z pierre $
+# $Id: PKGBUILD 87808 2010-08-18 10:56:40Z jgc $
# Maintainer: tobias <tobias@justdreams.de>
# Modified by: eliott <eliott@cactuswax.net>
# Original by Benjamin Andresen, klapmuetz [at] gmail [dot] com
pkgname=fcgi
pkgver=2.4.0
-pkgrel=5
+pkgrel=6
depends=('gcc-libs')
-pkgdesc="FASTCgi(fcgi) islanguage independent, high performant extension to CGI"
-arch=(i686 x86_64)
+pkgdesc="FASTCgi(fcgi) is language independent, high performance extension to CGI"
+arch=('i686' 'x86_64')
license=('custom')
-options=('!libtool')
+options=('!libtool' '!makeflags')
url="http://www.fastcgi.com"
-source=("http://www.fastcgi.com/dist/$pkgname-$pkgver.tar.gz" 'fcgi-configure.patch')
-md5sums=('d15060a813b91383a9f3c66faf84867e' '4312cdf8ee47c9f8a276e7d892a18ea6')
+source=(http://www.fastcgi.com/dist/${pkgname}-${pkgver}.tar.gz
+ gcc44-fix-include.patch)
+md5sums=('d15060a813b91383a9f3c66faf84867e'
+ 'a8028462163755f3ce457a5c641f237b')
build() {
- cd $startdir/src/$pkgname-$pkgver
- # fix from Debian: http://ftp.debian.org/debian/pool/main/libf/libfcgi/libfcgi_2.4.0-7.diff.gz
- patch -p1 -i ${srcdir}/fcgi-configure.patch || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/gcc44-fix-include.patch"
+ libtoolize --force
+ aclocal
+ autoconf
+ automake --foreign
./configure --prefix=/usr
make || return 1
- make DESTDIR=$startdir/pkg install || return 1
- install -Dm 644 LICENSE.TERMS \
- ${startdir}/pkg/usr/share/licenses/${pkgname}/LICENSE
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+ install -Dm644 LICENSE.TERMS "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/abs/core/fcgi/gcc44-fix-include.patch b/abs/core/fcgi/gcc44-fix-include.patch
new file mode 100644
index 0000000..7999e1b
--- /dev/null
+++ b/abs/core/fcgi/gcc44-fix-include.patch
@@ -0,0 +1,17 @@
+Author: Tatsuki Sugiura <sugi@nemui.org>
+Origin: vendor, http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=504963
+Bug-Debian: http://bugs.debian.org/504963
+Forwarded: no
+Last-Update: 2010-02-08
+
+Index: libfcgi/libfcgi/fcgio.cpp
+===================================================================
+--- libfcgi.orig/libfcgi/fcgio.cpp 2010-01-23 19:13:53.000000000 +0900
++++ libfcgi/libfcgi/fcgio.cpp 2010-01-23 19:13:55.000000000 +0900
+@@ -22,6 +22,7 @@
+ #define DLLAPI __declspec(dllexport)
+ #endif
+
++#include <cstdio>
+ #include <limits.h>
+ #include "fcgio.h"