summaryrefslogtreecommitdiffstats
path: root/abs/core/ffmpeg/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-07 14:13:22 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-07 14:13:22 (GMT)
commit04c0d379b9941e3aeb16707ff86f9c162d3efc7a (patch)
treef93e70b90ad09b417facc6187af3767eb57b3410 /abs/core/ffmpeg/PKGBUILD
parentc91a5da7886c10519be4370d232cd9275d515640 (diff)
downloadlinhes_pkgbuild-04c0d379b9941e3aeb16707ff86f9c162d3efc7a.zip
linhes_pkgbuild-04c0d379b9941e3aeb16707ff86f9c162d3efc7a.tar.gz
linhes_pkgbuild-04c0d379b9941e3aeb16707ff86f9c162d3efc7a.tar.bz2
ffmpeg: update to 2.7.2
Diffstat (limited to 'abs/core/ffmpeg/PKGBUILD')
-rw-r--r--abs/core/ffmpeg/PKGBUILD35
1 files changed, 21 insertions, 14 deletions
diff --git a/abs/core/ffmpeg/PKGBUILD b/abs/core/ffmpeg/PKGBUILD
index 115ddfb..38458a6 100644
--- a/abs/core/ffmpeg/PKGBUILD
+++ b/abs/core/ffmpeg/PKGBUILD
@@ -1,26 +1,34 @@
# $Id$
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=ffmpeg
-pkgver=2.4.3
-pkgrel=1
+pkgver=2.7.2
+pkgrel=2
epoch=1
-pkgdesc='Complete and free Internet live audio and video broadcasting solution'
+pkgdesc='Complete solution to record, convert and stream audio and video'
arch=('i686' 'x86_64')
url='http://ffmpeg.org/'
-license=('GPL')
+license=('GPL3')
depends=(
- 'alsa-lib' 'bzip2' 'fontconfig' 'gnutls' 'gsm' 'lame' 'libass' 'libvdpau'
- 'libbluray' 'libmodplug' 'libtheora' 'libva' 'libvorbis' 'libvpx'
- 'opencore-amr' 'openjpeg' 'opus' 'rtmpdump' 'schroedinger' 'sdl' 'speex'
- 'v4l-utils' 'libx264' 'xvidcore' 'zlib' 'x265' 'fribidi'
+ 'alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame' 'libass'
+ 'libbluray' 'libmodplug' 'libsoxr' 'libssh' 'libtheora'
+ 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg' 'opus'
+ 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+ 'libvorbis.so' 'libvorbisenc.so' 'libvpx.so' 'libx264.so' 'libx265.so'
+)
+makedepends=('hardening-wrapper' 'libvdpau' 'yasm')
+provides=(
+ 'libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so'
)
-makedepends=('libvdpau' 'yasm')
source=(http://ffmpeg.org/releases/$pkgname-$pkgver.tar.bz2{,.asc})
-md5sums=('8da635baff57d7ab704b1daca5a99b47'
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8') # ffmpeg-devel
+md5sums=('7eb2140bab9f0a8669b65b50c8e4cfb5'
'SKIP')
build() {
@@ -48,20 +56,19 @@ build() {
--enable-libopenjpeg \
--enable-libopus \
--disable-libpulse \
- --enable-librtmp \
--enable-libschroedinger \
+ --enable-libsoxr \
--enable-libspeex \
+ --enable-libssh \
--enable-libtheora \
--enable-libv4l2 \
--enable-libvorbis \
--enable-libvpx \
+ --enable-libwebp \
--enable-libx264 \
--enable-libx265 \
--enable-libxvid \
- --enable-runtime-cpudetect \
--enable-shared \
- --enable-swresample \
- --enable-vdpau \
--enable-version3 \
--enable-x11grab \