summaryrefslogtreecommitdiffstats
path: root/abs/core/ffmpeg/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-06-08 13:59:40 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-06-08 13:59:40 (GMT)
commit89f8528c17f96a0378a22c9d00e96bc6b01dda6c (patch)
tree8a113cb2fe486db2acaec9ed146707bee06f849b /abs/core/ffmpeg/PKGBUILD
parentd02478f01aa136755c16c516ef817f572a98430e (diff)
downloadlinhes_pkgbuild-89f8528c17f96a0378a22c9d00e96bc6b01dda6c.zip
linhes_pkgbuild-89f8528c17f96a0378a22c9d00e96bc6b01dda6c.tar.gz
linhes_pkgbuild-89f8528c17f96a0378a22c9d00e96bc6b01dda6c.tar.bz2
ffmpeg: update to 3.0.2
Diffstat (limited to 'abs/core/ffmpeg/PKGBUILD')
-rw-r--r--abs/core/ffmpeg/PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/abs/core/ffmpeg/PKGBUILD b/abs/core/ffmpeg/PKGBUILD
index 8f3e9d7..541249f 100644
--- a/abs/core/ffmpeg/PKGBUILD
+++ b/abs/core/ffmpeg/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=ffmpeg
-pkgver=2.8.5
+pkgver=3.0.2
pkgrel=2
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video'
@@ -14,9 +14,10 @@ arch=('i686' 'x86_64')
url='http://ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame'
- 'libass' 'libbluray' 'libmodplug' 'libsoxr' 'libssh'
- 'libtheora' 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg'
- 'opus' 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+ 'libass' 'libavc1394' 'libbluray' 'libiec61883' 'libmodplug'
+ 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau' 'libwebp'
+ 'netcdf' 'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex'
+ 'v4l-utils' 'xvidcore' 'zlib'
'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
'libvpx.so' 'libx264.so' 'libx265.so')
makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
@@ -26,7 +27,7 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libswscale.so')
source=(http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2{,.asc})
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
-sha256sums=('3b6d9951533323ee64a21d0aa7667a780b3470bfe4e0fb7c1b33307ce290615a'
+sha256sums=('30e3c77c2f4c358ed087869455a7496cbd7753a5e1b98d20ba49c1004009fd36'
'SKIP')
build() {
@@ -49,6 +50,7 @@ build() {
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \
+ --enable-libiec61883 \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
@@ -69,6 +71,7 @@ build() {
--enable-libx264 \
--enable-libx265 \
--enable-libxvid \
+ --enable-netcdf \
--enable-shared \
--enable-version3 \
--enable-x11grab