summaryrefslogtreecommitdiffstats
path: root/abs/core/ffmpeg/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-21 21:03:30 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-21 21:03:30 (GMT)
commite6a0ffcd96761ff1b705b283026114889cc891dc (patch)
treec9fbabb9279e4e12268d93b0f7347964dd858aae /abs/core/ffmpeg/PKGBUILD
parent7fb1a88facfc7f36f1d2731f3e772065689526d8 (diff)
downloadlinhes_pkgbuild-e6a0ffcd96761ff1b705b283026114889cc891dc.zip
linhes_pkgbuild-e6a0ffcd96761ff1b705b283026114889cc891dc.tar.gz
linhes_pkgbuild-e6a0ffcd96761ff1b705b283026114889cc891dc.tar.bz2
ffmpeg: update to 3.4.2
Diffstat (limited to 'abs/core/ffmpeg/PKGBUILD')
-rw-r--r--abs/core/ffmpeg/PKGBUILD41
1 files changed, 26 insertions, 15 deletions
diff --git a/abs/core/ffmpeg/PKGBUILD b/abs/core/ffmpeg/PKGBUILD
index 4e9be79..8e23c0f 100644
--- a/abs/core/ffmpeg/PKGBUILD
+++ b/abs/core/ffmpeg/PKGBUILD
@@ -6,30 +6,41 @@
# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=ffmpeg
-pkgver=3.2.2
+pkgver=3.4.2
pkgrel=2
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
'lame' 'libavc1394' 'libiec61883' 'libmodplug'
- 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau'
- 'libwebp' 'libx11' 'libxcb' 'opencore-amr' 'openjpeg2' 'opus'
- 'schroedinger' 'sdl2' 'speex' 'v4l-utils' 'xz' 'zlib'
- 'libass.so' 'libbluray.so' 'libfreetype.so' 'libnetcdf.so'
- 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
- 'libx264.so' 'libx265.so' 'libxvidcore.so')
-makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
+ 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
+ 'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
+ 'speex' 'v4l-utils' 'xz' 'zlib'
+ 'libomxil-bellagio'
+ 'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
+ 'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
+ 'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so')
+makedepends=('ladspa' 'libvdpau' 'yasm')
optdepends=('ladspa: LADSPA filters')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
'libswscale.so')
-source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc})
+source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
+ 'fs56089.patch')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
-sha256sums=('3f01bd1fe1a17a277f8c84869e5d9192b4b978cb660872aa2b54c3cc8a2fedfc'
- 'SKIP')
+sha256sums=('2b92e9578ef8b3e49eeab229e69305f5f4cbc1fdaa22e927fc7fca18acccd740'
+ 'SKIP'
+ '0bfcd12d1992903f21c146ae56d9ad89b52818cfb2303197ee905347c25a5427')
+
+prepare() {
+ cd ffmpeg-${pkgver}
+
+ # https://bugs.archlinux.org/task/56089
+ # Backport of http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=a606f27f4c610708fa96e35eed7b7537d3d8f712
+ patch -Np1 -i ../fs56089.patch
+}
build() {
cd ffmpeg-${pkgver}
@@ -59,7 +70,6 @@ build() {
--enable-libopenjpeg \
--enable-libopus \
--disable-libpulse \
- --enable-libschroedinger \
--enable-libsoxr \
--enable-libspeex \
--enable-libssh \
@@ -71,11 +81,12 @@ build() {
--enable-libwebp \
--enable-libx264 \
--enable-libx265 \
+ --enable-libxcb \
+ --enable-libxml2 \
--enable-libxvid \
- --enable-netcdf \
--enable-shared \
--enable-version3 \
- --enable-x11grab
+ --enable-omx
make
make tools/qt-faststart