summaryrefslogtreecommitdiffstats
path: root/abs/core/filesystem/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-09 19:47:51 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-09 19:47:51 (GMT)
commit19ebf7c8c7ccdde7f0e2ee779f56b57d596df5fd (patch)
treebd7eb9601d071e45ef187a5f7fc7238e65838592 /abs/core/filesystem/PKGBUILD
parent50895f38e1d64e9ea39558f6aab60dc6f5fbbea8 (diff)
downloadlinhes_pkgbuild-19ebf7c8c7ccdde7f0e2ee779f56b57d596df5fd.zip
linhes_pkgbuild-19ebf7c8c7ccdde7f0e2ee779f56b57d596df5fd.tar.gz
linhes_pkgbuild-19ebf7c8c7ccdde7f0e2ee779f56b57d596df5fd.tar.bz2
filesystem: update to 2015.02
Diffstat (limited to 'abs/core/filesystem/PKGBUILD')
-rw-r--r--abs/core/filesystem/PKGBUILD71
1 files changed, 50 insertions, 21 deletions
diff --git a/abs/core/filesystem/PKGBUILD b/abs/core/filesystem/PKGBUILD
index 7b0ca08..0dec23d 100644
--- a/abs/core/filesystem/PKGBUILD
+++ b/abs/core/filesystem/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 187026 2013-06-03 11:15:07Z allan $
+# $Id$
# Maintainer: Tom Gundersen <teg@jklm.no>
pkgname=filesystem
-pkgver=2013.05
-pkgrel=4
+pkgver=2015.02
+pkgrel=1
pkgdesc='Base filesystem'
arch=('i686' 'x86_64')
license=('GPL')
@@ -20,8 +20,36 @@ source=('group' 'issue' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first' 'archlinux.7.txt'
'locale.sh')
+lint() {
+ # ensure that passwd is sync'd to shadow and group is sync'd to gshadow.
+ local r=0
+
+ local passwd shadow group gshadow
+
+ for f in passwd shadow group gshadow; do
+ mapfile -t "$f" < <(cut -d: -f1 "$f" | sort)
+ done
+
+ # we can cheat and do simple string comparison only because we can make some
+ # assumptions about the data in these files
+ if [[ ${passwd[*]} != "${shadow[*]}" ]]; then
+ error 'passwd is not in sync with shadow!'
+ r=1
+ fi
+
+ if [[ ${group[*]} != "${gshadow[*]}" ]]; then
+ error 'group is not in sync with gshadow!'
+ r=1
+ fi
+
+ return $r
+}
+
build() {
cd ${srcdir}
+
+ lint
+
a2x -d manpage -f manpage archlinux.7.txt
}
@@ -43,7 +71,7 @@ package() {
# setup /etc
install -d etc/{ld.so.conf.d,skel,profile.d}
- for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
+ for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf passwd resolv.conf securetty shells profile; do
install -m644 ${srcdir}/${f} etc/
done
ln -s /proc/self/mounts etc/mtab
@@ -53,9 +81,10 @@ package() {
touch etc/arch-release
install -D -m644 ${srcdir}/modprobe.d.usb-load-ehci-first usr/lib/modprobe.d/usb-load-ehci-first.conf
install -m755 ${srcdir}/locale.sh etc/profile.d/locale.sh
+ install -Dm644 "$srcdir"/os-release "$pkgdir"/usr/lib/os-release
# setup /var
- for d in cache/man local opt log/old lib/misc empty; do
+ for d in cache local opt log/old lib/misc empty; do
install -d -m755 var/${d}
done
install -d -m1777 var/{tmp,spool/mail}
@@ -65,9 +94,9 @@ package() {
ln -s ../run var/run
ln -s ../run/lock var/lock
-
- #setup /usr hierarchy
-
+ #
+ # setup /usr hierarchy
+ #
for d in bin include lib share/misc src; do
install -d -m755 usr/${d}
done
@@ -79,17 +108,17 @@ package() {
# add lib symlinks
#
ln -s usr/lib ${pkgdir}/lib
- [[ ${CARCH} = "x86_64" ]] && (
+ [[ ${CARCH} = "x86_64" ]] && (
ln -s usr/lib ${pkgdir}/lib64
ln -s lib ${pkgdir}/usr/lib64
)
-# #
-# # add bin symlinks
-# #
- ln -s usr/bin ${pkgdir}/bin
- ln -s usr/bin ${pkgdir}/sbin
- ln -s bin ${pkgdir}/usr/sbin
+ #
+ # add bin symlinks
+ #
+ ln -s usr/bin ${pkgdir}/bin
+ ln -s usr/bin ${pkgdir}/sbin
+ ln -s bin ${pkgdir}/usr/sbin
#
# install archlinux(7) manpage
@@ -104,23 +133,23 @@ package() {
done
ln -s ../man usr/local/share/man
}
-md5sums=('7b8e40f8f793e60f471511641bb1c9f2'
+md5sums=('4d7417d2bf8872665c0907f09ae37c34'
'7813c481156f6b280a3ba91fc6236368'
'9e4533df61f0c82d6b2e2371f7376282'
'4c4540eeb748bf1f71d631b8c1dcf0b3'
'f28150d4c0b22a017be51b9f7f9977ed'
'6e488ffecc8ba142c0cf7e2d7aeb832e'
- '1cfd310dff0804a7d21958487c32a3b1'
- '2ef2429c2c98d0883906aa6f5363be80'
+ 'a998d1e6c7cc5791a7f4a2b49b2d10ce'
+ '1ec1b16e2a71fad63ab8f147069a5d97'
'693c97f2c9a519bb97a17008e92c2b74'
- '1745349eb24ed21b4cfaa6f423bddb76'
+ 'f0a5071f50d8864d2810c44e23eb00cc'
'7bc65f234dfb6abf24e7c3b03e86f4ff'
'd41d8cd98f00b204e9800998ecf8427e'
'3d96b9f0f4ea7b583261682a20283c46'
'6f48288b6fcaf0065fcb7b0e525413e0'
'22518e922891f9359f971f4f5b4e793c'
- 'f45389e116ab0b9e9968287617d27c7d'
+ '69e460404f45bdb7288d1de662e56dd9'
'0b6f835598c7640184e476057b3c7722'
'a8a962370cd0128465d514e6a1f74130'
'2e193c4a37245f2323ebe87f1a673563'
- '3807d07215d9116331fe1cf8feeaa0f8')
+ '71ed98c52e11ada1f936ac8cb14eecd9')