summaryrefslogtreecommitdiffstats
path: root/abs/core/filesystem/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-17 00:08:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:05 (GMT)
commit48c7caf0470b8693b849ac13454fdac4a697e812 (patch)
tree6460c8274cfdf4219846d0637d2509c5ae94c7fd /abs/core/filesystem/PKGBUILD
parentd8b6c41b41644281729f379050b63700a11cceab (diff)
downloadlinhes_pkgbuild-48c7caf0470b8693b849ac13454fdac4a697e812.zip
linhes_pkgbuild-48c7caf0470b8693b849ac13454fdac4a697e812.tar.gz
linhes_pkgbuild-48c7caf0470b8693b849ac13454fdac4a697e812.tar.bz2
filesystem: 2013_05
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/core/filesystem/PKGBUILD')
-rw-r--r--abs/core/filesystem/PKGBUILD61
1 files changed, 39 insertions, 22 deletions
diff --git a/abs/core/filesystem/PKGBUILD b/abs/core/filesystem/PKGBUILD
index 1bce61a..ad62704 100644
--- a/abs/core/filesystem/PKGBUILD
+++ b/abs/core/filesystem/PKGBUILD
@@ -1,24 +1,24 @@
-# $Id: PKGBUILD 169662 2012-10-25 10:06:29Z tomegun $
+# $Id: PKGBUILD 187026 2013-06-03 11:15:07Z allan $
# Maintainer: Tom Gundersen <teg@jklm.no>
pkgname=filesystem
-pkgver=2012.10
-pkgrel=2
+pkgver=2013.05
+pkgrel=3
pkgdesc='Base filesystem'
-arch=('any')
+arch=('i686' 'x86_64')
license=('GPL')
url='http://www.archlinux.org'
groups=('base')
install='filesystem.install'
makedepends=('asciidoc')
-depends=('iana-etc' 'bash' 'coreutils' 'nss-myhostname')
+depends=('iana-etc')
backup=('etc/fstab' 'etc/crypttab' 'etc/group' 'etc/hosts' 'etc/ld.so.conf' 'etc/passwd'
'etc/shadow' 'etc/gshadow' 'etc/resolv.conf' 'etc/motd' 'etc/nsswitch.conf'
'etc/shells' 'etc/host.conf' 'etc/securetty' 'etc/profile' 'etc/issue')
-source=('group' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
+source=('group' 'issue' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
'passwd' 'shadow' 'fstab' 'crypttab' 'hosts' 'motd' 'os-release' 'resolv.conf'
'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first' 'archlinux.7.txt'
- 'locale.sh')
+ 'locale.sh')
build() {
cd ${srcdir}
@@ -31,7 +31,7 @@ package() {
#
# setup root filesystem
#
- for d in boot dev etc home media mnt usr var opt srv/http run; do
+ for d in boot dev etc home mnt usr var opt srv/http run; do
install -d -m755 ${d}
done
install -d -m555 proc
@@ -43,7 +43,7 @@ package() {
# setup /etc
install -d etc/{ld.so.conf.d,skel,profile.d}
- for f in fstab group host.conf hosts ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
+ for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
install -m644 ${srcdir}/${f} etc/
done
ln -s /proc/self/mounts etc/mtab
@@ -65,10 +65,10 @@ package() {
ln -s ../run var/run
ln -s ../run/lock var/lock
- #
- # setup /usr hierarchy
- #
- for d in bin include lib sbin share/misc src; do
+
+ #setup /usr hierarchy
+
+ for d in bin include lib share/misc src; do
install -d -m755 usr/${d}
done
for d in $(seq 8); do
@@ -76,6 +76,22 @@ package() {
done
#
+ # add lib symlinks
+ #
+ ln -s usr/lib ${pkgdir}/lib
+ [[ ${CARCH} = "x86_64" ]] && (
+ ln -s usr/lib ${pkgdir}/lib64
+ ln -s lib ${pkgdir}/usr/lib64
+ )
+
+# #
+# # add bin symlinks
+# #
+ ln -s usr/bin ${pkgdir}/bin
+ ln -s usr/bin ${pkgdir}/sbin
+ ln -s bin ${pkgdir}/usr/sbin
+
+ #
# install archlinux(7) manpage
#
install -D -m644 ${srcdir}/archlinux.7 usr/share/man/man7/archlinux.7
@@ -88,22 +104,23 @@ package() {
done
ln -s ../man usr/local/share/man
}
-md5sums=('004013ac940ef3d3cdd8c596e7accfe1'
+md5sums=('7b8e40f8f793e60f471511641bb1c9f2'
+ '7813c481156f6b280a3ba91fc6236368'
'9e4533df61f0c82d6b2e2371f7376282'
- 'f833071f3b4c1e1033770c0ef30da0a4'
+ '4c4540eeb748bf1f71d631b8c1dcf0b3'
'f28150d4c0b22a017be51b9f7f9977ed'
'6e488ffecc8ba142c0cf7e2d7aeb832e'
- '455b78cada80f40b6f6968f5cbd97a2e'
- '01249bb0ba4468f95e2cc3a627f5e6e3'
- 'ca716f853860199c1286e7939b2f2666'
+ '1cfd310dff0804a7d21958487c32a3b1'
+ '2ef2429c2c98d0883906aa6f5363be80'
+ '693c97f2c9a519bb97a17008e92c2b74'
'1745349eb24ed21b4cfaa6f423bddb76'
'7bc65f234dfb6abf24e7c3b03e86f4ff'
'd41d8cd98f00b204e9800998ecf8427e'
- 'c1e795aa3bae70bf0fb76b8a720e4825'
+ 'b16a4674ccf3a932ff34c6c8393a4f33'
'6f48288b6fcaf0065fcb7b0e525413e0'
'22518e922891f9359f971f4f5b4e793c'
- '677523dbe94b79299aa91b35ed8203b6'
- 'f3b6ae7db8adffaaa4bffc6099dcbd50'
+ 'f45389e116ab0b9e9968287617d27c7d'
+ '0b6f835598c7640184e476057b3c7722'
'a8a962370cd0128465d514e6a1f74130'
- 'f339bbc45ff3ad4dd73039beab2f28e3'
+ '2e193c4a37245f2323ebe87f1a673563'
'3807d07215d9116331fe1cf8feeaa0f8')