summaryrefslogtreecommitdiffstats
path: root/abs/core/filesystem/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-07 15:06:59 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-07 15:06:59 (GMT)
commitb05c6f777dde33dc0dde24ac461b5e4b8ed4f466 (patch)
tree27c3c2eade503db3b4d429e19694da7df141a88a /abs/core/filesystem/PKGBUILD
parenta091721d6178ffaa83ee445a5908419a39fdaba0 (diff)
downloadlinhes_pkgbuild-b05c6f777dde33dc0dde24ac461b5e4b8ed4f466.zip
linhes_pkgbuild-b05c6f777dde33dc0dde24ac461b5e4b8ed4f466.tar.gz
linhes_pkgbuild-b05c6f777dde33dc0dde24ac461b5e4b8ed4f466.tar.bz2
filesystem: 2012.10
Diffstat (limited to 'abs/core/filesystem/PKGBUILD')
-rw-r--r--abs/core/filesystem/PKGBUILD43
1 files changed, 28 insertions, 15 deletions
diff --git a/abs/core/filesystem/PKGBUILD b/abs/core/filesystem/PKGBUILD
index e0e0497..1bce61a 100644
--- a/abs/core/filesystem/PKGBUILD
+++ b/abs/core/filesystem/PKGBUILD
@@ -1,22 +1,29 @@
-# $Id: PKGBUILD 163828 2012-07-20 23:48:47Z tomegun $
+# $Id: PKGBUILD 169662 2012-10-25 10:06:29Z tomegun $
# Maintainer: Tom Gundersen <teg@jklm.no>
pkgname=filesystem
-pkgver=2012.7
-pkgrel=1
+pkgver=2012.10
+pkgrel=2
pkgdesc='Base filesystem'
arch=('any')
license=('GPL')
url='http://www.archlinux.org'
groups=('base')
install='filesystem.install'
-depends=('iana-etc' 'bash' 'coreutils')
+makedepends=('asciidoc')
+depends=('iana-etc' 'bash' 'coreutils' 'nss-myhostname')
backup=('etc/fstab' 'etc/crypttab' 'etc/group' 'etc/hosts' 'etc/ld.so.conf' 'etc/passwd'
'etc/shadow' 'etc/gshadow' 'etc/resolv.conf' 'etc/motd' 'etc/nsswitch.conf'
'etc/shells' 'etc/host.conf' 'etc/securetty' 'etc/profile' 'etc/issue')
-source=('group' 'issue' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
+source=('group' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
'passwd' 'shadow' 'fstab' 'crypttab' 'hosts' 'motd' 'os-release' 'resolv.conf'
- 'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first')
+ 'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first' 'archlinux.7.txt'
+ 'locale.sh')
+
+build() {
+ cd ${srcdir}
+ a2x -d manpage -f manpage archlinux.7.txt
+}
package() {
cd ${pkgdir}
@@ -36,7 +43,7 @@ package() {
# setup /etc
install -d etc/{ld.so.conf.d,skel,profile.d}
- for f in fstab group host.conf hosts ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
+ for f in fstab group host.conf hosts ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
install -m644 ${srcdir}/${f} etc/
done
ln -s /proc/self/mounts etc/mtab
@@ -45,6 +52,7 @@ package() {
done
touch etc/arch-release
install -D -m644 ${srcdir}/modprobe.d.usb-load-ehci-first usr/lib/modprobe.d/usb-load-ehci-first.conf
+ install -m755 ${srcdir}/locale.sh etc/profile.d/locale.sh
# setup /var
for d in cache/man local opt log/old lib/misc empty; do
@@ -67,6 +75,10 @@ package() {
install -d -m755 usr/share/man/man${d}
done
+ #
+ # install archlinux(7) manpage
+ #
+ install -D -m644 ${srcdir}/archlinux.7 usr/share/man/man7/archlinux.7
#
# setup /usr/local hierarchy
@@ -76,21 +88,22 @@ package() {
done
ln -s ../man usr/local/share/man
}
-md5sums=('45940618da782cc391c59f88ab3333c3'
- 'b153cc716cd73e8ec17bc27fa127d052'
- '13753e4e0964f3652b0cc60a28528bdf'
+md5sums=('004013ac940ef3d3cdd8c596e7accfe1'
+ '9e4533df61f0c82d6b2e2371f7376282'
'f833071f3b4c1e1033770c0ef30da0a4'
'f28150d4c0b22a017be51b9f7f9977ed'
'6e488ffecc8ba142c0cf7e2d7aeb832e'
- '8a9042a2cedf6b6b47eb8973f14289cb'
- 'b8355d9d2782f424f4cedcf682651be0'
+ '455b78cada80f40b6f6968f5cbd97a2e'
+ '01249bb0ba4468f95e2cc3a627f5e6e3'
'ca716f853860199c1286e7939b2f2666'
- 'e5d8323a4dbee7a6d0d2a19cbf4b819f'
+ '1745349eb24ed21b4cfaa6f423bddb76'
'7bc65f234dfb6abf24e7c3b03e86f4ff'
'd41d8cd98f00b204e9800998ecf8427e'
'c1e795aa3bae70bf0fb76b8a720e4825'
'6f48288b6fcaf0065fcb7b0e525413e0'
'22518e922891f9359f971f4f5b4e793c'
- 'f95416882cef800edef08382a1176b7d'
+ '677523dbe94b79299aa91b35ed8203b6'
'f3b6ae7db8adffaaa4bffc6099dcbd50'
- 'a8a962370cd0128465d514e6a1f74130')
+ 'a8a962370cd0128465d514e6a1f74130'
+ 'f339bbc45ff3ad4dd73039beab2f28e3'
+ '3807d07215d9116331fe1cf8feeaa0f8')