summaryrefslogtreecommitdiffstats
path: root/abs/core/filesystem
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/filesystem
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/filesystem')
-rw-r--r--abs/core/filesystem/PKGBUILD56
-rw-r--r--abs/core/filesystem/filesystem.install8
-rw-r--r--abs/core/filesystem/fstab3
-rw-r--r--abs/core/filesystem/group1
-rw-r--r--abs/core/filesystem/modprobe.d.usb-load-ehci-first2
-rw-r--r--abs/core/filesystem/profile4
6 files changed, 46 insertions, 28 deletions
diff --git a/abs/core/filesystem/PKGBUILD b/abs/core/filesystem/PKGBUILD
index 4dee201..02649c3 100644
--- a/abs/core/filesystem/PKGBUILD
+++ b/abs/core/filesystem/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 4675 2008-07-08 19:16:06Z pierre $
+# $Id: PKGBUILD 23639 2009-01-11 14:36:30Z thomas $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=filesystem
-pkgver=2008.07
-pkgrel=10
+pkgver=2009.01
+pkgrel=2
pkgdesc="Base filesystem"
arch=(i686 x86_64)
license=('GPL')
@@ -12,12 +12,31 @@ url="http://www.archlinux.org"
groups=('base')
install=filesystem.install
#depends=('sh' 'coreutils')
-backup=(etc/fstab etc/crypttab etc/group etc/hosts etc/ld.so.conf etc/passwd \
- etc/shadow etc/gshadow etc/resolv.conf etc/motd etc/nsswitch.conf \
+backup=(etc/fstab etc/crypttab etc/group etc/hosts etc/ld.so.conf etc/passwd
+ etc/shadow etc/gshadow etc/resolv.conf etc/motd etc/nsswitch.conf
etc/shells etc/host.conf etc/securetty etc/profile etc/issue)
-source=(group issue nsswitch.conf securetty host.conf ld.so.conf \
- passwd shadow fstab crypttab hosts motd resolv.conf shells \
- gshadow services protocols profile)
+source=(group issue nsswitch.conf securetty host.conf ld.so.conf
+ passwd shadow fstab crypttab hosts motd resolv.conf shells
+ gshadow services protocols profile modprobe.d.usb-load-ehci-first)
+md5sums=('f4cf8d0a2de2658165148d5f64d81675'
+ '1bdc5dba66947d74866a5df8ce9ef3b1'
+ '775464ba7588b4976e0c2a02b83123f4'
+ '655071da46d2ac03e0fb8a071bf193ea'
+ 'f28150d4c0b22a017be51b9f7f9977ed'
+ '2c24792d97ef3cf0d73b60d4c429730b'
+ '8a9042a2cedf6b6b47eb8973f14289cb'
+ '019e5c24f9befef395a28e7ef2e4e5b9'
+ 'c4f23a66a1bcc08fd164639bdafbc60a'
+ 'e5d8323a4dbee7a6d0d2a19cbf4b819f'
+ '81b3cb42a6ddabc2ed2310511ee9c859'
+ 'd41d8cd98f00b204e9800998ecf8427e'
+ '6f48288b6fcaf0065fcb7b0e525413e0'
+ '40dac0de4c6b99c8ca97effbd7527c84'
+ 'ab9c2a40eba287b2918589ab8e0b2fbf'
+ 'f436d2e0ed02b7b73bd10c6693e95ac3'
+ '65d78e621ed69eed69f854c3ee2e5942'
+ '288a2e8d63c5ea2c2d852c7147e59d28'
+ '8098ffd9fbf890468d3198277596b85a')
build()
{
@@ -69,22 +88,7 @@ build()
# re-add /etc/arch-release, some software uses it
# to check whether arch is running
touch $startdir/pkg/etc/arch-release
+
+ # Add /etc/modprobe.d/
+ install -D -m644 ${srcdir}/modprobe.d.usb-load-ehci-first ${pkgdir}/etc/modprobe.d/usb-load-ehci-first
}
-md5sums=('f64f86c4a6356961b69ead0471294145'
- '1bdc5dba66947d74866a5df8ce9ef3b1'
- '775464ba7588b4976e0c2a02b83123f4'
- '655071da46d2ac03e0fb8a071bf193ea'
- 'f28150d4c0b22a017be51b9f7f9977ed'
- '2c24792d97ef3cf0d73b60d4c429730b'
- '8a9042a2cedf6b6b47eb8973f14289cb'
- '019e5c24f9befef395a28e7ef2e4e5b9'
- '4e2f238bae5cbf716ff73c9404404269'
- 'e5d8323a4dbee7a6d0d2a19cbf4b819f'
- '81b3cb42a6ddabc2ed2310511ee9c859'
- 'd41d8cd98f00b204e9800998ecf8427e'
- '6f48288b6fcaf0065fcb7b0e525413e0'
- '40dac0de4c6b99c8ca97effbd7527c84'
- 'ab9c2a40eba287b2918589ab8e0b2fbf'
- 'f436d2e0ed02b7b73bd10c6693e95ac3'
- '65d78e621ed69eed69f854c3ee2e5942'
- 'f2a88eacb5c37201368c916d9e594440')
diff --git a/abs/core/filesystem/filesystem.install b/abs/core/filesystem/filesystem.install
index 92b336f..5be51ed 100644
--- a/abs/core/filesystem/filesystem.install
+++ b/abs/core/filesystem/filesystem.install
@@ -57,4 +57,12 @@ post_upgrade() {
echo "adding new group: scanner"
usr/sbin/groupadd -g 96 scanner >/dev/null
fi
+ cp /etc/fstab /etc/fstab.orig
+ if grep -q /dev/sro /etc/fstab
+ then
+ exit
+ else
+ grep -v /dev/dvd /etc/fstab > /tmp/fstab
+ cat /tmp/fstab | sed -e 's|/dev/cdrom|/dev/sr0|g' > /etc/fstab
+ fi
}
diff --git a/abs/core/filesystem/fstab b/abs/core/filesystem/fstab
index a609a32..c3a01cb 100644
--- a/abs/core/filesystem/fstab
+++ b/abs/core/filesystem/fstab
@@ -5,7 +5,6 @@
none /dev/pts devpts defaults 0 0
none /dev/shm tmpfs defaults 0 0
-/dev/cdrom /media/cd auto ro,user,noauto,unhide 0 0
-/dev/dvd /media/dvd auto ro,user,noauto,unhide 0 0
+/dev/sr0 /media/cd auto ro,user,noauto,unhide 0 0
/dev/fd0 /media/fl auto user,noauto 0 0
diff --git a/abs/core/filesystem/group b/abs/core/filesystem/group
index f0d4712..a34b83f 100644
--- a/abs/core/filesystem/group
+++ b/abs/core/filesystem/group
@@ -13,6 +13,7 @@ ftp::11:
mail::12:
uucp::14:
log::19:root
+locate::21:
smmsp::25:
http::33:
games::50:
diff --git a/abs/core/filesystem/modprobe.d.usb-load-ehci-first b/abs/core/filesystem/modprobe.d.usb-load-ehci-first
new file mode 100644
index 0000000..3b5db0e
--- /dev/null
+++ b/abs/core/filesystem/modprobe.d.usb-load-ehci-first
@@ -0,0 +1,2 @@
+install ohci_hcd /sbin/modprobe ehci_hcd ; /sbin/modprobe --ignore-install ohci_hcd $CMDLINE_OPTS
+install uhci_hcd /sbin/modprobe ehci_hcd ; /sbin/modprobe --ignore-install uhci_hcd $CMDLINE_OPTS
diff --git a/abs/core/filesystem/profile b/abs/core/filesystem/profile
index d18b99a..5eabf8e 100644
--- a/abs/core/filesystem/profile
+++ b/abs/core/filesystem/profile
@@ -32,6 +32,10 @@ umask 022
PATH="/bin:/usr/bin:/sbin:/usr/sbin"
export PATH
+# Export default pkg-config path
+PKG_CONFIG_PATH="/usr/lib/pkgconfig"
+export PKG_CONFIG_PATH
+
# Some readline stuff that is fairly common
HISTSIZE=1000
HISTCONTROL="erasedups"