summaryrefslogtreecommitdiffstats
path: root/abs/core/flex
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/flex
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/flex')
-rw-r--r--abs/core/flex/PKGBUILD30
-rw-r--r--abs/core/flex/flex-yytext.patch22
-rw-r--r--abs/core/flex/lex.sh3
3 files changed, 55 insertions, 0 deletions
diff --git a/abs/core/flex/PKGBUILD b/abs/core/flex/PKGBUILD
new file mode 100644
index 0000000..f36300f
--- /dev/null
+++ b/abs/core/flex/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 3606 2008-06-26 00:29:52Z paul $
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=flex
+pkgver=2.5.35
+pkgrel=1
+pkgdesc="A tool for generating text-scanning programs"
+arch=(i686 x86_64)
+url="http://flex.sourceforge.net"
+license=('custom')
+groups=('base-devel')
+depends=('glibc' 'sh')
+source=(http://downloads.sourceforge.net/sourceforge/flex/flex-$pkgver.tar.bz2
+ lex.sh)
+md5sums=('10714e50cea54dc7a227e3eddcd44d57' 'f725259ec23a9e87ee29e2ef82eda9a5')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver || return 1
+
+ # configure
+ ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+
+ # build and install
+ make || return 1
+ make prefix=$startdir/pkg/usr mandir=$startdir/pkg/usr/share/man install || return 1
+ install -D -m755 $startdir/src/lex.sh $startdir/pkg/usr/bin/lex || return 1
+
+ # install license
+ install -D -m644 COPYING \
+ $startdir/pkg/usr/share/licenses/$pkgname/license.txt || return 1
+}
diff --git a/abs/core/flex/flex-yytext.patch b/abs/core/flex/flex-yytext.patch
new file mode 100644
index 0000000..27cfaa4
--- /dev/null
+++ b/abs/core/flex/flex-yytext.patch
@@ -0,0 +1,22 @@
+diff -Naur flex-2.5.31-orig/flex.skl flex-2.5.31/flex.skl
+--- flex-2.5.31-orig/flex.skl 2003-03-31 17:51:38.000000000 -0800
++++ flex-2.5.31/flex.skl 2004-04-11 12:19:10.000000000 -0700
+@@ -3280,7 +3280,6 @@
+ #undef yy_set_bol
+ #undef yy_new_buffer
+ #undef yy_set_interactive
+-#undef yytext_ptr
+ #undef YY_DO_BEFORE_ACTION
+
+ #ifdef YY_DECL_IS_OURS
+diff -Naur flex-2.5.31-orig/gen.c flex-2.5.31/gen.c
+--- flex-2.5.31-orig/gen.c 2003-03-30 11:58:44.000000000 -0800
++++ flex-2.5.31/gen.c 2004-04-11 12:19:38.000000000 -0700
+@@ -1812,7 +1812,6 @@
+ if (yytext_is_array) {
+ if (!reentrant){
+ indent_puts ("static int yy_more_offset = 0;");
+- }else{
+ indent_puts ("static int yy_prev_more_offset = 0;");
+ }
+ }
diff --git a/abs/core/flex/lex.sh b/abs/core/flex/lex.sh
new file mode 100644
index 0000000..13e7de6
--- /dev/null
+++ b/abs/core/flex/lex.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/bin/flex -l "$@"