summaryrefslogtreecommitdiffstats
path: root/abs/core/fluxbox/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-09 15:49:19 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-09 15:49:19 (GMT)
commitf44ed8385a015ec5ba348026cc0577554ec74647 (patch)
tree3e4c3be0e3678aa77c662d9729e8debc9b3b3e0a /abs/core/fluxbox/PKGBUILD
parent4b64b958d5a908750cd701729d45598d7a5497bd (diff)
downloadlinhes_pkgbuild-f44ed8385a015ec5ba348026cc0577554ec74647.zip
linhes_pkgbuild-f44ed8385a015ec5ba348026cc0577554ec74647.tar.gz
linhes_pkgbuild-f44ed8385a015ec5ba348026cc0577554ec74647.tar.bz2
fluxbox: 1.3.2
note 1.3.1 doesn't compile on 64 bit
Diffstat (limited to 'abs/core/fluxbox/PKGBUILD')
-rw-r--r--abs/core/fluxbox/PKGBUILD27
1 files changed, 9 insertions, 18 deletions
diff --git a/abs/core/fluxbox/PKGBUILD b/abs/core/fluxbox/PKGBUILD
index abe2c8a..45db54a 100644
--- a/abs/core/fluxbox/PKGBUILD
+++ b/abs/core/fluxbox/PKGBUILD
@@ -1,29 +1,25 @@
-# $Id$
+# $Id: PKGBUILD 141366 2011-10-30 03:08:02Z eric $
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=fluxbox
-pkgver=1.3.1
-pkgrel=7
+pkgver=1.3.2
+pkgrel=1
pkgdesc="A lightweight and highly-configurable window manager"
arch=('i686' 'x86_64')
url="http://www.fluxbox.org"
license=('MIT')
-depends=('libxft' 'libxpm' 'libxinerama' 'libxrandr' 'gcc-libs' 'sh' 'imlib2' 'fribidi'
-'LinHES-system>=2-52')
-makedepends=('pkg-config')
+depends=('libxft' 'libxpm' 'libxinerama' 'libxrandr' 'gcc-libs' 'imlib2' 'fribidi')
optdepends=('xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu utilities')
options=('!makeflags')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2 \
- fluxbox.desktop keys fluxbox_fullscreen_focus.patch)
-#install=fluxbox.install
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz \
+ fluxbox.desktop)
+sha1sums=('15ba1b9eaaf170d87fa647b7118a63c05f093b5c'
+ 'f3f83b8ce84d79c2f8670ef687e0dd89ab0552b8')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- echo "Patching fluxbox"
- patch -p0 < $srcdir/fluxbox_fullscreen_focus.patch || return 1
- echo "Building fluxbox"
./configure --prefix=/usr \
- --enable-gnome --enable-xft --enable-xinerama \
+ --enable-xft --enable-xinerama \
--enable-imlib2 --enable-nls
make
}
@@ -32,10 +28,5 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -D -m644 ../fluxbox.desktop "${pkgdir}/usr/share/xsessions/fluxbox.desktop"
- install -D -m644 ../keys ${pkgdir}/usr/share/$pkgname/keys || return 1
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-md5sums=('0eaa940a69c0a876a520bb85d67b8bec'
- 'eeae9c88a2526ac0bd8afcd9ce97f9ed'
- 'c6d548dbefd76bad117db23bdf927bcd'
- '7d2fff845c9f951e925b9adcd1053242')