summaryrefslogtreecommitdiffstats
path: root/abs/core/fluxbox
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-02-23 04:40:13 (GMT)
committerCecil <knoppmyth@gmail.com>2011-02-23 04:40:13 (GMT)
commitdb0a627f2aaab6bbd5eb4d7f4ee9f5b19309a2cb (patch)
tree424b3beb7c24b073376f1cac335c2d6751393d07 /abs/core/fluxbox
parentc37b11f27037ffa7585f0ce8386d3b5c818f708e (diff)
downloadlinhes_pkgbuild-db0a627f2aaab6bbd5eb4d7f4ee9f5b19309a2cb.zip
linhes_pkgbuild-db0a627f2aaab6bbd5eb4d7f4ee9f5b19309a2cb.tar.gz
linhes_pkgbuild-db0a627f2aaab6bbd5eb4d7f4ee9f5b19309a2cb.tar.bz2
fluxbox:bumped to latest.
Diffstat (limited to 'abs/core/fluxbox')
-rw-r--r--abs/core/fluxbox/ChangeLog10
-rw-r--r--abs/core/fluxbox/PKGBUILD46
-rw-r--r--abs/core/fluxbox/__changelog1
-rw-r--r--abs/core/fluxbox/fluxbox-1.0.0-gcc43.patch10
-rw-r--r--abs/core/fluxbox/fluxbox_fullscreen_focus.patch12
5 files changed, 23 insertions, 56 deletions
diff --git a/abs/core/fluxbox/ChangeLog b/abs/core/fluxbox/ChangeLog
deleted file mode 100644
index f2f2e81..0000000
--- a/abs/core/fluxbox/ChangeLog
+++ /dev/null
@@ -1,10 +0,0 @@
-2008-09-19 Eric Belanger <eric@archlinux.org>
-
- * fluxbox 1.1.1-1
- * Upstream update
-
-2008-09-05 Eric Belanger <eric@archlinux.org>
-
- * fluxbox 1.1.0.1-1
- * Upstream update
- * Added ChangeLog
diff --git a/abs/core/fluxbox/PKGBUILD b/abs/core/fluxbox/PKGBUILD
index 3873ff1..2f96e1e 100644
--- a/abs/core/fluxbox/PKGBUILD
+++ b/abs/core/fluxbox/PKGBUILD
@@ -1,37 +1,35 @@
-# $Id: PKGBUILD 12779 2008-09-20 06:42:07Z eric $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: John Proctor <jproctor@prium.net>
+# $Id: PKGBUILD 110541 2011-02-19 21:51:38Z eric $
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=fluxbox
-pkgver=1.1.1
-pkgrel=11
+pkgver=1.3.0
+pkgrel=2
pkgdesc="A lightweight and highly-configurable window manager"
arch=('i686' 'x86_64')
url="http://www.fluxbox.org"
license=('MIT')
-depends=('libxft' 'libxpm' 'libxinerama' 'libxrandr' 'gcc-libs' 'bash' 'imlib2')
-makedepends=('pkgconfig')
+depends=('libxft' 'libxpm' 'libxinerama' 'libxrandr' 'gcc-libs' 'sh' 'imlib2' 'fribidi')
+makedepends=('pkg-config')
+optdepends=('xorg-xmessage: for using the fbsetbg and fluxbox-generate_menu utilities')
options=('!makeflags')
source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2 \
- fluxbox.desktop keys fluxbox_fullscreen_focus.patch)
+ fluxbox.desktop keys)
build() {
- echo "==> Patching Fluxbox with fullscreen focus patch..."
- patch < fluxbox_fullscreen_focus.patch ${srcdir}/${pkgname}-${pkgver}/src/Window.cc || return 1
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr \
- --enable-kde --enable-gnome \
- --enable-xft --enable-xinerama \
- --enable-imlib2 --enable-nls || return 1
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
- # this is a fix to allow fluxbox to shutdown, but this can be changed by the user :-(
- sed -i 's|^.*slit\.autoHide.*$|session.screen0.slit.autoHide: True|' ${pkgdir}/usr/share/fluxbox/init || return 1
- install -D -m644 ../fluxbox.desktop ${pkgdir}/etc/X11/sessions/fluxbox.desktop || return 1
- install -D -m644 ../keys ${pkgdir}/usr/share/fluxbox/keys || return 1
- install -D -m644 COPYING ${pkgdir}/usr/share/licenses/$pkgname/COPYING || return 1
+ --enable-gnome --enable-xft --enable-xinerama \
+ --enable-imlib2 --enable-nls
+ make
}
-md5sums=('fa9fa8fe9a44f86522de5754f8b285ca'
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 ../fluxbox.desktop "${pkgdir}/usr/share/xsessions/fluxbox.desktop"
+ install -D -m644 ../keys "${pkgdir}/usr/share/fluxbox/keys"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+md5sums=('817ffe734b8ebb1aa4b9c53ed208c23f'
'eeae9c88a2526ac0bd8afcd9ce97f9ed'
- 'bb9f812c559263b4bf1d722628a11ca8'
- '82dac089f2d42bb9592debc93291846d')
+ 'bb9f812c559263b4bf1d722628a11ca8')
diff --git a/abs/core/fluxbox/__changelog b/abs/core/fluxbox/__changelog
new file mode 100644
index 0000000..5d2592e
--- /dev/null
+++ b/abs/core/fluxbox/__changelog
@@ -0,0 +1 @@
+2/22/11 - chw - Added keys file
diff --git a/abs/core/fluxbox/fluxbox-1.0.0-gcc43.patch b/abs/core/fluxbox/fluxbox-1.0.0-gcc43.patch
deleted file mode 100644
index 2e7db28..0000000
--- a/abs/core/fluxbox/fluxbox-1.0.0-gcc43.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- fluxbox-1.0.0-orig/src/main.cc 2007-08-11 14:22:20.000000000 -0400
-+++ fluxbox-1.0.0/src/main.cc 2008-05-05 15:14:59.000000000 -0400
-@@ -49,6 +49,7 @@
- #include <fstream>
- #include <stdexcept>
- #include <typeinfo>
-+#include <cstring>
-
- using std::cout;
- using std::cerr;
diff --git a/abs/core/fluxbox/fluxbox_fullscreen_focus.patch b/abs/core/fluxbox/fluxbox_fullscreen_focus.patch
deleted file mode 100644
index 1a8c233..0000000
--- a/abs/core/fluxbox/fluxbox_fullscreen_focus.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/Window.cc.orig 2010-04-12 16:45:00.750585365 -0500
-+++ src/Window.cc 2010-04-12 16:45:38.719755786 -0500
-@@ -2042,8 +2042,7 @@
- FluxboxWindow *cur = FocusControl::focusedFbWindow();
- WinClient *client = FocusControl::focusedWindow();
- if (ret && cur && getRootTransientFor(&from) != getRootTransientFor(client))
-- ret = !(cur->isFullscreen() && getOnHead() == cur->getOnHead()) &&
-- !cur->isTyping();
-+ ret = !cur->isTyping();
-
- if (!ret)
- Fluxbox::instance()->attentionHandler().addAttention(from);