summaryrefslogtreecommitdiffstats
path: root/abs/core/fontconfig
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-01 18:52:30 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-01 18:52:30 (GMT)
commit57c39ce61930bd6669100296ed19461cb2a382d4 (patch)
treecc26d6796498eb43fad593da2854ae3ad8460e58 /abs/core/fontconfig
parent8d1495ac7754fe50303e695f294d3ca8b69961be (diff)
downloadlinhes_pkgbuild-57c39ce61930bd6669100296ed19461cb2a382d4.zip
linhes_pkgbuild-57c39ce61930bd6669100296ed19461cb2a382d4.tar.gz
linhes_pkgbuild-57c39ce61930bd6669100296ed19461cb2a382d4.tar.bz2
fontconfig: update to 2.11.1. dep of pango
Diffstat (limited to 'abs/core/fontconfig')
-rw-r--r--abs/core/fontconfig/PKGBUILD36
1 files changed, 13 insertions, 23 deletions
diff --git a/abs/core/fontconfig/PKGBUILD b/abs/core/fontconfig/PKGBUILD
index f698618..2919bb1 100644
--- a/abs/core/fontconfig/PKGBUILD
+++ b/abs/core/fontconfig/PKGBUILD
@@ -1,27 +1,27 @@
-# $Id: PKGBUILD 166327 2012-09-06 13:53:52Z andyrtr $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=fontconfig
-pkgver=2.10.1
-pkgrel=2
+pkgver=2.11.1
+pkgrel=1
pkgdesc="A library for configuring and customizing font access"
arch=(i686 x86_64)
url="http://www.fontconfig.org/release/"
license=('custom')
depends=('expat' 'freetype2')
-options=('!libtool')
install=fontconfig.install
-source=(http://www.fontconfig.org/release/$pkgname-$pkgver.tar.gz
- 29-replace-bitmap-fonts.conf)
-md5sums=('c94e380eea42f2f23ca9537035ef1899'
- 'f6b67e8cc79197ed6abd4701911e83da')
+source=(http://www.fontconfig.org/release/$pkgname-$pkgver.tar.bz2)
+sha256sums=('dc62447533bca844463a3c3fd4083b57c90f18a70506e7a9f4936b5a1e516a99')
+
+ # a nice page to test font matching:
+ # http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
# make sure there's no rpath trouble and sane .so versioning - FC and Gentoo do this as well
libtoolize -f
- autoreconf -f
+ autoreconf -fi
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -35,22 +35,12 @@ build() {
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
make -k check
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
-
- # not upstream, not in FC and not in Gentoo, this should probably go upstream
- # meanwhile to satisfy pages like http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html we bring it back
- install -m644 "$srcdir/29-replace-bitmap-fonts.conf" "$pkgdir/etc/fonts/conf.avail"
- pushd $pkgdir/etc/fonts/conf.d
- ln -s /etc/fonts/conf.avail/29-replace-bitmap-fonts.conf .
- popd
-
- #Install license
- install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
- install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}