summaryrefslogtreecommitdiffstats
path: root/abs/core/fuse/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-16 23:47:07 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:03 (GMT)
commit1c975aea312ffdcc6b580bbe87318424b1f6b6c2 (patch)
treec20dd080ab09a7d43158bc16baf746a0d215c313 /abs/core/fuse/PKGBUILD
parent1a1a281c4c9e1b8ad80ebb2f115e95210246f3a0 (diff)
downloadlinhes_pkgbuild-1c975aea312ffdcc6b580bbe87318424b1f6b6c2.zip
linhes_pkgbuild-1c975aea312ffdcc6b580bbe87318424b1f6b6c2.tar.gz
linhes_pkgbuild-1c975aea312ffdcc6b580bbe87318424b1f6b6c2.tar.bz2
fuse: 2.9.3
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/core/fuse/PKGBUILD')
-rw-r--r--abs/core/fuse/PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/abs/core/fuse/PKGBUILD b/abs/core/fuse/PKGBUILD
index c16e6d7..fcfb387 100644
--- a/abs/core/fuse/PKGBUILD
+++ b/abs/core/fuse/PKGBUILD
@@ -1,11 +1,11 @@
-# $Id: PKGBUILD 157796 2012-04-29 15:29:44Z dreisner $
+# $Id: PKGBUILD 197300 2013-10-25 01:41:17Z allan $
# Maintainer: Ronald van Haren <ronald.archlinux.org>
# Contributor: Tom Gundersen <teg@jklm.no>
# Contributor: Mark Rosenstand <mark@archlinux.org>
pkgname=fuse
-pkgver=2.9.0
-pkgrel=1
+pkgver=2.9.3
+pkgrel=2
pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
arch=('i686' 'x86_64')
url="http://fuse.sourceforge.net/"
@@ -15,18 +15,22 @@ makedepends=('pkg-config')
backup=(etc/fuse.conf)
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
'fuse.conf')
-options=(!libtool)
-sha1sums=('e64396d516cca55995e0a8f8dd75456fd9d9d21d'
+sha1sums=('94bd1974a9f2173ac3c2cf122f9fa3c35996b88e'
'3b42e37a741d4651099225987dc40e7f02a716ad')
-build() {
+prepare() {
cd "$pkgname-$pkgver"
# fix building with glibc-2.14
- sed -i '1i#define _GNU_SOURCE' util/fusermount.c
+ sed -i '1i#define _GNU_SOURCE' util/fusermount.c
+
+ sed -i "/MOUNT_FUSE_PATH=/s#/sbin#/usr/bin#" configure
+}
- ./configure --prefix=/usr --libdir=/usr/lib --enable-lib \
- --enable-util --bindir=/bin
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr --libdir=/usr/lib \
+ --enable-lib --enable-util
make
}
@@ -38,7 +42,6 @@ package() {
# Remove init script in wrong path
# Don't add our own for now, as fusectl fs oopses on 2.6.18
rm -rf ${pkgdir}/etc/init.d
- #install -D -m755 ${srcdir}/fuse.rc.d ${pkgdir}/etc/rc.d/fuse
# install sample config file
install -Dm644 ${srcdir}/fuse.conf ${pkgdir}/etc/fuse.conf