summaryrefslogtreecommitdiffstats
path: root/abs/core/gawk
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-15 18:12:45 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-15 18:12:45 (GMT)
commit24f0e5139064db07c57568cfb3893b71895391f3 (patch)
tree48a5d17be2b3bc9c241455b4b7b5c962f15282d6 /abs/core/gawk
parent2084076a3e4acf8359d81d79b32ccc9128c3f60a (diff)
downloadlinhes_pkgbuild-24f0e5139064db07c57568cfb3893b71895391f3.zip
linhes_pkgbuild-24f0e5139064db07c57568cfb3893b71895391f3.tar.gz
linhes_pkgbuild-24f0e5139064db07c57568cfb3893b71895391f3.tar.bz2
gawk: upadate to 4.2.0
Diffstat (limited to 'abs/core/gawk')
-rw-r--r--abs/core/gawk/PKGBUILD17
-rw-r--r--abs/core/gawk/gawk.install22
2 files changed, 8 insertions, 31 deletions
diff --git a/abs/core/gawk/PKGBUILD b/abs/core/gawk/PKGBUILD
index 071d2ec..5272608 100644
--- a/abs/core/gawk/PKGBUILD
+++ b/abs/core/gawk/PKGBUILD
@@ -3,25 +3,24 @@
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=gawk
-pkgver=4.1.3
-pkgrel=1
+pkgver=4.2.0
+pkgrel=3
pkgdesc="GNU version of awk"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.gnu.org/software/gawk/"
license=('GPL')
groups=('base' 'base-devel')
depends=('sh' 'glibc' 'mpfr')
provides=('awk')
-install=gawk.install
-source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.sig})
-md5sums=('55d37f4069502677f25d1340df8eec97'
+source=(https://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.sig})
+md5sums=('0b598c31bc703d66082bd958d4189980'
'SKIP')
validpgpkeys=('D1967C63788713177D861ED7DF597815937EC0D2') # Arnold Robbins
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --libexecdir=/usr/lib --without-libsigsegv
- make
+ ./configure --prefix=/usr --libexecdir=/usr/lib --sysconfdir=/etc --without-libsigsegv
+ make
}
check() {
@@ -33,7 +32,7 @@ package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
- #install -dm755 ${pkgdir}/bin
+ #install -dm755 ${pkgdir}/bin
#ln -sf /usr/bin/gawk ${pkgdir}/bin/
#ln -sf gawk ${pkgdir}/bin/awk
}
diff --git a/abs/core/gawk/gawk.install b/abs/core/gawk/gawk.install
deleted file mode 100644
index 3f7f24c..0000000
--- a/abs/core/gawk/gawk.install
+++ /dev/null
@@ -1,22 +0,0 @@
-infodir=usr/share/info
-filelist=(gawk.info.gz gawkinet.info.gz)
-
-post_install() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-# vim:set ts=2 sw=2 et: