summaryrefslogtreecommitdiffstats
path: root/abs/core/gdb/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:22:05 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:22:05 (GMT)
commit850d9d17a0e28d1ba069c5f6cd852c939c6f20f3 (patch)
treef7e6401248e7934de190b39cc8e167b94157be5a /abs/core/gdb/PKGBUILD
parent3e54414d9e4e72327e0a7bd46601e6df54f97396 (diff)
downloadlinhes_pkgbuild-850d9d17a0e28d1ba069c5f6cd852c939c6f20f3.zip
linhes_pkgbuild-850d9d17a0e28d1ba069c5f6cd852c939c6f20f3.tar.gz
linhes_pkgbuild-850d9d17a0e28d1ba069c5f6cd852c939c6f20f3.tar.bz2
gdb: 7.4.1
Diffstat (limited to 'abs/core/gdb/PKGBUILD')
-rw-r--r--abs/core/gdb/PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/abs/core/gdb/PKGBUILD b/abs/core/gdb/PKGBUILD
index d96cb93..3c5769c 100644
--- a/abs/core/gdb/PKGBUILD
+++ b/abs/core/gdb/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 90312 2010-09-10 14:58:18Z allan $
+# $Id: PKGBUILD 157331 2012-04-27 05:07:31Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gdb
-pkgver=7.2
-pkgrel=2
+pkgver=7.4.1
+pkgrel=1
pkgdesc="The GNU Debugger"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/gdb/"
@@ -14,24 +14,21 @@ makedepends=('texinfo')
backup=('etc/gdb/gdbinit')
options=('!libtool')
install=gdb.install
-source=(http://ftp.gnu.org/gnu/gdb/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('64260e6c56979ee750a01055f16091a5')
+source=(http://ftp.gnu.org/gnu/gdb/${pkgname}-${pkgver}.tar.bz2{,.sig} siginfo_t.patch)
build() {
cd ${srcdir}/${pkgname}-${pkgver}
-
+ patch -Np1 <$srcdir/siginfo_t.patch || exit 1
./configure --prefix=/usr --disable-nls \
--with-system-readline \
+ --with-python=/usr/bin/python2 \
--with-system-gdbinit=/etc/gdb/gdbinit
- make || return 1
-
- # requires dejagnu
- #make check
+ make
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ make DESTDIR=${pkgdir} install
# install "custom" system gdbinit
install -dm755 $pkgdir/etc/gdb
@@ -42,3 +39,6 @@ package() {
rm ${pkgdir}/usr/lib/{libbfd,libiberty,libopcodes}.a
rm ${pkgdir}/usr/share/info/{bfd,configure,standards}.info
}
+md5sums=('8854d34691087ec127d934692639855f'
+ 'a3d48626efc9e7d802f0734ca39a7878'
+ 'd3d6566382696c7d5a1b6aea5df0bbc2')