summaryrefslogtreecommitdiffstats
path: root/abs/core/gdk-pixbuf2
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-15 22:19:09 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-15 22:19:09 (GMT)
commitab2bf439ab66e334fb8db266f555e6bc97db9286 (patch)
treee776e2601670db71d6b0495cf2c84b69d9f67344 /abs/core/gdk-pixbuf2
parenta50622f2a92acb1a48a3aa651d58381884ff163c (diff)
downloadlinhes_pkgbuild-ab2bf439ab66e334fb8db266f555e6bc97db9286.zip
linhes_pkgbuild-ab2bf439ab66e334fb8db266f555e6bc97db9286.tar.gz
linhes_pkgbuild-ab2bf439ab66e334fb8db266f555e6bc97db9286.tar.bz2
gdk-pixbuf2: recompile for libx11
Diffstat (limited to 'abs/core/gdk-pixbuf2')
-rw-r--r--abs/core/gdk-pixbuf2/PKGBUILD32
-rw-r--r--abs/core/gdk-pixbuf2/gdk-pixbuf2.install11
2 files changed, 43 insertions, 0 deletions
diff --git a/abs/core/gdk-pixbuf2/PKGBUILD b/abs/core/gdk-pixbuf2/PKGBUILD
new file mode 100644
index 0000000..91c74af
--- /dev/null
+++ b/abs/core/gdk-pixbuf2/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 98279 2010-11-06 11:00:15Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+pkgname=gdk-pixbuf2
+pkgver=2.22.1
+pkgrel=2
+pkgdesc="An image loading library for gtk2"
+arch=('i686' 'x86_64')
+url="http://www.gtk.org/"
+license=('GPL2')
+depends=('glib2>=2.26.0' 'libpng>=1.4.3' 'libtiff>=3.9.4' 'libjpeg>=8.0.2' 'libx11')
+makedepends=('gtk-doc' 'gobject-introspection')
+options=('!libtool')
+install=gdk-pixbuf2.install
+source=(http://download.gnome.org/sources/gdk-pixbuf/2.22/gdk-pixbuf-${pkgver}.tar.bz2)
+sha256sums=('6ce87eda24af9362307b2593c154d0b660f4e26d0abf2e71d46d0ddd55fd953d')
+
+build() {
+ cd "${srcdir}/gdk-pixbuf-${pkgver}"
+
+ ./configure --prefix=/usr \
+ --without-libjasper \
+ --with-included-loaders=png
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/gdk-pixbuf-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/gdk-pixbuf2/gdk-pixbuf2.install b/abs/core/gdk-pixbuf2/gdk-pixbuf2.install
new file mode 100644
index 0000000..1b35942
--- /dev/null
+++ b/abs/core/gdk-pixbuf2/gdk-pixbuf2.install
@@ -0,0 +1,11 @@
+post_install() {
+ usr/bin/gdk-pixbuf-query-loaders --update-cache
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ rm -f usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/loaders.cache
+}