summaryrefslogtreecommitdiffstats
path: root/abs/core/ghostscript/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:23:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:23:50 (GMT)
commit2e4361d7e1a7815e79bc8aff478d7089278882de (patch)
tree7dab28de1bda3482d7fc95507140bb42827ef956 /abs/core/ghostscript/PKGBUILD
parent37f0ed2c99873a5f175a837ae46358664e34862a (diff)
downloadlinhes_pkgbuild-2e4361d7e1a7815e79bc8aff478d7089278882de.zip
linhes_pkgbuild-2e4361d7e1a7815e79bc8aff478d7089278882de.tar.gz
linhes_pkgbuild-2e4361d7e1a7815e79bc8aff478d7089278882de.tar.bz2
ghostscript 9.05
Diffstat (limited to 'abs/core/ghostscript/PKGBUILD')
-rw-r--r--abs/core/ghostscript/PKGBUILD69
1 files changed, 34 insertions, 35 deletions
diff --git a/abs/core/ghostscript/PKGBUILD b/abs/core/ghostscript/PKGBUILD
index c479bdc..a911598 100644
--- a/abs/core/ghostscript/PKGBUILD
+++ b/abs/core/ghostscript/PKGBUILD
@@ -1,62 +1,57 @@
-# $Id: PKGBUILD 94631 2010-10-08 20:42:27Z andyrtr $
+# $Id: PKGBUILD 149988 2012-02-12 09:04:00Z andyrtr $
# Maintainer: AndyRTR <andyrtr@archlinux.org>
pkgname=ghostscript
-pkgver=9.00
+pkgver=9.05
pkgrel=1
pkgdesc="An interpreter for the PostScript language"
arch=('i686' 'x86_64')
license=('GPL3' 'custom')
-depends=('libxext' 'libxt' 'libcups>=1.4.2-3' 'fontconfig>=2.8.0' 'gnutls>=2.8.5' 'cairo>=1.8.8-2'
- 'jasper>=1.900.1-4' 'zlib' 'libpng>=1.4.0' 'libjpeg>=8')
-makedepends=('automake' 'autoconf' 'gtk2>=2.18.6')
-optdepends=('texlive-core: dvipdf'
- 'gtk2: gsx')
-replaces=('ghostscript-lrpng')
-provides=('ghostscript-lprng')
+depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg' 'libtiff>=4.0.0' 'lcms') # 'lcms2' won't get used) # move in libpaper from community?
+makedepends=('gtk2' 'gnutls')
+optdepends=('texlive-core: needed for dvipdf'
+ 'gtk2: needed for gsx')
url="http://www.ghostscript.com/"
-source=(http://ghostscript.com/releases/ghostscript-${pkgver}.tar.xz
- ghostscript-fPIC.patch
- ghostscript-system-jasper.patch)
+source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2)
options=('!libtool' '!makeflags')
-md5sums=('1ca5f245677f78f573e6490bdb40702f'
- '766d44c47c693f96941b658e360c1277'
- '03e27cd02471ab3b642c344fa06b623e')
+md5sums=('8bcef1f33ddf8a4d12b2cf8da385c191')
build() {
cd ${srcdir}/ghostscript-${pkgver}
+
# force it to use system-libs
- rm -rf jpeg libpng zlib jasper expat
-
- # fix build with systems jasper
- patch -Np1 -i ${srcdir}/ghostscript-system-jasper.patch || return 1
+ rm -rf jpeg libpng zlib jasper expat tiff lcms freetype
- if [ "$CARCH" = "x86_64" ]; then
- patch -Np1 -i ${srcdir}/ghostscript-fPIC.patch || return 1
- fi
+ ./configure --prefix=/usr \
+ --enable-dynamic \
+ --with-ijs \
+ --with-jbig2dec \
+ --with-omni \
+ --with-x \
+ --with-drivers=ALL\
+ --with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
+ --with-install-cups \
+ --enable-fontconfig \
+ --enable-freetype \
+ --without-luratech \
+ --with-system-libtiff \
+ --disable-compile-inits #--help # needed for linking with system-zlib
+ make
# Build IJS
cd ${srcdir}/ghostscript-${pkgver}/ijs
./autogen.sh
./configure --prefix=/usr --enable-shared --disable-static
- make || return 1
- make -j1 DESTDIR=${pkgdir} install || return 1
-
- cd ..
- ./autogen.sh
- ./configure --prefix=/usr --enable-dynamic --with-ijs \
- --with-jbig2dec --with-omni --with-x --with-drivers=ALL\
- --with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
- --disable-compile-inits # needed for linking with system-zlib
- make || return 1
+ make
}
+
package() {
- cd ${srcdir}/ghostscript-${pkgver}
- make -j1 DESTDIR=${pkgdir} \
+ cd ${srcdir}/ghostscript-${pkgver}
+ make DESTDIR=${pkgdir} \
cups_serverroot=${pkgdir}/etc/cups \
cups_serverbin=${pkgdir}/usr/lib/cups install soinstall
- # install a missing doc files # http://bugs.archlinux.org/task/18023
+ # install missing doc files # http://bugs.archlinux.org/task/18023
install -m 644 ${srcdir}/ghostscript-${pkgver}/doc/{Ps2ps2.htm,gs-vms.hlp,gsdoc.el,pscet_status.txt} ${pkgdir}/usr/share/ghostscript/$pkgver/doc/
mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
@@ -64,4 +59,8 @@ package() {
# remove unwanted localized man-pages
rm -rf $pkgdir/usr/share/man/[^man1]*
+
+ # install IJS
+ cd ${srcdir}/ghostscript-${pkgver}/ijs
+ make DESTDIR=${pkgdir} install
}