summaryrefslogtreecommitdiffstats
path: root/abs/core/ghostscript
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/ghostscript
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/ghostscript')
-rw-r--r--abs/core/ghostscript/PKGBUILD50
-rw-r--r--abs/core/ghostscript/ghostscript-fPIC.patch31
-rw-r--r--abs/core/ghostscript/ghostscript.install14
3 files changed, 95 insertions, 0 deletions
diff --git a/abs/core/ghostscript/PKGBUILD b/abs/core/ghostscript/PKGBUILD
new file mode 100644
index 0000000..2cf5416
--- /dev/null
+++ b/abs/core/ghostscript/PKGBUILD
@@ -0,0 +1,50 @@
+# $Id: PKGBUILD 7626 2008-08-03 15:52:01Z jgc $
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=ghostscript
+pkgver=8.63
+pkgrel=3
+pkgdesc="An interpreter for the PostScript language"
+arch=(i686 x86_64)
+license=('GPL' 'custom')
+depends=('libxext' 'libxt' 'libcups>=1.3.8-2' 'fontconfig>=2.6.0' 'gtk2>=2.12.11' 'gnutls>=2.4.1')
+makedepends=('automake' 'autoconf')
+replaces=('ghostscript-lrpng')
+provides=('ghostscript-lprng')
+url="http://www.cs.wisc.edu/~ghost/"
+#url="http://www.cups.org/espgs/"
+install=ghostscript.install
+source=(ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/gs863/ghostscript-${pkgver}.tar.bz2
+ ghostscript-fPIC.patch)
+options=('!libtool' '!makeflags')
+md5sums=('c770eedfdd846a53e211e3ba5339de21'
+ '29540cd88aad9a3a788d68193523080d')
+
+build() {
+ cd ${srcdir}/ghostscript-${pkgver}
+ if [ "$CARCH" = "x86_64" ]; then
+ patch -Np1 -i ${srcdir}/ghostscript-fPIC.patch || return 1
+ fi
+
+ # Build IJS
+ cd ${srcdir}/ghostscript-${pkgver}/ijs
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-shared --disable-static
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ cd ..
+ ./configure --prefix=/usr --enable-dynamic --enable-threads --with-ijs \
+ --with-jbig2dec --with-omni --with-x --with-drivers=ALL\
+ --with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts
+ make || return 1
+ make DESTDIR=${pkgdir} \
+ cups_serverroot=${pkgdir}/etc/cups \
+ cups_serverbin=${pkgdir}/usr/lib/cups install soinstall
+
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
+
+ # remove unwanted localized man-pages
+ rm -rf $pkgdir/usr/share/man/[^man1]*
+}
diff --git a/abs/core/ghostscript/ghostscript-fPIC.patch b/abs/core/ghostscript/ghostscript-fPIC.patch
new file mode 100644
index 0000000..9b4deb2
--- /dev/null
+++ b/abs/core/ghostscript/ghostscript-fPIC.patch
@@ -0,0 +1,31 @@
+--- ghostscript-8.60-r8112/src/lib.mak.fPIC 2007-07-10 17:03:11.000000000 +0100
++++ ghostscript-8.60-r8112/src/lib.mak 2007-07-10 17:05:56.000000000 +0100
+@@ -874,7 +874,7 @@
+ $(GLOBJ)gsparamx.$(OBJ) : $(GLSRC)gsparamx.c $(string__h)\
+ $(gserror_h) $(gserrors_h) $(gsmemory_h) $(gsparam_h) $(gsparamx_h)\
+ $(gstypes_h)
+- $(GLCC) $(GLO_)gsparamx.$(OBJ) $(C_) $(GLSRC)gsparamx.c
++ $(GLCCSHARED) $(GLO_)gsparamx.$(OBJ) $(C_) $(GLSRC)gsparamx.c
+
+ # Future replacement for gsparams.c
+ $(GLOBJ)gsparam2.$(OBJ) : $(GLSRC)gsparam2.c $(GXERR) $(memory__h)\
+@@ -1077,7 +1077,7 @@
+
+ # Provide a mapping between StandardEncoding and ISOLatin1Encoding.
+ $(GLOBJ)gdevemap.$(OBJ) : $(GLSRC)gdevemap.c $(AK) $(std_h)
+- $(GLCC) $(GLO_)gdevemap.$(OBJ) $(C_) $(GLSRC)gdevemap.c
++ $(GLCCSHARED) $(GLO_)gdevemap.$(OBJ) $(C_) $(GLSRC)gdevemap.c
+
+ ###### Create a pseudo-"feature" for the entire graphics library.
+
+--- ghostscript-8.60-r8112/src/devs.mak.fPIC 2007-07-10 17:05:00.000000000 +0100
++++ ghostscript-8.60-r8112/src/devs.mak 2007-07-10 17:05:07.000000000 +0100
+@@ -464,7 +464,7 @@
+ $(GLCCSHARED) $(XINCLUDE) $(GLO_)gdevx.$(OBJ) $(C_) $(GLSRC)gdevx.c
+
+ $(GLOBJ)gdevxcmp.$(OBJ) : $(GLSRC)gdevxcmp.c $(GDEVX) $(math__h)
+- $(GLCC) $(XINCLUDE) $(GLO_)gdevxcmp.$(OBJ) $(C_) $(GLSRC)gdevxcmp.c
++ $(GLCCSHARED) $(XINCLUDE) $(GLO_)gdevxcmp.$(OBJ) $(C_) $(GLSRC)gdevxcmp.c
+
+ $(GLOBJ)gdevxini.$(OBJ) : $(GLSRC)gdevxini.c $(GDEVX) $(memory__h)\
+ $(gserrors_h) $(gsparamx_h) $(gxdevmem_h) $(gdevbbox_h)
diff --git a/abs/core/ghostscript/ghostscript.install b/abs/core/ghostscript/ghostscript.install
new file mode 100644
index 0000000..10d2d7a
--- /dev/null
+++ b/abs/core/ghostscript/ghostscript.install
@@ -0,0 +1,14 @@
+post_install() {
+cat << EOF
+==> To use dvipdf, you need to install tetex:
+==> # pacman -S tetex
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+$op $*