summaryrefslogtreecommitdiffstats
path: root/abs/core/glibc/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/core/glibc/PKGBUILD
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/core/glibc/PKGBUILD')
-rw-r--r--abs/core/glibc/PKGBUILD188
1 files changed, 0 insertions, 188 deletions
diff --git a/abs/core/glibc/PKGBUILD b/abs/core/glibc/PKGBUILD
deleted file mode 100644
index 1c9d578..0000000
--- a/abs/core/glibc/PKGBUILD
+++ /dev/null
@@ -1,188 +0,0 @@
-# $Id$
-# Maintainer: Allan McRae <allan@archlinux.org>
-
-# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
-# NOTE: valgrind requires rebuilt with each new glibc version
-
-pkgname=glibc
-pkgver=2.14
-pkgrel=4
-_glibcdate=20110617
-pkgdesc="GNU C Library"
-arch=('i686' 'x86_64')
-url="http://www.gnu.org/software/libc"
-license=('GPL' 'LGPL')
-groups=('base')
-depends=('linux-api-headers>=2.6.39' 'tzdata')
-makedepends=('gcc>=4.4')
-backup=(etc/locale.gen
- etc/nscd.conf)
-options=('!strip')
-install=glibc.install
-source=(ftp://ftp.archlinux.org/other/glibc/${pkgname}-${pkgver}_${_glibcdate}.tar.xz
- glibc-2.10-dont-build-timezone.patch
- glibc-2.10-bz4781.patch
- glibc-__i686.patch
- glibc-2.12.1-static-shared-getpagesize.patch
- glibc-2.12.2-ignore-origin-of-privileged-program.patch
- glibc-2.13-futex.patch
- glibc-2.14-libdl-crash.patch
- #glibc-2.14-fix-resolver-crash-typo.patch
- glibc-2.14-revert-4462fad3.patch
- glibc-2.14-reexport-rpc-interface.patch
- glibc-2.14-reinstall-nis-rpc-headers.patch
- nscd
- locale.gen.txt
- locale-gen)
-md5sums=('e441d745609d93c907b72548ba646dad'
- '4dadb9203b69a3210d53514bb46f41c3'
- '0c5540efc51c0b93996c51b57a8540ae'
- '40cd342e21f71f5e49e32622b25acc52'
- 'a3ac6f318d680347bb6e2805d42b73b2'
- 'b042647ea7d6f22ad319e12e796bd13e'
- '7d0154b7e17ea218c9fa953599d24cc4'
- 'cea62cc6b903d222c5f26e05a3c0e0e6'
- '46e56492cccb1c9172ed3a235cf43c6c'
- 'c5de2a946215d647c8af5432ec4b0da0'
- '55febbb72139ac7b65757df085024b83'
- 'b587ee3a70c9b3713099295609afde49'
- '07ac979b6ab5eeb778d55f041529d623'
- '476e9113489f93b348b21e144b6a8fcf')
-
-
-mksource() {
- git clone git://sourceware.org/git/glibc.git
- pushd glibc
- git checkout -b glibc-2.14-arch origin/release/2.14/master
- popd
- tar -cvJf glibc-${pkgver}_${_glibcdate}.tar.xz glibc/*
-}
-
-build() {
- cd ${srcdir}/glibc
-
- # timezone data is in separate package (tzdata)
- patch -Np1 -i ${srcdir}/glibc-2.10-dont-build-timezone.patch
-
- # http://sources.redhat.com/bugzilla/show_bug.cgi?id=4781
- patch -Np1 -i ${srcdir}/glibc-2.10-bz4781.patch
-
- # http://sources.redhat.com/bugzilla/show_bug.cgi?id=411
- # http://sourceware.org/ml/libc-alpha/2009-07/msg00072.html
- patch -Np1 -i ${srcdir}/glibc-__i686.patch
-
- # http://sourceware.org/bugzilla/show_bug.cgi?id=11929
- # using Fedora "fix" as patch in that bug report causes breakages...
- patch -Np1 -i ${srcdir}/glibc-2.12.1-static-shared-getpagesize.patch
-
- # http://www.exploit-db.com/exploits/15274/
- # http://sourceware.org/git/?p=glibc.git;a=patch;h=d14e6b09 (only fedora branch...)
- patch -Np1 -i ${srcdir}/glibc-2.12.2-ignore-origin-of-privileged-program.patch
-
- # http://sourceware.org/bugzilla/show_bug.cgi?id=12403
- patch -Np1 -i ${srcdir}/glibc-2.13-futex.patch
-
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=675155e9 (only fedora branch...)
- # http://sourceware.org/ml/libc-alpha/2011-06/msg00006.html
- patch -Np1 -i ${srcdir}/glibc-2.14-libdl-crash.patch
-
- # This fixes the main segfault but not the assert fail (FS#24615)
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=57912a71
- #patch -Np1 -i ${srcdir}/glibc-2.14-fix-resolver-crash-typo.patch
- # resort to reverting the bad commit completely for the moment
- patch -Np1 -i ${srcdir}/glibc-2.14-revert-4462fad3.patch
-
- # re-export RPC interface until libtirpc is ready as a replacement
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=acee4873 (only fedora branch...)
- patch -Np1 -i ${srcdir}/glibc-2.14-reexport-rpc-interface.patch
- # http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=bdd816a3 (only fedora branch...)
- patch -Np1 -i ${srcdir}/glibc-2.14-reinstall-nis-rpc-headers.patch
-
- install -dm755 ${pkgdir}/etc
- touch ${pkgdir}/etc/ld.so.conf
-
- cd ${srcdir}
- mkdir glibc-build
- cd glibc-build
-
- if [[ ${CARCH} = "i686" ]]; then
- # Hack to fix NPTL issues with Xen, only required on 32bit platforms
- export CFLAGS="${CFLAGS} -mno-tls-direct-seg-refs"
- fi
-
- echo "slibdir=/lib" >> configparms
-
- ${srcdir}/glibc/configure --prefix=/usr \
- --libdir=/usr/lib --libexecdir=/usr/lib \
- --with-headers=/usr/include \
- --enable-add-ons=nptl,libidn \
- --enable-kernel=2.6.27 \
- --with-tls --with-__thread \
- --enable-bind-now --without-gd \
- --without-cvs --disable-profile \
- --disable-multi-arch
-
- make
-}
-
-check() {
- cd ${srcdir}/glibc-build
-
- # some errors are expected - manually check log files
- make -k check || true
-}
-
-package() {
- cd ${srcdir}/glibc-build
- make install_root=${pkgdir} install
-
- rm -f ${pkgdir}/etc/ld.so.{cache,conf}
-
- install -dm755 ${pkgdir}/etc/rc.d
- install -dm755 ${pkgdir}/usr/sbin
- install -dm755 ${pkgdir}/usr/lib/locale
- install -m644 ${srcdir}/glibc/nscd/nscd.conf ${pkgdir}/etc/nscd.conf
- install -m755 ${srcdir}/nscd ${pkgdir}/etc/rc.d/nscd
- install -m755 ${srcdir}/locale-gen ${pkgdir}/usr/sbin
- install -m644 ${srcdir}/glibc/posix/gai.conf ${pkgdir}/etc/gai.conf
-
- sed -i -e 's/^\tserver-user/#\tserver-user/' ${pkgdir}/etc/nscd.conf
-
- # create /etc/locale.gen
- install -m644 ${srcdir}/locale.gen.txt ${pkgdir}/etc/locale.gen
- sed -i "s|/| |g" ${srcdir}/glibc/localedata/SUPPORTED
- sed -i 's|\\| |g' ${srcdir}/glibc/localedata/SUPPORTED
- sed -i "s|SUPPORTED-LOCALES=||" ${srcdir}/glibc/localedata/SUPPORTED
- cat ${srcdir}/glibc/localedata/SUPPORTED >> ${pkgdir}/etc/locale.gen
- sed -i "s|^|#|g" ${pkgdir}/etc/locale.gen
-
- if [[ ${CARCH} = "x86_64" ]]; then
- # fix for the linker
- sed -i '/RTLDLIST/s%lib64%lib%' ${pkgdir}/usr/bin/ldd
- # Comply with multilib binaries, they look for the linker in /lib64
- mkdir ${pkgdir}/lib64
- cd ${pkgdir}/lib64
- ln -v -s ../lib/ld* .
- fi
-
- # manually strip files as stripping libpthread-*.so and libthread_db.so
- # with the default $STRIP_SHARED breaks gdb and stripping ld-*.so breaks
- # valgrind on x86_64
-
- cd $pkgdir
- strip $STRIP_BINARIES sbin/{ldconfig,sln} \
- usr/bin/{gencat,getconf,getent,iconv,locale} \
- usr/bin/{localedef,pcprofiledump,rpcgen,sprof} \
- usr/lib/getconf/* \
- usr/sbin/{iconvconfig,nscd}
- [[ $CARCH = "i686" ]] && strip $STRIP_BINARIES usr/bin/lddlibc4
-
- strip $STRIP_STATIC usr/lib/*.a \
- lib/{{ld,libpthread}-${pkgver},libthread_db-1.0}.so
-
- strip $STRIP_SHARED lib/{libanl,libBrokenLocale,libc,libcidn,libcrypt}-${pkgver}.so \
- lib/libnss_{compat,dns,files,hesiod,nis,nisplus}-${pkgver}.so \
- lib/{libdl,libm,libnsl,libresolv,librt,libutil}-${pkgver}.so \
- lib/{libmemusage,libpcprofile,libSegFault}.so \
- usr/lib/{pt_chown,{audit,gconv}/*.so}
-}