summaryrefslogtreecommitdiffstats
path: root/abs/core/glibc
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/glibc
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/glibc')
-rw-r--r--abs/core/glibc/ChangeLog39
-rw-r--r--abs/core/glibc/PKGBUILD150
-rw-r--r--abs/core/glibc/fix-makecontext.patch33
-rw-r--r--abs/core/glibc/glibc-2.10-bz4781.patch42
-rw-r--r--abs/core/glibc/glibc-2.10-dont-build-timezone.patch13
-rw-r--r--abs/core/glibc/glibc-__i686.patch13
-rw-r--r--abs/core/glibc/glibc.install131
-rw-r--r--abs/core/glibc/locale.gen438
8 files changed, 165 insertions, 694 deletions
diff --git a/abs/core/glibc/ChangeLog b/abs/core/glibc/ChangeLog
deleted file mode 100644
index 631f360..0000000
--- a/abs/core/glibc/ChangeLog
+++ /dev/null
@@ -1,39 +0,0 @@
-glibc 2.9-3
-- remove texinfo dep
-- only call install-info when needed
-
-glibc 2.9-2
-- apply Fedora10 changes to fix
- name resolving issues
-
-glibc 2.9-1
-- bump to new 2.9 branch
-
-glibc 2.8-2
-- fix an old memory issue again
-
-glibc 2.8-1
-- no more tarballs
-- we checkout the current release branch incl. libidn
-- cleanup the patches
-
-glibc 2.7-6
-- fix broken locales with upstream changes
-- disable the whole weekday patch, fixes #8530
-
-glibc 2.7-5
-- fix a regression: http://sourceware.org/bugzilla/show_bug.cgi?id=4781
- mainly for x86_64 where using gcc-gcj eats all memory
-
-glibc 2.7-4
-- extract /etc/locale.gen from sources to have all new locales supported
-- mask other broken locales / added a comment to post.install message
-- apply changes from Debian 2.7-exp7 pkg
- to fix some broken locales
-
-glibc 2.7-3
-- removed locale/check-unknown-symbols.diff
- localedata/tailor-iso14651_t1.diff partly
- to fix broken et_EE locale
-- switch to compressed patches
-- added ChangeLog
diff --git a/abs/core/glibc/PKGBUILD b/abs/core/glibc/PKGBUILD
index e7f866f..673951b 100644
--- a/abs/core/glibc/PKGBUILD
+++ b/abs/core/glibc/PKGBUILD
@@ -1,67 +1,69 @@
-# $Id: PKGBUILD 25809 2009-01-29 17:49:56Z aaron $
+# $Id: PKGBUILD 87193 2010-08-11 00:55:29Z allan $
# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Maintainer: Allan McRae <allan@archlinux.org>
+
+# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
+# NOTE: valgrind requires rebuilt with each new glibc version
pkgname=glibc
-pkgver=2.9
-pkgrel=4
-_glibcdate=20081119
-install=glibc.install
-backup=(etc/locale.gen)
+pkgver=2.12.1
+pkgrel=1
+_glibcdate=20100811
pkgdesc="GNU C Library"
-arch=(i686 x86_64)
-license=('GPL' 'LGPL')
+arch=('i686' 'x86_64')
url="http://www.gnu.org/software/libc"
+license=('GPL' 'LGPL')
groups=('base')
-depends=('kernel-headers>=2.6.27.6' 'tzdata')
-makedepends=('gcc>=4.3.2-2')
+depends=('linux-api-headers>=2.6.34' 'tzdata')
+makedepends=('gcc>=4.4')
replaces=('glibc-xen')
-source=(ftp://ftp.archlinux.org/other/glibc/${pkgname}-${pkgver}_${_glibcdate}.tar.bz2
- ftp://ftp.archlinux.org/other/glibc/glibc-patches-${pkgver}-2.tar.gz
- nscd
- locale.gen.txt
- locale-gen)
-md5sums=('1f7cc590a7a9bbef8b09fe89af69fb8c'
- '7679e2bcd981847efccb2bad9e57fee3'
+backup=(etc/locale.gen
+ etc/nscd.conf)
+options=('!strip')
+install=glibc.install
+source=(ftp://ftp.archlinux.org/other/glibc/${pkgname}-${pkgver}_${_glibcdate}.tar.xz
+ glibc-2.10-dont-build-timezone.patch
+ glibc-2.10-bz4781.patch
+ glibc-__i686.patch
+ nscd
+ locale.gen.txt
+ locale-gen)
+md5sums=('3f0d64de5a9fc5614d8acc0f1d5846ed'
+ '4dadb9203b69a3210d53514bb46f41c3'
+ '0c5540efc51c0b93996c51b57a8540ae'
+ '40cd342e21f71f5e49e32622b25acc52'
'b587ee3a70c9b3713099295609afde49'
'07ac979b6ab5eeb778d55f041529d623'
'476e9113489f93b348b21e144b6a8fcf')
-build() {
-
- # for cvs checkout
- mkdir ${srcdir}/glibc-${_glibcdate}
- cd ${srcdir}/glibc-${_glibcdate}
- export _TAG=glibc-2_9-branch
- export 'CVSROOT=:pserver:anoncvs@sources.redhat.com:/cvs/glibc'
-# cvs -z9 co -r $_TAG libc || return 1
-# tar -cvjf ../../glibc-2.9_${_glibcdate}.tar.bz2 libc
-# return 1
-
- cd ${srcdir}/libc
+mksource() {
+ git clone git://sourceware.org/git/glibc.git
+ pushd glibc
+ git checkout -b glibc-2.12-arch origin/release/2.12/master
+ popd
+ tar -cvJf glibc-${pkgver}_${_glibcdate}.tar.xz glibc/*
+}
- # patch from Debian
- patch -Np1 -i ${srcdir}/glibc-patches/glibc-2.5-localedef_segfault-1.patch || return 1 # still needed?
+build() {
+ cd ${srcdir}/glibc
- # Upstream fixes. See sources.redhat.com bugzilla
- patch -Np1 -i ${srcdir}/glibc-patches/glibc-2.7-bz4781.patch || return 1
+ # timezone data is in separate package (tzdata)
+ patch -Np1 -i ${srcdir}/glibc-2.10-dont-build-timezone.patch
- # Gentoo fixes
- patch -Np1 -i ${srcdir}/glibc-patches/glibc-dont-build-timezone.patch || return 1
+ # http://sources.redhat.com/bugzilla/show_bug.cgi?id=4781
+ patch -Np1 -i ${srcdir}/glibc-2.10-bz4781.patch
- # fixes taken from FC10 2.9-3 rpm, fixes FS#12215
- # see http://sources.redhat.com/bugzilla/show_bug.cgi?id=7060
- # see https://bugzilla.redhat.com/show_bug.cgi?id=459756
- patch -Np1 -i ${srcdir}/glibc-patches/glibc-nss_dns-gethostbyname4-disable.patch || return 1
- patch -Np1 -i ${srcdir}/glibc-patches/glibc-fixes1.patch || return 1
+ # http://sources.redhat.com/bugzilla/show_bug.cgi?id=411
+ # http://sourceware.org/ml/libc-alpha/2009-07/msg00072.html
+ patch -Np1 -i ${srcdir}/glibc-__i686.patch
- install -m755 -d ${pkgdir}/etc
+ install -dm755 ${pkgdir}/etc
touch ${pkgdir}/etc/ld.so.conf
mkdir glibc-build
cd glibc-build
- if [ "${CARCH}" = "i686" ]; then
+ if [[ ${CARCH} = "i686" ]]; then
# Hack to fix NPTL issues with Xen, only required on 32bit platforms
export CFLAGS="${CFLAGS} -mno-tls-direct-seg-refs"
fi
@@ -70,34 +72,41 @@ build() {
../configure --prefix=/usr \
--enable-add-ons=nptl,libidn --without-cvs \
- --enable-kernel=2.6.16 --disable-profile \
+ --enable-kernel=2.6.18 --disable-profile \
--with-headers=/usr/include --libexecdir=/usr/lib \
--enable-bind-now --with-tls --with-__thread \
- --libdir=/usr/lib --without-gd
-
- make || return 1
- make install_root=${pkgdir} install || return 1
+ --libdir=/usr/lib --without-gd --disable-multi-arch
+
+ make
+}
- rm -f ${pkgdir}/etc/ld.so.cache ${pkgdir}/etc/ld.so.conf ${pkgdir}/etc/localtime
+package() {
+ cd ${srcdir}/glibc/glibc-build
+ make install_root=${pkgdir} install
- install -m755 -d ${pkgdir}/etc/rc.d
- install -m755 -d ${pkgdir}/usr/sbin
- install -m755 -d ${pkgdir}/usr/lib/locale
- install -m644 ${srcdir}/libc/nscd/nscd.conf ${pkgdir}/etc/nscd.conf
+ # provided by kernel-headers
+ rm ${pkgdir}/usr/include/scsi/scsi.h
+
+ rm ${pkgdir}/etc/ld.so.conf
+
+ install -dm755 ${pkgdir}/etc/rc.d
+ install -dm755 ${pkgdir}/usr/sbin
+ install -dm755 ${pkgdir}/usr/lib/locale
+ install -m644 ${srcdir}/glibc/nscd/nscd.conf ${pkgdir}/etc/nscd.conf
install -m755 ${srcdir}/nscd ${pkgdir}/etc/rc.d/nscd
install -m755 ${srcdir}/locale-gen ${pkgdir}/usr/sbin
- sed -i -e 's/^\tserver-user/#\tserver-user/' ${pkgdir}/etc/nscd.conf || return 1
+ sed -i -e 's/^\tserver-user/#\tserver-user/' ${pkgdir}/etc/nscd.conf
# create /etc/locale.gen
install -m644 ${srcdir}/locale.gen.txt ${pkgdir}/etc/locale.gen
- sed -i "s|/| |g" ${srcdir}/libc/localedata/SUPPORTED
- sed -i 's|\\| |g' ${srcdir}/libc/localedata/SUPPORTED
- sed -i "s|SUPPORTED-LOCALES=||" ${srcdir}/libc/localedata/SUPPORTED
- cat ${srcdir}/libc/localedata/SUPPORTED >> ${pkgdir}/etc/locale.gen
+ sed -i "s|/| |g" ${srcdir}/glibc/localedata/SUPPORTED
+ sed -i 's|\\| |g' ${srcdir}/glibc/localedata/SUPPORTED
+ sed -i "s|SUPPORTED-LOCALES=||" ${srcdir}/glibc/localedata/SUPPORTED
+ cat ${srcdir}/glibc/localedata/SUPPORTED >> ${pkgdir}/etc/locale.gen
sed -i "s|^|#|g" ${pkgdir}/etc/locale.gen
- if [ "${CARCH}" = "x86_64" ]; then
+ if [[ ${CARCH} = "x86_64" ]]; then
# fix for the linker
sed -i '/RTLDLIST/s%/ld-linux.so.2 /lib64%%' ${pkgdir}/usr/bin/ldd
#Comply with multilib binaries, they look for the linker in /lib64
@@ -105,6 +114,25 @@ build() {
cd ${pkgdir}/lib64
ln -v -s ../lib/ld* .
fi
-
- rm -f ${pkgdir}/usr/share/info/dir
+
+ # manually strip files as stripping libpthread-*.so and libthread_db.so
+ # with the default $STRIP_SHARED breaks gdb and stripping ld-*.so breaks
+ # valgrind on x86_64
+
+ cd $pkgdir
+ strip $STRIP_BINARIES sbin/{ldconfig,sln} \
+ usr/bin/{gencat,getconf,getent,iconv,locale} \
+ usr/bin/{localedef,pcprofiledump,rpcgen,sprof} \
+ usr/lib/getconf/* \
+ usr/sbin/{iconvconfig,nscd,rpcinfo}
+ [[ $CARCH = "i686" ]] && strip $STRIP_BINARIES usr/bin/lddlibc4
+
+ strip $STRIP_STATIC usr/lib/*.a \
+ lib/{{ld,libpthread}-${pkgver},libthread_db-1.0}.so
+
+ strip $STRIP_SHARED lib/{libanl,libBrokenLocale,libc,libcidn,libcrypt}-${pkgver}.so \
+ lib/libnss_{compat,dns,files,hesiod,nis,nisplus}-${pkgver}.so \
+ lib/{libdl,libm,libnsl,libresolv,librt,libutil}-${pkgver}.so \
+ lib/{libmemusage,libpcprofile,libSegFault}.so \
+ usr/lib/{pt_chown,gconv/*.so}
}
diff --git a/abs/core/glibc/fix-makecontext.patch b/abs/core/glibc/fix-makecontext.patch
deleted file mode 100644
index f507b7a..0000000
--- a/abs/core/glibc/fix-makecontext.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-===================================================================
-RCS file: /cvs/glibc/libc/sysdeps/unix/sysv/linux/i386/makecontext.S,v
-retrieving revision 1.8
-retrieving revision 1.9
-diff -u -r1.8 -r1.9
---- libc/sysdeps/unix/sysv/linux/i386/makecontext.S 2007/12/03 04:56:56 1.8
-+++ libc/sysdeps/unix/sysv/linux/i386/makecontext.S 2008/01/09 19:35:15 1.9
-@@ -1,5 +1,5 @@
- /* Create new context.
-- Copyright (C) 2001, 2002, 2005 Free Software Foundation, Inc.
-+ Copyright (C) 2001, 2002, 2005, 2007, 2008 Free Software Foundation, Inc.
- This file is part of the GNU C Library.
- Contributed by Ulrich Drepper <drepper@redhat.com>, 2001.
-
-@@ -41,13 +41,15 @@
- movl 12(%esp), %ecx
- movl %ecx, oEBX(%eax)
-
-- /* Make room on the new stack for the parameters. */
-+ /* Make room on the new stack for the parameters.
-+ Room for the arguments, return address (== L(exitcode)) and
-+ oLINK pointer is needed. One of the pointer sizes is subtracted
-+ after aligning the stack. */
- negl %ecx
-- leal -8(%edx,%ecx,4), %edx
-+ leal -4(%edx,%ecx,4), %edx
- negl %ecx
-
- /* Align the stack. */
-- addl $16, %edx
- andl $0xfffffff0, %edx
- subl $4, %edx
-
diff --git a/abs/core/glibc/glibc-2.10-bz4781.patch b/abs/core/glibc/glibc-2.10-bz4781.patch
new file mode 100644
index 0000000..cf1a97a
--- /dev/null
+++ b/abs/core/glibc/glibc-2.10-bz4781.patch
@@ -0,0 +1,42 @@
+diff -Naur glibc-old/sysdeps/unix/sysv/linux/i386/clone.S glibc/sysdeps/unix/sysv/linux/i386/clone.S
+--- glibc-old/sysdeps/unix/sysv/linux/i386/clone.S 2009-05-09 13:35:30.000000000 +1000
++++ glibc/sysdeps/unix/sysv/linux/i386/clone.S 2009-05-23 13:27:46.000000000 +1000
+@@ -120,9 +120,6 @@
+ ret
+
+ L(thread_start):
+- cfi_startproc;
+- /* Clearing frame pointer is insufficient, use CFI. */
+- cfi_undefined (eip);
+ /* Note: %esi is zero. */
+ movl %esi,%ebp /* terminate the stack frame */
+ #ifdef RESET_PID
+@@ -155,7 +152,6 @@
+ jmp L(haspid)
+ .previous
+ #endif
+- cfi_endproc;
+
+ cfi_startproc
+ PSEUDO_END (BP_SYM (__clone))
+diff -Naur glibc-old/sysdeps/unix/sysv/linux/x86_64/clone.S glibc/sysdeps/unix/sysv/linux/x86_64/clone.S
+--- glibc-old/sysdeps/unix/sysv/linux/x86_64/clone.S 2009-05-09 13:35:30.000000000 +1000
++++ glibc/sysdeps/unix/sysv/linux/x86_64/clone.S 2009-05-23 13:27:46.000000000 +1000
+@@ -89,9 +89,6 @@
+ ret
+
+ L(thread_start):
+- cfi_startproc;
+- /* Clearing frame pointer is insufficient, use CFI. */
+- cfi_undefined (rip);
+ /* Clear the frame pointer. The ABI suggests this be done, to mark
+ the outermost frame obviously. */
+ xorl %ebp, %ebp
+@@ -116,7 +113,6 @@
+ /* Call exit with return value from function call. */
+ movq %rax, %rdi
+ call HIDDEN_JUMPTARGET (_exit)
+- cfi_endproc;
+
+ cfi_startproc;
+ PSEUDO_END (BP_SYM (__clone))
diff --git a/abs/core/glibc/glibc-2.10-dont-build-timezone.patch b/abs/core/glibc/glibc-2.10-dont-build-timezone.patch
new file mode 100644
index 0000000..d3abeff
--- /dev/null
+++ b/abs/core/glibc/glibc-2.10-dont-build-timezone.patch
@@ -0,0 +1,13 @@
+timezone data has been split into the package sys-libs/timezone-data
+
+--- glibc-2.4/Makeconfig
++++ glibc-2.4/Makeconfig
+@@ -931,7 +931,7 @@
+ stdlib stdio-common libio malloc string wcsmbs time dirent \
+ grp pwd posix io termios resource misc socket sysvipc gmon \
+ gnulib iconv iconvdata wctype manual shadow gshadow po argp \
+- crypt nss localedata timezone rt conform debug \
++ crypt nss localedata rt conform debug \
+ $(add-on-subdirs) $(dlfcn) $(binfmt-subdir)
+
+ ifndef avoid-generated
diff --git a/abs/core/glibc/glibc-__i686.patch b/abs/core/glibc/glibc-__i686.patch
new file mode 100644
index 0000000..28d5dd4
--- /dev/null
+++ b/abs/core/glibc/glibc-__i686.patch
@@ -0,0 +1,13 @@
+diff -Naur glibc-old//sysdeps/i386/Makefile glibc//sysdeps/i386/Makefile
+--- glibc-old//sysdeps/i386/Makefile 2010-03-18 11:52:30.000000000 +1000
++++ glibc//sysdeps/i386/Makefile 2010-04-16 15:05:50.000000000 +1000
+@@ -1,6 +1,7 @@
+ # The mpn functions need a #define for asm syntax flavor.
+-# Every i386 port in use uses gas syntax (I think).
+-asm-CPPFLAGS += -DGAS_SYNTAX
++# Every i386 port in use uses gas syntax (I think). Don't replace
++# __i686 in __i686.get_pc_thunk.bx.
++asm-CPPFLAGS += -DGAS_SYNTAX -U __i686
+
+ # The i386 `long double' is a distinct type we support.
+ long-double-fcts = yes
diff --git a/abs/core/glibc/glibc.install b/abs/core/glibc/glibc.install
index 17c6b5d..5e15c81 100644
--- a/abs/core/glibc/glibc.install
+++ b/abs/core/glibc/glibc.install
@@ -2,135 +2,20 @@ infodir=/usr/share/info
filelist=(libc.info libc.info-1 libc.info-2 libc.info-3 libc.info-4 libc.info-5 libc.info-6 libc.info-7
libc.info-8 libc.info-9 libc.info-10 libc.info-11)
-pre_upgrade() {
-if [ "`uname -m`" = "x86_64" ]; then
- if [ "`vercmp $2 2.4`" -lt 0 ]; then
- cat << _EOF
- ==> glibc oldpkgver < 2.4 detected!
- ==>
- ==> ATTENTION x86_64 USERS:
- ==>
- ==> We now switch from the former lib-linking to pure /lib support. To get rid
- ==> of all lib64 directories we have removed the link /lib -> /lib64 and
- ==> /usr/lib -> /usr/lib64.
- ==>
- ==> We have also rebuilt all packages we know that still used lib64 directories.
- ==> Now all should go to /lib directories.
- ==>
- ==> Internally we have removed the link and then mv /lib64 /lib. Same to /usr/lib64.
- ==> /lib64 and /usr/lib64 shouldn't exist anymore. If any package still installs to
- ==> /lib64 or /usr/lib64 let us know.
- ==>
-_EOF
-
-# now the moving
-rm -rf /lib/tls && echo "/lib/tls removed"
-ldconfig -r .
-rm -f /usr/lib
-mv /usr/lib64 /usr/lib && echo "/usr/lib64 moved"
-rm -f /lib
-mv /lib64 /lib && echo "/lib64 moved"
-
- fi
-fi
-
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- usr/bin/install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
post_upgrade() {
- ldconfig -r .
- init u
-
- if [ "`vercmp $2 2.3.6`" -lt 0 ]; then
- cat << _EOF
- ==> ATTENTION INTERNATIONAL USERS:
- ==>
- ==> Locales are no longer included in the glibc package.
- ==> They are generated by /usr/sbin/locale-gen depending on the contents
- ==> of /etc/locale.gen.
- ==> glibc will try to autodetect the required locales now, if you need
- ==> additional locales, please enable them in /etc/locale.gen and run
- ==> /usr/sbin/locale-gen
- ==>
-_EOF
- # Check active locales, enable the ones that are in use
- loc=("$LANG"
- "`grep '^LOCALE=' etc/rc.conf | awk -F '=' '{ print $2 }'`")
- for l in "${loc[@]}"; do
- if [ ! -z "${l}" ]; then
- line="`grep -i "^#${l}[[:space:]]" etc/locale.gen`"
- if [ ! -z "${line}" ]; then
- sed -i -e "s|${line}|${line/\#/}|" etc/locale.gen
- fi
- fi
- done
- fi
-
+ sbin/ldconfig -r .
+ [ -x sbin/init ] && sbin/init u
usr/sbin/locale-gen
-
-# fix CHOST for arch64
-if [ "`uname -m`" = "x86_64" ]; then
- if [ "`vercmp $2 2.4`" -lt 0 ]; then
- sed -i s/'x86_64-pc-linux-gnu'/'x86_64-unknown-linux-gnu'/ /etc/makepkg.conf && \
- echo "in /etc/makepkg.conf CHOST has been changed to \"x86_64-unknown-linux-gnu\""
-
- # we remove files from glibc 2.3.6 that are not removed automatically
- rm -f /lib/ld-2.3.* && echo "removing unneeded old files"
- rm -f /lib/libBrokenLocale-2.3.*
- rm -f /lib/libNoVersion*
- rm -f /lib/libanl-2.3.*
- rm -f /lib/libc-2.3.*
- rm -f /lib/libcidn-2.3.*
- rm -f /lib/libcrypt-2.3.*
- rm -f /lib/libdl-2.3.*
- rm -f /lib/libm-2.3.*
- rm -f /lib/libnsl-2.3.*
- rm -f /lib/libnss1*
- rm -f /lib/libnss_compat-2.3.*
- rm -f /lib/libnss_dns-2.3.*
- rm -f /lib/libnss_dns.so.1
- rm -f /lib/libnss_files-2.3.*
- rm -f /lib/libnss_files.so.1
- rm -f /lib/libnss_hesiod-2.3.*
- rm -f /lib/libnss_nis-2.3.*
- rm -f /lib/libnss_nis.so.1
- rm -f /lib/libnss_nisplus-2.3.*
- rm -f /lib/libpthread-0.10.so
- rm -f /lib/libresolv-2.3.*
- rm -f /lib/librt-2.3.*
- rm -f /lib/libutil-2.3.*
- rm -fR /lib/nosegneg
- #rm -fR /usr/include/asm
- #rm -fR /usr/include/linux
- rm -fR /usr/include/ntpl
- rm -f /usr/lib/libNoVersion*
- rm -f /usr/lib/libc_stubs.a
- rm -f /usr/lib/libnss1*
- rm -f /usr/lib/libnss_compat.so.1
- rm -f /usr/lib/libnss_dns.so.1
- rm -f /usr/lib/libnss_files.so.1
- rm -f /usr/lib/libnss_nis.so.1
- rm -fR /usr/lib/nptl
- rm -f /usr/sbin/nscd_nischeck
- rm -fR /usr/share/zoneinfo/SystemV
- rm -fR /usr/share/zoneinfo/posix/SystemV
- rm -fR /usr/share/zoneinfo/right/SystemV
- ldconfig -r .
- fi
-fi
-
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- usr/bin/install-info $infodir/$file $infodir/dir 2> /dev/null
- done
+
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ usr/bin/install-info $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
}
pre_remove() {
[ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
- usr/bin/install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ usr/bin/install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
done
}
diff --git a/abs/core/glibc/locale.gen b/abs/core/glibc/locale.gen
deleted file mode 100644
index c739380..0000000
--- a/abs/core/glibc/locale.gen
+++ /dev/null
@@ -1,438 +0,0 @@
-# Configuration file for locale-gen
-#
-# lists of locales that are to be generated by the locale-gen command.
-#
-# Each line is of the form:
-#
-# <locale> <charset>
-#
-# where <locale> is one of the locales given in /usr/share/i18n/locales
-# and <charset> is one of the character sets listed in /usr/share/i18n/charmaps
-#
-# Examples:
-# en_US ISO-8859-1
-# en_US.UTF-8 UTF-8
-# de_DE ISO-8859-1
-# de_DE@euro ISO-8859-15
-#
-# The locale-gen command will generate all the locales,
-# placing them in /usr/lib/locale.
-#
-# A list of supported locales is included in this file.
-# Uncomment the ones you need.
-#
-#aa_DJ.UTF-8 UTF-8
-#aa_DJ ISO-8859-1
-#aa_ER UTF-8
-#aa_ER@saaho UTF-8
-#aa_ET UTF-8
-#af_ZA.UTF-8 UTF-8
-#af_ZA ISO-8859-1
-#am_ET UTF-8
-#an_ES.UTF-8 UTF-8
-#an_ES ISO-8859-15
-#ar_AE.UTF-8 UTF-8
-#ar_AE ISO-8859-6
-#ar_BH.UTF-8 UTF-8
-#ar_BH ISO-8859-6
-#ar_DZ.UTF-8 UTF-8
-#ar_DZ ISO-8859-6
-#ar_EG.UTF-8 UTF-8
-#ar_EG ISO-8859-6
-#ar_IN UTF-8
-#ar_IQ.UTF-8 UTF-8
-#ar_IQ ISO-8859-6
-#ar_JO.UTF-8 UTF-8
-#ar_JO ISO-8859-6
-#ar_KW.UTF-8 UTF-8
-#ar_KW ISO-8859-6
-#ar_LB.UTF-8 UTF-8
-#ar_LB ISO-8859-6
-#ar_LY.UTF-8 UTF-8
-#ar_LY ISO-8859-6
-#ar_MA.UTF-8 UTF-8
-#ar_MA ISO-8859-6
-#ar_OM.UTF-8 UTF-8
-#ar_OM ISO-8859-6
-#ar_QA.UTF-8 UTF-8
-#ar_QA ISO-8859-6
-#ar_SA.UTF-8 UTF-8
-#ar_SA ISO-8859-6
-#ar_SD.UTF-8 UTF-8
-#ar_SD ISO-8859-6
-#ar_SY.UTF-8 UTF-8
-#ar_SY ISO-8859-6
-#ar_TN.UTF-8 UTF-8
-#ar_TN ISO-8859-6
-#ar_YE.UTF-8 UTF-8
-#ar_YE ISO-8859-6
-#az_AZ.UTF-8 UTF-8
-#as_IN.UTF-8 UTF-8
-#ast_ES.UTF-8 UTF-8
-#ast_ES ISO-8859-15
-#be_BY.UTF-8 UTF-8
-#be_BY CP1251
-#be_BY@latin UTF-8
-#ber_DZ UTF-8
-#ber_MA UTF-8
-#bg_BG.UTF-8 UTF-8
-#bg_BG CP1251
-#bn_BD UTF-8
-#bn_IN UTF-8
-#br_FR.UTF-8 UTF-8
-#br_FR ISO-8859-1
-#br_FR@euro ISO-8859-15
-#bs_BA.UTF-8 UTF-8
-#bs_BA ISO-8859-2
-#byn_ER UTF-8
-#ca_AD.UTF-8 UTF-8
-#ca_AD ISO-8859-15
-#ca_ES.UTF-8 UTF-8
-#ca_ES ISO-8859-1
-#ca_ES@euro ISO-8859-15
-#ca_ES.UTF-8@valencia UTF-8
-#ca_ES@valencia ISO-8859-15
-#ca_FR.UTF-8 UTF-8
-#ca_FR ISO-8859-15
-#ca_IT.UTF-8 UTF-8
-#ca_IT ISO-8859-15
-#crh_UA UTF-8
-#cs_CZ.UTF-8 UTF-8
-#cs_CZ ISO-8859-2
-#csb_PL UTF-8
-#cy_GB.UTF-8 UTF-8
-#cy_GB ISO-8859-14
-#da_DK.UTF-8 UTF-8
-#da_DK ISO-8859-1
-#da_DK.ISO-8859-15 ISO-8859-15
-#de_AT.UTF-8 UTF-8
-#de_AT ISO-8859-1
-#de_AT@euro ISO-8859-15
-#de_BE.UTF-8 UTF-8
-#de_BE ISO-8859-1
-#de_BE@euro ISO-8859-15
-#de_CH.UTF-8 UTF-8
-#de_CH ISO-8859-1
-#de_DE.UTF-8 UTF-8
-#de_DE ISO-8859-1
-#de_DE@euro ISO-8859-15
-#de_LU.UTF-8 UTF-8
-#de_LU ISO-8859-1
-#de_LU@euro ISO-8859-15
-#dz_BT UTF-8
-#el_GR.UTF-8 UTF-8
-#el_GR ISO-8859-7
-#el_CY.UTF-8 UTF-8
-#el_CY ISO-8859-7
-#en_AU.UTF-8 UTF-8
-#en_AU ISO-8859-1
-#en_BW.UTF-8 UTF-8
-#en_BW ISO-8859-1
-#en_CA.UTF-8 UTF-8
-#en_CA ISO-8859-1
-#en_DK.UTF-8 UTF-8
-#en_DK.ISO-8859-15 ISO-8859-15
-#en_DK ISO-8859-1
-#en_GB.UTF-8 UTF-8
-#en_GB ISO-8859-1
-#en_GB.ISO-8859-15 ISO-8859-15
-#en_HK.UTF-8 UTF-8
-#en_HK ISO-8859-1
-#en_IE.UTF-8 UTF-8
-#en_IE ISO-8859-1
-#en_IE@euro ISO-8859-15
-#en_IN UTF-8
-#en_NG UTF-8
-#en_NZ.UTF-8 UTF-8
-#en_NZ ISO-8859-1
-#en_PH.UTF-8 UTF-8
-#en_PH ISO-8859-1
-#en_SG.UTF-8 UTF-8
-#en_SG ISO-8859-1
-#en_US.UTF-8 UTF-8
-#en_US ISO-8859-1
-#en_US.ISO-8859-15 ISO-8859-15
-#en_ZA.UTF-8 UTF-8
-#en_ZA ISO-8859-1
-#en_ZW.UTF-8 UTF-8
-#en_ZW ISO-8859-1
-#eo.UTF-8 UTF-8
-#eo ISO-8859-3
-#es_AR.UTF-8 UTF-8
-#es_AR ISO-8859-1
-#es_BO.UTF-8 UTF-8
-#es_BO ISO-8859-1
-#es_CL.UTF-8 UTF-8
-#es_CL ISO-8859-1
-#es_CO.UTF-8 UTF-8
-#es_CO ISO-8859-1
-#es_CR.UTF-8 UTF-8
-#es_CR ISO-8859-1
-#es_DO.UTF-8 UTF-8
-#es_DO ISO-8859-1
-#es_EC.UTF-8 UTF-8
-#es_EC ISO-8859-1
-#es_ES.UTF-8 UTF-8
-#es_ES ISO-8859-1
-#es_ES@euro ISO-8859-15
-#es_GT.UTF-8 UTF-8
-#es_GT ISO-8859-1
-#es_HN.UTF-8 UTF-8
-#es_HN ISO-8859-1
-#es_MX.UTF-8 UTF-8
-#es_MX ISO-8859-1
-#es_NI.UTF-8 UTF-8
-#es_NI ISO-8859-1
-#es_PA.UTF-8 UTF-8
-#es_PA ISO-8859-1
-#es_PE.UTF-8 UTF-8
-#es_PE ISO-8859-1
-#es_PR.UTF-8 UTF-8
-#es_PR ISO-8859-1
-#es_PY.UTF-8 UTF-8
-#es_PY ISO-8859-1
-#es_SV.UTF-8 UTF-8
-#es_SV ISO-8859-1
-#es_US.UTF-8 UTF-8
-#es_US ISO-8859-1
-#es_UY.UTF-8 UTF-8
-#es_UY ISO-8859-1
-#es_VE.UTF-8 UTF-8
-#es_VE ISO-8859-1
-#et_EE.UTF-8 UTF-8
-#et_EE ISO-8859-1
-#et_EE.ISO-8859-15 ISO-8859-15
-#eu_ES.UTF-8 UTF-8
-#eu_ES ISO-8859-1
-#eu_ES@euro ISO-8859-15
-#eu_FR.UTF-8 UTF-8
-#eu_FR ISO-8859-1
-#eu_FR@euro ISO-8859-15
-#fa_IR UTF-8
-#fi_FI.UTF-8 UTF-8
-#fi_FI ISO-8859-1
-#fi_FI@euro ISO-8859-15
-#fil_PH UTF-8
-#fo_FO.UTF-8 UTF-8
-#fo_FO ISO-8859-1
-#fr_BE.UTF-8 UTF-8
-#fr_BE ISO-8859-1
-#fr_BE@euro ISO-8859-15
-#fr_CA.UTF-8 UTF-8
-#fr_CA ISO-8859-1
-#fr_CH.UTF-8 UTF-8
-#fr_CH ISO-8859-1
-#fr_FR.UTF-8 UTF-8
-#fr_FR ISO-8859-1
-#fr_FR@euro ISO-8859-15
-#fr_LU.UTF-8 UTF-8
-#fr_LU ISO-8859-1
-#fr_LU@euro ISO-8859-15
-#fur_IT UTF-8
-#fy_NL UTF-8
-#fy_DE UTF-8
-#ga_IE.UTF-8 UTF-8
-#ga_IE ISO-8859-1
-#ga_IE@euro ISO-8859-15
-#gd_GB.UTF-8 UTF-8
-#gd_GB ISO-8859-15
-#gez_ER UTF-8
-#gez_ER@abegede UTF-8
-#gez_ET UTF-8
-#gez_ET@abegede UTF-8
-#gl_ES.UTF-8 UTF-8
-#gl_ES ISO-8859-1
-#gl_ES@euro ISO-8859-15
-#gu_IN UTF-8
-#gv_GB.UTF-8 UTF-8
-#gv_GB ISO-8859-1
-#ha_NG UTF-8
-#he_IL.UTF-8 UTF-8
-#he_IL ISO-8859-8
-#hi_IN UTF-8
-#hr_HR.UTF-8 UTF-8
-#hr_HR ISO-8859-2
-#hsb_DE.UTF-8 UTF-8
-#hsb_DE ISO-8859-2
-#hu_HU.UTF-8 UTF-8
-#hu_HU ISO-8859-2
-#hy_AM UTF-8
-#hy_AM.ARMSCII-8 ARMSCII-8
-#ia UTF-8
-#id_ID.UTF-8 UTF-8
-#id_ID ISO-8859-1
-#ig_NG UTF-8
-#ik_CA UTF-8
-#is_IS.UTF-8 UTF-8
-#is_IS ISO-8859-1
-#it_CH.UTF-8 UTF-8
-#it_CH ISO-8859-1
-#it_IT.UTF-8 UTF-8
-#it_IT ISO-8859-1
-#it_IT@euro ISO-8859-15
-#iu_CA UTF-8
-#iw_IL.UTF-8 UTF-8
-#iw_IL ISO-8859-8
-#ja_JP.UTF-8 UTF-8
-#ja_JP.EUC-JP EUC-JP
-#ka_GE.UTF-8 UTF-8
-#ka_GE GEORGIAN-PS
-#kk_KZ.UTF-8 UTF-8
-#kk_KZ PT154
-#kl_GL.UTF-8 UTF-8
-#kl_GL ISO-8859-1
-#km_KH UTF-8
-#kn_IN UTF-8
-#ko_KR.UTF-8 UTF-8
-#ko_KR.EUC-KR EUC-KR
-#ku_TR.UTF-8 UTF-8
-#ku_TR ISO-8859-9
-#kw_GB.UTF-8 UTF-8
-#kw_GB ISO-8859-1
-#ky_KG UTF-8
-#lg_UG.UTF-8 UTF-8
-#lg_UG ISO-8859-10
-#li_BE UTF-8
-#li_NL UTF-8
-#lo_LA UTF-8
-#lt_LT.UTF-8 UTF-8
-#lt_LT ISO-8859-13
-#lv_LV.UTF-8 UTF-8
-#lv_LV ISO-8859-13
-#mai_IN UTF-8
-#mg_MG.UTF-8 UTF-8
-#mg_MG ISO-8859-15
-#mi_NZ.UTF-8 UTF-8
-#mi_NZ ISO-8859-13
-#mk_MK.UTF-8 UTF-8
-#mk_MK ISO-8859-5
-#ml_IN UTF-8
-#mn_MN UTF-8
-#mr_IN UTF-8
-#ms_MY.UTF-8 UTF-8
-#ms_MY ISO-8859-1
-#mt_MT.UTF-8 UTF-8
-#mt_MT ISO-8859-3
-#nb_NO.UTF-8 UTF-8
-#nb_NO ISO-8859-1
-#nds_DE UTF-8
-#nds_NL UTF-8
-#ne_NP UTF-8
-#nl_BE.UTF-8 UTF-8
-#nl_BE ISO-8859-1
-#nl_BE@euro ISO-8859-15
-#nl_NL.UTF-8 UTF-8
-#nl_NL ISO-8859-1
-#nl_NL@euro ISO-8859-15
-#nn_NO.UTF-8 UTF-8
-#nn_NO ISO-8859-1
-#nr_ZA UTF-8
-#nso_ZA UTF-8
-#oc_FR.UTF-8 UTF-8
-#oc_FR ISO-8859-1
-#om_ET UTF-8
-#om_KE.UTF-8 UTF-8
-#om_KE ISO-8859-1
-#or_IN UTF-8
-#pa_IN UTF-8
-#pa_PK UTF-8
-#pap_AN UTF-8
-#pl_PL.UTF-8 UTF-8
-#pl_PL ISO-8859-2
-#pt_BR.UTF-8 UTF-8
-#pt_BR ISO-8859-1
-#pt_PT.UTF-8 UTF-8
-#pt_PT ISO-8859-1
-#pt_PT@euro ISO-8859-15
-#ro_RO.UTF-8 UTF-8
-#ro_RO ISO-8859-2
-#ru_RU.UTF-8 UTF-8
-#ru_RU.KOI8-R KOI8-R
-#ru_RU ISO-8859-5
-#ru_RU.CP1251 CP1251
-#ru_UA.UTF-8 UTF-8
-#ru_UA KOI8-U
-#rw_RW UTF-8
-#sa_IN UTF-8
-#sc_IT UTF-8
-#se_NO UTF-8
-#si_LK UTF-8
-#sid_ET UTF-8
-#sk_SK.UTF-8 UTF-8
-#sk_SK ISO-8859-2
-#sl_SI.UTF-8 UTF-8
-#sl_SI ISO-8859-2
-#so_DJ.UTF-8 UTF-8
-#so_DJ ISO-8859-1
-#so_ET UTF-8
-#so_KE.UTF-8 UTF-8
-#so_KE ISO-8859-1
-#so_SO.UTF-8 UTF-8
-#so_SO ISO-8859-1
-#sq_AL.UTF-8 UTF-8
-#sq_AL ISO-8859-1
-#sr_ME UTF-8
-#sr_RS UTF-8
-#sr_RS@latin UTF-8
-#ss_ZA UTF-8
-#st_ZA.UTF-8 UTF-8
-#st_ZA ISO-8859-1
-#sv_FI.UTF-8 UTF-8
-#sv_FI ISO-8859-1
-#sv_FI@euro ISO-8859-15
-#sv_SE.UTF-8 UTF-8
-#sv_SE ISO-8859-1
-#sv_SE.ISO-8859-15 ISO-8859-15
-#ta_IN UTF-8
-#te_IN UTF-8
-#tg_TJ.UTF-8 UTF-8
-#tg_TJ KOI8-T
-#th_TH.UTF-8 UTF-8
-#th_TH TIS-620
-#ti_ER UTF-8
-#ti_ET UTF-8
-#tig_ER UTF-8
-#tk_TM UTF-8
-#tl_PH.UTF-8 UTF-8
-#tl_PH ISO-8859-1
-#tn_ZA UTF-8
-#tr_CY.UTF-8 UTF-8
-#tr_CY ISO-8859-9
-#tr_TR.UTF-8 UTF-8
-#tr_TR ISO-8859-9
-#ts_ZA UTF-8
-#tt_RU.UTF-8 UTF-8
-#tt_RU@iqtelif.UTF-8 UTF-8
-#ug_CN UTF-8
-#uk_UA.UTF-8 UTF-8
-#uk_UA KOI8-U
-#ur_PK UTF-8
-#uz_UZ.UTF-8 UTF-8
-#uz_UZ ISO-8859-1
-#uz_UZ@cyrillic UTF-8
-#ve_ZA UTF-8
-#vi_VN UTF-8
-#vi_VN.TCVN TCVN5712-1
-#wa_BE.UTF-8 UTF-8
-#wa_BE ISO-8859-1
-#wa_BE@euro ISO-8859-15
-#wo_SN UTF-8
-#xh_ZA.UTF-8 UTF-8
-#xh_ZA ISO-8859-1
-#yi_US.UTF-8 UTF-8
-#yi_US CP1255
-#yo_NG UTF-8
-#zh_CN.UTF-8 UTF-8
-#zh_CN.GB18030 GB18030
-#zh_CN.GBK GBK
-#zh_CN GB2312
-#zh_HK.UTF-8 UTF-8
-#zh_HK BIG5-HKSCS
-#zh_SG.UTF-8 UTF-8
-#zh_SG.GBK GBK
-#zh_SG GB2312
-#zh_TW.UTF-8 UTF-8
-#zh_TW BIG5
-#zh_TW.EUC-TW EUC-TW
-#zu_ZA.UTF-8 UTF-8
-#zu_ZA ISO-8859-1