summaryrefslogtreecommitdiffstats
path: root/abs/core/gnupg
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-16 23:48:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:03 (GMT)
commitbf2f4dd3098203b922ed0bf3fa75b7d2b2fde722 (patch)
treee0c280e084d9eaa7ba4464c2ec96f8428c734cbd /abs/core/gnupg
parent4a9cb8b966e09bb71d1efaa34fe17027d3424b4b (diff)
downloadlinhes_pkgbuild-bf2f4dd3098203b922ed0bf3fa75b7d2b2fde722.zip
linhes_pkgbuild-bf2f4dd3098203b922ed0bf3fa75b7d2b2fde722.tar.gz
linhes_pkgbuild-bf2f4dd3098203b922ed0bf3fa75b7d2b2fde722.tar.bz2
gnupg:
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/core/gnupg')
-rw-r--r--abs/core/gnupg/PKGBUILD36
-rw-r--r--abs/core/gnupg/protect-tool-env.patch28
2 files changed, 53 insertions, 11 deletions
diff --git a/abs/core/gnupg/PKGBUILD b/abs/core/gnupg/PKGBUILD
index cfc51b0..9ac8772 100644
--- a/abs/core/gnupg/PKGBUILD
+++ b/abs/core/gnupg/PKGBUILD
@@ -1,25 +1,25 @@
-# $Id: PKGBUILD 156582 2012-04-21 09:42:46Z bisson $
+# $Id: PKGBUILD 195927 2013-10-05 17:40:59Z bisson $
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=gnupg
-pkgver=2.0.19
-pkgrel=2
+pkgver=2.0.22
+pkgrel=1
pkgdesc='Complete and free implementation of the OpenPGP standard'
url='http://www.gnupg.org/'
license=('GPL')
arch=('i686' 'x86_64')
optdepends=('curl: gpg2keys_curl'
'libldap: gpg2keys_ldap'
- 'libusb-compat: scdaemon'
- 'texinfo: documentation')
-makedepends=('curl' 'libldap' 'libusb-compat' 'texinfo')
+ 'libusb-compat: scdaemon')
+makedepends=('curl' 'libldap' 'libusb-compat')
depends=('bzip2' 'libksba' 'libgcrypt' 'pth' 'libassuan' 'readline' 'pinentry' 'dirmngr')
-source=("ftp://ftp.gnupg.org/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2"{,.sig})
-sha1sums=('190c09e6688f688fb0a5cf884d01e240d957ac1f'
- 'f6e6830610a8629b0aad69d789373bf8ca481733')
+source=("ftp://ftp.gnupg.org/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2"{,.sig}
+ 'protect-tool-env.patch')
+sha1sums=('9ba9ee288e9bf813e0f1e25cbe06b58d3072d8b8' 'SKIP'
+ '2ec97ba55ae47ff0d63bc813b8c64cb79cef11db')
install=install
@@ -27,9 +27,22 @@ conflicts=('gnupg2')
provides=("gnupg2=${pkgver}")
replaces=('gnupg2')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i ../protect-tool-env.patch # FS#31900
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --libexecdir=/usr/lib/gnupg
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/gnupg \
+ --enable-maintainer-mode \
+ --enable-symcryptrun \
+ --enable-gpgtar \
+
make
}
@@ -42,6 +55,7 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
ln -s gpg2 "${pkgdir}"/usr/bin/gpg
- ln -s gpg2 "${pkgdir}"/usr/bin/gpgv
+ ln -s gpgv2 "${pkgdir}"/usr/bin/gpgv
ln -s gpg2.1.gz "${pkgdir}"/usr/share/man/man1/gpg.1.gz
+ rm "${pkgdir}/usr/share/gnupg/com-certs.pem" # FS#33059
}
diff --git a/abs/core/gnupg/protect-tool-env.patch b/abs/core/gnupg/protect-tool-env.patch
new file mode 100644
index 0000000..132791f
--- /dev/null
+++ b/abs/core/gnupg/protect-tool-env.patch
@@ -0,0 +1,28 @@
+diff -Naur old/agent/protect-tool.c new/agent/protect-tool.c
+--- old/agent/protect-tool.c 2012-12-08 13:53:17.067611957 +1100
++++ new/agent/protect-tool.c 2012-12-08 13:53:28.247633012 +1100
+@@ -102,6 +102,7 @@
+ static int opt_status_msg;
+ static const char *opt_p12_charset;
+ static const char *opt_agent_program;
++static session_env_t opt_session_env;
+
+ static char *get_passphrase (int promptno);
+ static void release_passphrase (char *pw);
+@@ -1040,6 +1041,7 @@
+
+ opt_homedir = default_homedir ();
+
++ opt_session_env = session_env_new ();
+
+ pargs.argc = &argc;
+ pargs.argv = &argv;
+@@ -1091,7 +1093,7 @@
+ opt.verbose,
+ opt_homedir,
+ opt_agent_program,
+- NULL, NULL, NULL);
++ NULL, NULL, opt_session_env);
+
+ if (opt_prompt)
+ opt_prompt = percent_plus_unescape (opt_prompt, 0);