summaryrefslogtreecommitdiffstats
path: root/abs/core/gpgme
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:28:56 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:28:56 (GMT)
commit712f4fc8ca3addee71c8ccbc589a8b60ed84780c (patch)
tree5246c3d8acf764941001c514b960d43b17feeb52 /abs/core/gpgme
parent73ed013a5832c3582b0af3f6f436c9c2723d5d1c (diff)
downloadlinhes_pkgbuild-712f4fc8ca3addee71c8ccbc589a8b60ed84780c.zip
linhes_pkgbuild-712f4fc8ca3addee71c8ccbc589a8b60ed84780c.tar.gz
linhes_pkgbuild-712f4fc8ca3addee71c8ccbc589a8b60ed84780c.tar.bz2
gpgme 1.3.1
-new
Diffstat (limited to 'abs/core/gpgme')
-rw-r--r--abs/core/gpgme/PKGBUILD36
-rw-r--r--abs/core/gpgme/gpgme.install18
2 files changed, 54 insertions, 0 deletions
diff --git a/abs/core/gpgme/PKGBUILD b/abs/core/gpgme/PKGBUILD
new file mode 100644
index 0000000..8c1150e
--- /dev/null
+++ b/abs/core/gpgme/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 154388 2012-03-27 12:00:19Z bisson $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Roman Kyrylych <roman@archlinux.org>
+# Contributor: Sarah Hay <sarah@archlinux.org>
+
+pkgname=gpgme
+pkgver=1.3.1
+pkgrel=4
+pkgdesc="A C wrapper library for GnuPG"
+arch=('i686' 'x86_64')
+url="http://www.gnupg.org/related_software/gpgme/"
+license=('GPL')
+depends=('libgpg-error' 'pth' 'gnupg>=2')
+install=${pkgname}.install
+options=('!libtool' '!emptydirs')
+source=(ftp://ftp.gnupg.org/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2{,.sig})
+md5sums=('90afa8436ce2b2683c001c824bd22601'
+ 'a032ddc27177ef4ee54e25a231e62da5')
+sha1sums=('7d19a95a2239da13764dad7f97541be884ec5a37'
+ '93316a81a8f903c5b604716b6937884ea7b0917a')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/abs/core/gpgme/gpgme.install b/abs/core/gpgme/gpgme.install
new file mode 100644
index 0000000..b54620d
--- /dev/null
+++ b/abs/core/gpgme/gpgme.install
@@ -0,0 +1,18 @@
+infodir=/usr/share/info
+filelist=(gpgme.info gpgme.info-1 gpgme.info-2)
+
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}