summaryrefslogtreecommitdiffstats
path: root/abs/core/gpm
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/gpm
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/gpm')
-rw-r--r--abs/core/gpm/ChangeLog11
-rw-r--r--abs/core/gpm/PKGBUILD35
-rwxr-xr-xabs/core/gpm/gpm40
-rw-r--r--abs/core/gpm/gpm.conf.d4
4 files changed, 90 insertions, 0 deletions
diff --git a/abs/core/gpm/ChangeLog b/abs/core/gpm/ChangeLog
new file mode 100644
index 0000000..c6c6a14
--- /dev/null
+++ b/abs/core/gpm/ChangeLog
@@ -0,0 +1,11 @@
+2008-06-16 Eric Belanger <eric@archlinux.org>
+
+ * gpm 1.20.5-1
+ * Upstream update
+ * Added sanity checks
+
+2008-04-17 Eric Belanger <eric@archlinux.org>
+
+ * gpm 1.20.3-1
+ * Upstream update
+ * Added missing /usr/lib/libgpm.so.1 symlink (close FS#9949)
diff --git a/abs/core/gpm/PKGBUILD b/abs/core/gpm/PKGBUILD
new file mode 100644
index 0000000..7a7c571
--- /dev/null
+++ b/abs/core/gpm/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id: PKGBUILD 3002 2008-06-18 01:56:59Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=gpm
+pkgver=1.20.5
+pkgrel=1
+pkgdesc="A mouse server for the console and xterm"
+arch=('i686' 'x86_64')
+url="http://unix.schottelius.org/gpm/"
+license=('GPL')
+depends=('ncurses')
+backup=('etc/conf.d/gpm')
+options=('!makeflags')
+source=(http://unix.schottelius.org/gpm/archives/${pkgname}-${pkgver}.tar.bz2 \
+ gpm gpm.conf.d)
+md5sums=('e55473932e4052f3b74c730dfefe0d15' 'c4d42a4725503a5524cae060a959a3d3'\
+ '5f109341a7d1bb18c59d7c3a395d848a')
+sha1sums=('4a8c2109167da8e60055c25dadc383d02ba32538'
+ 'c13ad1422d24af320e2abb9786c7eacef39b293c'
+ '3bcb67027f0ad7dc393388fb02c261126671f9f5')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc || return 1
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+ install -D -m755 ../gpm ${startdir}/pkg/etc/rc.d/gpm || return 1
+ install -D -m644 ../gpm.conf.d ${startdir}/pkg/etc/conf.d/gpm || return 1
+
+# library fixes
+ cd ${startdir}/pkg/usr/lib/
+ ln -s libgpm.so.2.* libgpm.so || return 1
+ chmod 755 ${startdir}/pkg/usr/lib/libgpm.so.* || return 1
+}
diff --git a/abs/core/gpm/gpm b/abs/core/gpm/gpm
new file mode 100755
index 0000000..4acc908
--- /dev/null
+++ b/abs/core/gpm/gpm
@@ -0,0 +1,40 @@
+#!/bin/bash
+
+# source application-specific settings
+GPM_ARGS=
+[ -f /etc/conf.d/gpm ] && . /etc/conf.d/gpm
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/gpm`
+case "$1" in
+ start)
+ stat_busy "Starting GPM Daemon"
+ [ -z "$PID" ] && /usr/sbin/gpm ${GPM_ARGS}
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon gpm
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping GPM Daemon"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon gpm
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/abs/core/gpm/gpm.conf.d b/abs/core/gpm/gpm.conf.d
new file mode 100644
index 0000000..ed84f91
--- /dev/null
+++ b/abs/core/gpm/gpm.conf.d
@@ -0,0 +1,4 @@
+#
+# Parameters to be passed to gpm
+#
+GPM_ARGS="-m /dev/misc/psaux"