summaryrefslogtreecommitdiffstats
path: root/abs/core/gpm
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:29:10 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:29:10 (GMT)
commitb75dfcd759c84edb19648ad5c087dc70de59865e (patch)
tree1aa9609ac53967742a6c41419a5e5d6428796887 /abs/core/gpm
parent712f4fc8ca3addee71c8ccbc589a8b60ed84780c (diff)
downloadlinhes_pkgbuild-b75dfcd759c84edb19648ad5c087dc70de59865e.zip
linhes_pkgbuild-b75dfcd759c84edb19648ad5c087dc70de59865e.tar.gz
linhes_pkgbuild-b75dfcd759c84edb19648ad5c087dc70de59865e.tar.bz2
gpm 1.20.6
Diffstat (limited to 'abs/core/gpm')
-rw-r--r--abs/core/gpm/ChangeLog39
-rw-r--r--abs/core/gpm/PKGBUILD45
-rw-r--r--abs/core/gpm/gpm.conf.d2
-rw-r--r--abs/core/gpm/gpm.service9
4 files changed, 35 insertions, 60 deletions
diff --git a/abs/core/gpm/ChangeLog b/abs/core/gpm/ChangeLog
deleted file mode 100644
index 847bb4d..0000000
--- a/abs/core/gpm/ChangeLog
+++ /dev/null
@@ -1,39 +0,0 @@
-2009-12-05 Eric Belanger <eric@archlinux.org>
-
- * gpm 1.20.6-5
- * Fixed gpm.sh such that disable-paste is only run when gpm is running
-
-2009-12-05 Eric Belanger <eric@archlinux.org>
-
- * gpm 1.20.6-4
- * Added profile for extra security on multi-user-console (close FS#17243)
- * Removed the need of texinfo depends
-
-2009-09-20 Eric Belanger <eric@archlinux.org>
-
- * gpm 1.20.6-3
- * Updated /dev/psaux to /dev/input/mice in stock config (close FS#16289)
-
-2009-09-20 Eric Belanger <eric@archlinux.org>
-
- * gpm 1.20.6-2
- * Updated stock config and fixed rc.d script (close FS#16126)
- * Removed array in install scriptlet
-
-2009-02-09 Eric Belanger <eric@archlinux.org>
-
- * gpm 1.20.6-1
- * Upstream update
- * Added info file support
-
-2008-06-16 Eric Belanger <eric@archlinux.org>
-
- * gpm 1.20.5-1
- * Upstream update
- * Added sanity checks
-
-2008-04-17 Eric Belanger <eric@archlinux.org>
-
- * gpm 1.20.3-1
- * Upstream update
- * Added missing /usr/lib/libgpm.so.1 symlink (close FS#9949)
diff --git a/abs/core/gpm/PKGBUILD b/abs/core/gpm/PKGBUILD
index 12ecf4d..eae4b2a 100644
--- a/abs/core/gpm/PKGBUILD
+++ b/abs/core/gpm/PKGBUILD
@@ -1,36 +1,41 @@
-# $Id: PKGBUILD 60782 2009-12-07 00:52:55Z eric $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# $Id: PKGBUILD 163618 2012-07-17 05:32:49Z eric $
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=gpm
pkgver=1.20.6
-pkgrel=5
+pkgrel=10
pkgdesc="A mouse server for the console and xterm"
arch=('i686' 'x86_64')
-url="http://unix.schottelius.org/gpm/"
+url="http://www.nico.schottelius.org/software/gpm/"
license=('GPL')
-depends=('ncurses')
+depends=('ncurses' 'bash')
backup=('etc/conf.d/gpm')
options=('!makeflags')
install=gpm.install
-source=(http://www.nico.schottelius.org/software/gpm/archives/${pkgname}-${pkgver}.tar.bz2 \
- gpm gpm.conf.d gpm.sh)
-md5sums=('6b534da16dc1b28ba828dea89e520f6f' '945ecde0836687e05c13ea837092ea6c'\
- '63e599950946e5f5a649432510aacf4c' 'e391fe4599ce102615f9cd449c380d41')
-sha1sums=('f3bb9272878b7934968381c8b25edab359114150' '19e1feb1493373512a77801699df012d186336ea'\
- 'e483f893b4e6b9e1221a208527d728ffefe5438e' '88fe5ff10916c68a87abc8418a56eb0073f69fa9')
+source=(http://www.nico.schottelius.org/software/gpm/archives/${pkgname}-${pkgver}.tar.lzma \
+ gpm gpm.conf.d gpm.sh gpm.service)
+sha1sums=('4677da0eb2f1910a5a744bbefa08fea82e0dca0c'
+ '19e1feb1493373512a77801699df012d186336ea'
+ '4c31cb7dd51cee4d16d3f7a8956e6d87fac1ad86'
+ '88fe5ff10916c68a87abc8418a56eb0073f69fa9'
+ '20b92360f0ad38a2032fcae37bdbd01b31e43f77')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --sysconfdir=/etc || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -D -m755 ../gpm "${pkgdir}/etc/rc.d/gpm" || return 1
- install -D -m644 ../gpm.conf.d "${pkgdir}/etc/conf.d/gpm" || return 1
- install -D -m755 ../gpm.sh "${pkgdir}/etc/profile.d/gpm.sh" || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m755 ../gpm "${pkgdir}/etc/rc.d/gpm"
+ install -D -m644 ../gpm.conf.d "${pkgdir}/etc/conf.d/gpm"
+ install -D -m755 ../gpm.sh "${pkgdir}/etc/profile.d/gpm.sh"
+ install -D -m644 ../gpm.service "${pkgdir}/usr/lib/systemd/system/gpm.service"
# library fixes
cd "${pkgdir}/usr/lib/"
- ln -s libgpm.so.2.* libgpm.so || return 1
- chmod 755 "${pkgdir}"/usr/lib/libgpm.so.* || return 1
+ ln -s libgpm.so.2.* libgpm.so
+ chmod 755 "${pkgdir}"/usr/lib/libgpm.so.*
}
diff --git a/abs/core/gpm/gpm.conf.d b/abs/core/gpm/gpm.conf.d
index 9d8c981..ab43bb7 100644
--- a/abs/core/gpm/gpm.conf.d
+++ b/abs/core/gpm/gpm.conf.d
@@ -1,4 +1,4 @@
#
# Parameters to be passed to gpm
#
-GPM_ARGS="-m /dev/input/mice"
+GPM_ARGS="-m /dev/input/mice -t imps2"
diff --git a/abs/core/gpm/gpm.service b/abs/core/gpm/gpm.service
new file mode 100644
index 0000000..59e837d
--- /dev/null
+++ b/abs/core/gpm/gpm.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Virtual console mouse server
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/gpm -m /dev/input/mice -t imps2
+
+[Install]
+WantedBy=multi-user.target