summaryrefslogtreecommitdiffstats
path: root/abs/core/gpm
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-16 23:48:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:03 (GMT)
commitdbddb42f18c42d9a280215be4031d2b2dd3ae98b (patch)
treed49cd0e6b697e383718081ff1bd565a1f2004ba2 /abs/core/gpm
parentbf2f4dd3098203b922ed0bf3fa75b7d2b2fde722 (diff)
downloadlinhes_pkgbuild-dbddb42f18c42d9a280215be4031d2b2dd3ae98b.zip
linhes_pkgbuild-dbddb42f18c42d9a280215be4031d2b2dd3ae98b.tar.gz
linhes_pkgbuild-dbddb42f18c42d9a280215be4031d2b2dd3ae98b.tar.bz2
gpm: 1.20.7
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/core/gpm')
-rw-r--r--abs/core/gpm/PKGBUILD22
-rwxr-xr-xabs/core/gpm/gpm41
-rw-r--r--abs/core/gpm/gpm.conf.d4
-rw-r--r--abs/core/gpm/gpm.service2
4 files changed, 10 insertions, 59 deletions
diff --git a/abs/core/gpm/PKGBUILD b/abs/core/gpm/PKGBUILD
index eae4b2a..cb2cd9b 100644
--- a/abs/core/gpm/PKGBUILD
+++ b/abs/core/gpm/PKGBUILD
@@ -1,36 +1,32 @@
-# $Id: PKGBUILD 163618 2012-07-17 05:32:49Z eric $
+# $Id: PKGBUILD 197717 2013-10-28 22:26:50Z eric $
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=gpm
-pkgver=1.20.6
-pkgrel=10
+pkgver=1.20.7
+pkgrel=4
pkgdesc="A mouse server for the console and xterm"
arch=('i686' 'x86_64')
url="http://www.nico.schottelius.org/software/gpm/"
license=('GPL')
-depends=('ncurses' 'bash')
-backup=('etc/conf.d/gpm')
+depends=('bash')
options=('!makeflags')
install=gpm.install
source=(http://www.nico.schottelius.org/software/gpm/archives/${pkgname}-${pkgver}.tar.lzma \
- gpm gpm.conf.d gpm.sh gpm.service)
-sha1sums=('4677da0eb2f1910a5a744bbefa08fea82e0dca0c'
- '19e1feb1493373512a77801699df012d186336ea'
- '4c31cb7dd51cee4d16d3f7a8956e6d87fac1ad86'
+ gpm.sh gpm.service)
+sha1sums=('8d9f3655c80ce7667d31ede2a100b44986480369'
'88fe5ff10916c68a87abc8418a56eb0073f69fa9'
- '20b92360f0ad38a2032fcae37bdbd01b31e43f77')
+ 'f9bde96eb9c78da9f225bcf40822647f6592cf23')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --sysconfdir=/etc
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -D -m755 ../gpm "${pkgdir}/etc/rc.d/gpm"
- install -D -m644 ../gpm.conf.d "${pkgdir}/etc/conf.d/gpm"
install -D -m755 ../gpm.sh "${pkgdir}/etc/profile.d/gpm.sh"
install -D -m644 ../gpm.service "${pkgdir}/usr/lib/systemd/system/gpm.service"
diff --git a/abs/core/gpm/gpm b/abs/core/gpm/gpm
deleted file mode 100755
index 7b5213d..0000000
--- a/abs/core/gpm/gpm
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/bash
-
-# source application-specific settings
-GPM_ARGS=
-[ -f /etc/conf.d/gpm ] && . /etc/conf.d/gpm
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=$(pidof -o %PPID /usr/sbin/gpm)
-case "$1" in
- start)
- stat_busy "Starting GPM Daemon"
- [ -z "$PID" ] && /usr/sbin/gpm ${GPM_ARGS}
- PID=$(pidof -o %PPID /usr/sbin/gpm)
- if [ -z "$PID" ]; then
- stat_fail
- else
- add_daemon gpm
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping GPM Daemon"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon gpm
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/abs/core/gpm/gpm.conf.d b/abs/core/gpm/gpm.conf.d
deleted file mode 100644
index ab43bb7..0000000
--- a/abs/core/gpm/gpm.conf.d
+++ /dev/null
@@ -1,4 +0,0 @@
-#
-# Parameters to be passed to gpm
-#
-GPM_ARGS="-m /dev/input/mice -t imps2"
diff --git a/abs/core/gpm/gpm.service b/abs/core/gpm/gpm.service
index 59e837d..510ee9f 100644
--- a/abs/core/gpm/gpm.service
+++ b/abs/core/gpm/gpm.service
@@ -3,7 +3,7 @@ Description=Virtual console mouse server
[Service]
Type=forking
-ExecStart=/usr/sbin/gpm -m /dev/input/mice -t imps2
+ExecStart=/usr/bin/gpm -m /dev/input/mice -t imps2
[Install]
WantedBy=multi-user.target