summaryrefslogtreecommitdiffstats
path: root/abs/core/gtk2
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/gtk2
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/gtk2')
-rw-r--r--abs/core/gtk2/PKGBUILD34
-rw-r--r--abs/core/gtk2/__changelog1
-rw-r--r--abs/core/gtk2/revert_64bit_fix.patch31
-rw-r--r--abs/core/gtk2/xid-collision-debug.patch15
4 files changed, 65 insertions, 16 deletions
diff --git a/abs/core/gtk2/PKGBUILD b/abs/core/gtk2/PKGBUILD
index 6cdc6e1..819001d 100644
--- a/abs/core/gtk2/PKGBUILD
+++ b/abs/core/gtk2/PKGBUILD
@@ -1,35 +1,37 @@
-# $Id: PKGBUILD 35332 2009-04-12 12:46:16Z jgc $
+# $Id: PKGBUILD 79610 2010-05-04 20:23:20Z ibiru $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=gtk2
-pkgver=2.16.1
-pkgrel=6
+pkgver=2.20.1
+pkgrel=3
pkgdesc="The GTK+ Toolkit (v2)"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://www.gtk.org/"
install=gtk2.install
-depends=('atk>=1.26.0' 'pango>=1.24.0-2' 'libxcursor' 'libxinerama' 'libxrandr>=1.3.0' 'libxi>=1.2.1' 'libcups>=1.3.9' 'libxcomposite' 'libxdamage' 'heimdal>=1.2.1' 'gnutls>=2.6.4' 'shared-mime-info')
-makedepends=('pkgconfig')
+depends=('atk>=1.30.0' 'pango>=1.28.0' 'libxcursor' 'libxinerama' 'libxrandr>=1.3.0' 'libxi>=1.3' 'libxcomposite' 'libxdamage' 'heimdal>=1.3.2' 'gnutls>=2.8.6' 'shared-mime-info' 'cairo>=1.8.10' 'libtiff>=3.9.2-2' )
+makedepends=('pkgconfig' 'gtk-doc' 'gobject-introspection')
replaces=('gtkprint-cups' 'gail')
conflicts=('gtkprint-cups' 'gail')
provides=('gail=1.22.3')
options=('!libtool' '!docs')
backup=(etc/gtk-2.0/gtkrc)
license=('LGPL')
-source=(http://ftp.gnome.org/pub/gnome/sources/gtk+/2.16/gtk+-${pkgver}.tar.bz2
- gtkclipboard-check.patch)
-md5sums=('74e35ff3e6e02c960fe2117a4b6b102f'
- '4025d3c15d6c6f73a032f403ffd4ff1c')
+source=(http://ftp.gnome.org/pub/gnome/sources/gtk+/2.20/gtk+-${pkgver}.tar.bz2
+ xid-collision-debug.patch
+ revert_64bit_fix.patch)
+sha256sums=('0e081731d21e34ff45c82199490c2889504fa8b3c7e117c043e82ababaec0f65'
+ 'd758bb93e59df15a4ea7732cf984d1c3c19dff67c94b957575efea132b8fe558'
+ '20f3a03760f765b68b85b614810e5df4a689b609da1ae200aa30072475121b4c')
build() {
cd "${srcdir}/gtk+-${pkgver}"
- # Workaround patch for flash
- patch -Np1 -i "${srcdir}/gtkclipboard-check.patch" || return 1
+ patch -Np1 -i "${srcdir}/xid-collision-debug.patch" || return 1
+ patch -RNp1 -i ${srcdir}/revert_64bit_fix.patch || retun 1
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --with-xinput=yes \
- --without-libjasper \
- --with-included-loaders=png || return 1
+ CXX=/bin/false ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --with-xinput=yes \
+ --without-libjasper --without-cups\
+ --with-included-loaders=png || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
diff --git a/abs/core/gtk2/__changelog b/abs/core/gtk2/__changelog
new file mode 100644
index 0000000..1384183
--- /dev/null
+++ b/abs/core/gtk2/__changelog
@@ -0,0 +1 @@
+removed cups support -jm
diff --git a/abs/core/gtk2/revert_64bit_fix.patch b/abs/core/gtk2/revert_64bit_fix.patch
new file mode 100644
index 0000000..a6453e3
--- /dev/null
+++ b/abs/core/gtk2/revert_64bit_fix.patch
@@ -0,0 +1,31 @@
+From a0f23e1706b34bca6a65183040d1f1498cce2a50 Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Thu, 25 Mar 2010 04:55:15 +0000
+Subject: Fix a 64bit issue
+
+Thank you libpng, for typedef unsigned long png_uint_32.
+---
+diff --git a/gdk-pixbuf/io-png.c b/gdk-pixbuf/io-png.c
+index c0374ca..43db70a 100644
+--- a/gdk-pixbuf/io-png.c
++++ b/gdk-pixbuf/io-png.c
+@@ -261,7 +261,7 @@ gdk_pixbuf__png_image_load (FILE *f, GError **error)
+ gchar *icc_profile_base64;
+ const gchar *icc_profile_title;
+ const gchar *icc_profile;
+- guint icc_profile_size;
++ gulong icc_profile_size;
+ guint32 retval;
+ gint compression_type;
+
+@@ -607,7 +607,7 @@ png_info_callback (png_structp png_read_ptr,
+ gchar *icc_profile_base64;
+ const gchar *icc_profile_title;
+ const gchar *icc_profile;
+- guint icc_profile_size;
++ gulong icc_profile_size;
+ guint32 retval;
+ gint compression_type;
+
+--
+cgit v0.8.3.1
diff --git a/abs/core/gtk2/xid-collision-debug.patch b/abs/core/gtk2/xid-collision-debug.patch
new file mode 100644
index 0000000..d61238c
--- /dev/null
+++ b/abs/core/gtk2/xid-collision-debug.patch
@@ -0,0 +1,15 @@
+--- gtk+-2.18.3/gdk/x11/gdkxid.c 2009-06-19 04:59:18.000000000 +0200
++++ gtk+-2.18.3/gdk/x11/gdkxid.c.new 2009-07-22 11:30:12.000000000 +0200
+@@ -56,10 +56,10 @@
+ if (!display_x11->xid_ht)
+ display_x11->xid_ht = g_hash_table_new ((GHashFunc) gdk_xid_hash,
+ (GEqualFunc) gdk_xid_equal);
+-
++/*
+ if (g_hash_table_lookup (display_x11->xid_ht, xid))
+ g_warning ("XID collision, trouble ahead");
+-
++*/
+ g_hash_table_insert (display_x11->xid_ht, xid, data);
+ }
+