summaryrefslogtreecommitdiffstats
path: root/abs/core/heimdal
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/heimdal
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/heimdal')
-rw-r--r--abs/core/heimdal/002_all_heimdal-no_libedit.patch10
-rw-r--r--abs/core/heimdal/003_all_heimdal-fPIC.patch12
-rw-r--r--abs/core/heimdal/004_all_heimdal-rxapps.patch19
-rw-r--r--abs/core/heimdal/006_all_heimdal-suid_fix.patch20
-rw-r--r--abs/core/heimdal/010_all_heimdal-system-libss.patch40
-rw-r--r--abs/core/heimdal/PKGBUILD103
-rw-r--r--abs/core/heimdal/heimdal-kdc.rc40
-rw-r--r--abs/core/heimdal/kadmind.rc40
-rw-r--r--abs/core/heimdal/kpasswd.rc40
9 files changed, 324 insertions, 0 deletions
diff --git a/abs/core/heimdal/002_all_heimdal-no_libedit.patch b/abs/core/heimdal/002_all_heimdal-no_libedit.patch
new file mode 100644
index 0000000..7806597
--- /dev/null
+++ b/abs/core/heimdal/002_all_heimdal-no_libedit.patch
@@ -0,0 +1,10 @@
+--- cf/krb-readline.m4 2004-09-15 13:24:15.000000000 +0000
++++ cf/krb-readline.m4 2004-09-17 16:11:39.610756024 +0000
+@@ -6,7 +6,6 @@
+ dnl el_init
+
+ AC_DEFUN([KRB_READLINE],[
+-AC_FIND_FUNC_NO_LIBS(el_init, edit, [], [], [$LIB_tgetent])
+ if test "$ac_cv_func_el_init" = yes ; then
+ AC_CACHE_CHECK(for four argument el_init, ac_cv_func_el_init_four,[
+ AC_TRY_COMPILE([#include <stdio.h>
diff --git a/abs/core/heimdal/003_all_heimdal-fPIC.patch b/abs/core/heimdal/003_all_heimdal-fPIC.patch
new file mode 100644
index 0000000..ee01e34
--- /dev/null
+++ b/abs/core/heimdal/003_all_heimdal-fPIC.patch
@@ -0,0 +1,12 @@
+--- lib/editline/Makefile.am 2004-05-10 09:27:21.442490749 +0000
++++ lib/editline/Makefile.am 2004-05-10 09:27:38.876209101 +0000
+@@ -47,6 +47,9 @@
+
+ EXTRA_DIST = $(man_MANS)
+
++$(libeditline_la_OBJECTS): %.lo: %.c
++ $(LTCOMPILE) -fPIC -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
++
+ snprintf.c:
+ $(LN_S) $(srcdir)/../roken/snprintf.c .
+ strdup.c:
diff --git a/abs/core/heimdal/004_all_heimdal-rxapps.patch b/abs/core/heimdal/004_all_heimdal-rxapps.patch
new file mode 100644
index 0000000..d6142a7
--- /dev/null
+++ b/abs/core/heimdal/004_all_heimdal-rxapps.patch
@@ -0,0 +1,19 @@
+--- appl/kx/rxterm.in 2004-02-21 21:49:23.893934354 +0000
++++ appl/kx/rxterm.in 2004-02-21 21:49:34.617299076 +0000
+@@ -2,6 +2,6 @@
+ #
+ usage="Usage: $0 [-l username] [-k] [-f] [-r rsh_args] [-x xterm_args] [-K kx_args] [-w term_emulator] [-b rsh_binary][-v] [-h | --help] [--version] host"
+-binary=rsh
++binary=krsh
+ term=xterm
+ while true
+ do
+--- appl/kx/rxtelnet.in 2005-06-16 16:29:10.000000000 +0000
++++ appl/kx/rxtelnet.in 2005-07-11 20:33:10.000000000 +0000
+@@ -2,7 +2,7 @@
+ #
+ usage="Usage: $0 [-l username] [-k] [-fF] [-t args_to_telnet] [-x args_to_xterm] [-K args_to_kx] [-w term_emulator] [-b telnet_binary] [-n] [-v] [-h | --help] [--version] host [port]"
+-binary=telnet
++binary=ktelnet
+ term=
+ kx_args=-P
diff --git a/abs/core/heimdal/006_all_heimdal-suid_fix.patch b/abs/core/heimdal/006_all_heimdal-suid_fix.patch
new file mode 100644
index 0000000..0f7d281
--- /dev/null
+++ b/abs/core/heimdal/006_all_heimdal-suid_fix.patch
@@ -0,0 +1,20 @@
+--- appl/otp/Makefile.am 2004-09-17 22:22:54.046301075 +0000
++++ appl/otp/Makefile.am 2004-09-17 22:23:15.293145945 +0000
+@@ -8,6 +8,7 @@
+ bin_SUIDS = otp
+ otp_SOURCES = otp.c otp_locl.h
+ otpprint_SOURCES = otpprint.c otp_locl.h
++otp_LDFLAGS = -Wl,-z,now
+
+ man_MANS = otp.1 otpprint.1
+
+--- appl/su/Makefile.am 2005-06-16 16:27:46.000000000 +0000
++++ appl/su/Makefile.am 2005-07-11 20:34:21.000000000 +0000
+@@ -7,6 +7,7 @@
+ bin_PROGRAMS = su
+ bin_SUIDS = su
+ su_SOURCES = su.c
++su_LDFLAGS = -Wl,-z,now
+ man_MANS = su.1
+
+ LDADD = $(LIB_kafs) \
diff --git a/abs/core/heimdal/010_all_heimdal-system-libss.patch b/abs/core/heimdal/010_all_heimdal-system-libss.patch
new file mode 100644
index 0000000..5cd4d9d
--- /dev/null
+++ b/abs/core/heimdal/010_all_heimdal-system-libss.patch
@@ -0,0 +1,40 @@
+--- lib/sl/Makefile.am~ 2007-06-01 09:48:09.000000000 +0200
++++ lib/sl/Makefile.am 2007-06-01 09:49:30.000000000 +0200
+@@ -12,36 +12,24 @@
+
+ include_HEADERS = sl.h
+
+-lib_LTLIBRARIES = libsl.la libss.la
++lib_LTLIBRARIES = libsl.la
+ libsl_la_LDFLAGS = -version-info 2:0:2
+-libss_la_LDFLAGS = -version-info 1:5:1
+
+ libsl_la_LIBADD = @LIB_readline@
+-libss_la_LIBADD = @LIB_readline@ @LIB_com_err@
+
+ libsl_la_SOURCES = sl_locl.h sl.c $(ES)
+-libss_la_SOURCES = $(libsl_la_SOURCES) ss.c ss.h
+
+ TESTS = test_sl
+ check_PROGRAMS = $(TESTS)
+
+ # install these?
+
+-bin_PROGRAMS = mk_cmds
+ noinst_PROGRAMS = slc
+
+-mk_cmds_SOURCES = make_cmds.c make_cmds.h parse.y lex.l
+-mk_cmds_LDADD = libsl.la $(LDADD)
+-
+ slc_SOURCES = slc-gram.y slc-lex.l slc.h
+
+-ssincludedir = $(includedir)/ss
+-ssinclude_HEADERS = ss.h
+-
+ CLEANFILES = lex.c parse.c parse.h snprintf.c strtok_r.c strdup.c strupr.c getprogname.c
+
+-$(mk_cmds_OBJECTS): parse.h parse.c
+-
+ LDADD = \
+ libsl.la \
+ $(LIB_roken) \
diff --git a/abs/core/heimdal/PKGBUILD b/abs/core/heimdal/PKGBUILD
new file mode 100644
index 0000000..4c79af6
--- /dev/null
+++ b/abs/core/heimdal/PKGBUILD
@@ -0,0 +1,103 @@
+# $Id: PKGBUILD 3738 2008-06-30 20:03:06Z andyrtr $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+#
+### Attention: build it 2 times - it links against itself! ###
+# ^ better remove old pkg before ;)
+
+pkgname=heimdal
+pkgver=1.2
+pkgrel=1
+pkgdesc="Heimdal Kerberos V5 libraries"
+arch=(i686 x86_64)
+url="http://www.pdc.kth.se/heimdal/"
+license=('custom')
+depends=('db>=4.7' 'openssl' 'e2fsprogs')
+options=('!libtool' '!emptydirs')
+backup=(etc/krb5.conf)
+source=(http://www.h5l.org/dist/src/heimdal-$pkgver.tar.gz \
+ 002_all_heimdal-no_libedit.patch \
+ 003_all_heimdal-fPIC.patch \
+ 004_all_heimdal-rxapps.patch \
+ #006_all_heimdal-suid_fix.patch \
+ heimdal-kdc.rc \
+ kadmind.rc \
+ kpasswd.rc)
+md5sums=('8d6b690069acd2ae8ada1315174f52f9'
+ '1199c4a4a38e9c2b2c0a99bd5781767a'
+ '3d0262aa218e1611500de735d3581e28'
+ '0fe81cb1e33b2a2e60edaf47dfdfe4de'
+ #'30372b1581e4d49a76688e450fd42443'
+ 'e59650992b9541a30dfce727a194f6e0'
+ '1f2f86a67bbfddb7af581d35fdca9627'
+ 'f8f1eca95b9d3f2b4ebf2417b71b81cf')
+
+build() {
+ [ -e /usr/lib/libasn1.so ] && echo "## remove old heimdal pkg first ##" && return 1
+
+ cd ${srcdir}/heimdal-${pkgver}
+ patch -Np0 -i ${srcdir}/002_all_heimdal-no_libedit.patch || return 1
+ patch -Np0 -i ${srcdir}/003_all_heimdal-fPIC.patch || return 1
+ patch -Np0 -i ${srcdir}/004_all_heimdal-rxapps.patch || return 1
+# patch -Np0 -i ${srcdir}/006_all_heimdal-suid_fix.patch || return 1
+
+# libtoolize -f -c || return 1
+# aclocal -I cf || return 1
+# autoheader || return 1
+# automake -a || return 1
+# autoconf || return 1
+# libtoolize -f -c || return 1
+
+# autoreconf || return 1
+# libtoolize -f -c || return 1
+
+ sed -i -e 's|var/heimdal|var/lib/heimdal|g' configure.in configure \
+ doc/setup.texi doc/heimdal.info kadmin/kadmind.8 kdc/kdc.8 \
+ lib/hdb/hdb.h lib/krb5/krb5.conf.5 lib/krb5/krb5.conf.cat5
+
+ ./configure --prefix=/usr --enable-shared=yes --without-x \
+ --sysconfdir=/etc --mandir=/usr/man \
+ --datadir=/var/lib/heimdal \
+ --localstatedir=/var/lib/heimdal \
+ --with-openssl=/usr \
+ --with-readline-lib=/usr/lib \
+ --with-readline-include=/usr/include/readline \
+ --libexecdir=/usr/sbin --with-berkeley-db \
+ --disable-krb4
+
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ for i in telnetd ftpd rshd; do
+ mv ${pkgdir}/usr/man/man8/${i}.8 ${pkgdir}/usr/man/man8/k${i}.8
+ mv ${pkgdir}/usr/sbin/${i} ${pkgdir}/usr/sbin/k${i}
+ done
+
+ for i in rcp rsh telnet ftp su login; do
+ if [ -f ${pkgdir}/usr/man/man1/${i}.1 ]; then
+ mv ${pkgdir}/usr/man/man1/${i}.1 ${pkgdir}/usr/man/man1/k${i}.1
+ fi
+ mv ${pkgdir}/usr/bin/${i} ${pkgdir}/usr/bin/k${i}
+ done
+ rm -rf ${pkgdir}/usr/man/cat{1,3,5,8}
+
+ #Arch could be a KDC too
+ mkdir -p ${pkgdir}/etc/rc.d
+ install -m644 ${srcdir}/heimdal-${pkgver}/krb5.conf ${pkgdir}/etc
+ for i in heimdal-kdc kadmind kpasswd; do
+ install -m755 ${srcdir}/${i}.rc ${pkgdir}/etc/rc.d/${i}
+ done
+
+ #Remove some conflicts
+ rm ${pkgdir}/usr/man/man5/ftpusers.5*
+ rm ${pkgdir}/usr/man/man5/login.access.5*
+ # and some more
+ rm ${pkgdir}/usr/bin/mk_cmds
+ rm ${pkgdir}/usr/include/ss/ss.h
+ rm ${pkgdir}/usr/lib/libss.a
+ rm ${pkgdir}/usr/lib/libss.so
+
+ # install the license
+ install -D -m644 ${srcdir}/${pkgname}-${pkgver}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/abs/core/heimdal/heimdal-kdc.rc b/abs/core/heimdal/heimdal-kdc.rc
new file mode 100644
index 0000000..b2a3b5f
--- /dev/null
+++ b/abs/core/heimdal/heimdal-kdc.rc
@@ -0,0 +1,40 @@
+#!/bin/bash
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/kdc`
+case "$1" in
+ start)
+ stat_busy "Starting heimdal kdc"
+ if [ -z "$PID" ]; then
+ /usr/sbin/kdc --detach
+ fi
+ if [ ! -z "$PID" -o $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon heimdal-kdc
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping heimdal kdc"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon heimdal-kdc
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+ ;;
+esac
+exit 0
diff --git a/abs/core/heimdal/kadmind.rc b/abs/core/heimdal/kadmind.rc
new file mode 100644
index 0000000..0f3b8c7
--- /dev/null
+++ b/abs/core/heimdal/kadmind.rc
@@ -0,0 +1,40 @@
+#!/bin/bash
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/kadmind`
+case "$1" in
+ start)
+ stat_busy "Starting heimdal admin server"
+ if [ -z "$PID" ]; then
+ /usr/sbin/kadmind &
+ fi
+ if [ ! -z "$PID" -o $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon kadmind
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping heimdal admin server"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon kadmind
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+ ;;
+esac
+exit 0
diff --git a/abs/core/heimdal/kpasswd.rc b/abs/core/heimdal/kpasswd.rc
new file mode 100644
index 0000000..3697322
--- /dev/null
+++ b/abs/core/heimdal/kpasswd.rc
@@ -0,0 +1,40 @@
+#!/bin/bash
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/kpasswdd`
+case "$1" in
+ start)
+ stat_busy "Starting heimdal kpasswdd"
+ if [ -z "$PID" ]; then
+ /usr/sbin/kpasswdd &
+ fi
+ if [ ! -z "$PID" -o $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon kpasswd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping heimdal kpasswdd"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon kpasswd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+ ;;
+esac
+exit 0