summaryrefslogtreecommitdiffstats
path: root/abs/core/iana-etc
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/iana-etc
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/iana-etc')
-rw-r--r--abs/core/iana-etc/Makefile.patch11
-rw-r--r--abs/core/iana-etc/PKGBUILD31
2 files changed, 42 insertions, 0 deletions
diff --git a/abs/core/iana-etc/Makefile.patch b/abs/core/iana-etc/Makefile.patch
new file mode 100644
index 0000000..b25bc26
--- /dev/null
+++ b/abs/core/iana-etc/Makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2010-07-23 04:16:11.000000000 -0300
++++ Makefile 2010-07-23 04:16:11.000000000 -0300
+@@ -42,7 +42,7 @@
+ protocol-numbers.iana port-numbers.iana
+
+ protocol-numbers.iana:
+- $(AWK) -f get.gawk -v file=protocol-numbers >protocol-numbers.iana
++ $(AWK) -f get.gawk -v file=protocol-numbers/protocol-numbers.txt >protocol-numbers.iana
+ rm -f protocol-numbers
+
+ port-numbers.iana:
diff --git a/abs/core/iana-etc/PKGBUILD b/abs/core/iana-etc/PKGBUILD
new file mode 100644
index 0000000..1c528a6
--- /dev/null
+++ b/abs/core/iana-etc/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 86037 2010-07-23 23:13:34Z thomas $
+# Maintainer: Thomas Bächler <thomas@archlinux.org>
+pkgname=iana-etc
+pkgver=2.30
+pkgrel=1
+pkgdesc="/etc/protocols and /etc/services provided by IANA"
+arch=('any')
+url="http://sethwklein.net/iana-etc"
+license=('custom')
+makedepends=('awk')
+source=(http://sethwklein.net/$pkgname-$pkgver.tar.bz2
+ Makefile.patch)
+sha256sums=('b9a6874fb20012836efef75452ef2acae624022d680feeb1994d73facba3f20d'
+ '3e6db7adb8a67b765b8be65825f2a0e6c525eb42367385193c678af6b75d0321')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p0 -i "$srcdir/Makefile.patch"
+ make get
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/iana-etc/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: