summaryrefslogtreecommitdiffstats
path: root/abs/core/imagemagick
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-03 23:53:46 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-03 23:53:46 (GMT)
commit8f53d430ab53cfd7f26b914bc1860f0273164373 (patch)
treec9ecf5c946177ea5f60a1052557005ded90a7966 /abs/core/imagemagick
parent2a663ad7b99d1642b8739dd78e04e8e83b8d6704 (diff)
downloadlinhes_pkgbuild-8f53d430ab53cfd7f26b914bc1860f0273164373.zip
linhes_pkgbuild-8f53d430ab53cfd7f26b914bc1860f0273164373.tar.gz
linhes_pkgbuild-8f53d430ab53cfd7f26b914bc1860f0273164373.tar.bz2
imagemagick: update to 6.9.0.0
Diffstat (limited to 'abs/core/imagemagick')
-rw-r--r--abs/core/imagemagick/PKGBUILD92
-rw-r--r--abs/core/imagemagick/perlmagick.rpath.patch13
2 files changed, 57 insertions, 48 deletions
diff --git a/abs/core/imagemagick/PKGBUILD b/abs/core/imagemagick/PKGBUILD
index e2426fc..4080a3b 100644
--- a/abs/core/imagemagick/PKGBUILD
+++ b/abs/core/imagemagick/PKGBUILD
@@ -1,82 +1,90 @@
-# $Id: PKGBUILD 163750 2012-07-19 04:55:07Z eric $
+# $Id$
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgbase=imagemagick
pkgname=('imagemagick' 'imagemagick-doc')
-pkgver=6.7.8.7
+pkgver=6.9.0.0
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"
license=('custom')
-makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript' \
- 'openexr' 'libwmf' 'librsvg' 'libxml2' 'jasper' 'liblqr')
-source=(ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz \
+makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript'
+ 'openexr' 'libwmf' 'librsvg' 'libxml2' 'liblqr' 'openjpeg2'
+ 'opencl-headers' 'libcl' 'libwebp' 'subversion')
+#source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
+source=(ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
perlmagick.rpath.patch)
+sha1sums=('6bf4263ceaeea61e00fe15a95db320d49bcc48c4'
+ 'SKIP'
+ 'e143cf9d530fabf3b58023899b5cc544ba93daec')
-build() {
- cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
-
+prepare() {
+ cd ImageMagick-${pkgver%.*}-${pkgver##*.}
sed '/AC_PATH_XTRA/d' -i configure.ac
- autoreconf --install
- patch -p0 -i ../perlmagick.rpath.patch
+ autoreconf --force --install
+ patch -p0 -i "${srcdir}/perlmagick.rpath.patch"
+}
+
+build() {
+ cd ImageMagick-${pkgver%.*}-${pkgver##*.}
+ [[ $CARCH = "i686" ]] && EXTRAOPTS="--with-gcc-arch=i686"
+ [[ $CARCH = "x86_64" ]] && EXTRAOPTS="--with-gcc-arch=x86-64"
- ./configure --prefix=/usr --sysconfdir=/etc --with-modules --disable-static \
- --disable-openmp --with-wmf --with-openexr --with-xml --with-lcms2 --with-jp2 \
- --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
- --with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr \
- --without-gvc --without-djvu --without-autotrace --without-webp \
- --without-jbig --without-fpx --without-dps --without-fftw
+ ./configure --prefix=/usr --sysconfdir=/etc --with-modules \
+ --enable-hdri --with-wmf --with-openexr --with-xml --with-lcms2 \
+ --with-webp --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
+ --with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr --with-rsvg \
+ --enable-opencl --with-openjp2 --without-gvc --without-djvu --without-autotrace \
+ --without-jbig --without-fpx --without-dps --without-fftw $EXTRAOPTS
make
}
check() {
- cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
- make check
+ cd ImageMagick-${pkgver%.*}-${pkgver##*.}
+# make check
}
package_imagemagick() {
pkgdesc="An image viewing/manipulation program"
- depends=('perl' 'libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr')
- optdepends=('ghostscript: for Ghostscript support'
+ depends=('perl' 'libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr' 'libcl')
+ optdepends=('imagemagick-doc: for additional information'
+ 'ghostscript: for Ghostscript support'
'openexr: for OpenEXR support'
+ 'openjpeg2: for JP2 support'
'libwmf: for WMF support'
'librsvg: for SVG support'
'libxml2: for XML support'
- 'jasper: for JPEG-2000 support'
- 'libpng: for PNG support')
- backup=('etc/ImageMagick/coder.xml'
- 'etc/ImageMagick/colors.xml'
- 'etc/ImageMagick/delegates.xml'
- 'etc/ImageMagick/log.xml'
- 'etc/ImageMagick/magic.xml'
- 'etc/ImageMagick/mime.xml'
- 'etc/ImageMagick/policy.xml'
- 'etc/ImageMagick/quantization-table.xml'
- 'etc/ImageMagick/thresholds.xml'
- 'etc/ImageMagick/type.xml'
- 'etc/ImageMagick/type-dejavu.xml'
- 'etc/ImageMagick/type-ghostscript.xml'
- 'etc/ImageMagick/type-windows.xml')
+ 'libpng: for PNG support'
+ 'libwebp: for WEBP support')
+ backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
+ "etc/ImageMagick-${pkgver%%.*}/colors.xml"
+ "etc/ImageMagick-${pkgver%%.*}/delegates.xml"
+ "etc/ImageMagick-${pkgver%%.*}/log.xml"
+ "etc/ImageMagick-${pkgver%%.*}/magic.xml"
+ "etc/ImageMagick-${pkgver%%.*}/mime.xml"
+ "etc/ImageMagick-${pkgver%%.*}/policy.xml"
+ "etc/ImageMagick-${pkgver%%.*}/quantization-table.xml"
+ "etc/ImageMagick-${pkgver%%.*}/thresholds.xml"
+ "etc/ImageMagick-${pkgver%%.*}/type.xml"
+ "etc/ImageMagick-${pkgver%%.*}/type-dejavu.xml"
+ "etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
+ "etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
options=('!docs' 'libtool' '!emptydirs')
- cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
- make DESTDIR="${pkgdir}" install
- chmod 755 "${pkgdir}/usr/lib/perl5/vendor_perl/auto/Image/Magick/Magick.so"
+ cd ImageMagick-${pkgver%.*}-${pkgver##*.}
+ make -j1 DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick/LICENSE"
install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick/NOTICE"
#Cleaning
- find "${pkgdir}" -name '*.bs' -delete
rm -f "${pkgdir}"/usr/lib/*.la
}
package_imagemagick-doc() {
pkgdesc="The ImageMagick documentation (utilities manuals and libraries API)"
- cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
+ cd ImageMagick-${pkgver%.*}-${pkgver##*.}
make DESTDIR="${pkgdir}" install-data-html
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick-doc/LICENSE"
install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick-doc/NOTICE"
}
-md5sums=('c12aa1fafac9ebdca42464ba872fac86'
- 'ff9974decbfe9846f8e347239d87e4eb')
diff --git a/abs/core/imagemagick/perlmagick.rpath.patch b/abs/core/imagemagick/perlmagick.rpath.patch
index 958c0f2..a5b1a82 100644
--- a/abs/core/imagemagick/perlmagick.rpath.patch
+++ b/abs/core/imagemagick/perlmagick.rpath.patch
@@ -1,10 +1,11 @@
---- Makefile.in.orig 2009-05-26 16:22:11.000000000 -0300
-+++ Makefile.in 2009-05-26 16:23:27.000000000 -0300
-@@ -10067,6 +10067,7 @@
+--- Makefile.in.orig 2013-02-21 03:26:56.785156600 -0500
++++ Makefile.in 2013-02-21 03:39:03.102411457 -0500
+@@ -10469,6 +10469,8 @@
- @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@$(PERLMAKEFILE): perl-sources $(PERLMAKEMAKER)
+ @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@$(PERLMAKEFILE): perl-sources $(MAGICKCORE_LIBS) $(MAGICKWAND_LIBS) $(PERLMAKEMAKER)
@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @PERL@ Makefile.PL $(PERL_MAKE_OPTIONS)
+@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @SED@ -i 's|LD_RUN_PATH|DIE_LD_RUN_PATH_DIE|g' Makefile
++@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @SED@ -i 's|LD_RUN_PATH|DIE_LD_RUN_PATH_DIE|g' quantum/Makefile
- @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@install-exec-perl: $(MAGICKCORE_LIBS) $(MAGICKWAND_LIBS) $(PERLMAKEFILE)
- @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && $(MAKE) CC='@CC@' install
+ @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@install-exec-perl: $(PERLMAKEFILE)
+ @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ ( cd $(PERLMAGICK) && $(MAKE) CC='@CC@' && \