summaryrefslogtreecommitdiffstats
path: root/abs/core/imagemagick
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-28 20:31:51 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-28 20:31:51 (GMT)
commitfec374317980ecfa8b6982b8d9980fdccdb4ed76 (patch)
tree58bf9f97360fe61bd870823c05e5db22cf52002a /abs/core/imagemagick
parent7060c58c78e966fad532fb01ea538b4a6a98fc93 (diff)
downloadlinhes_pkgbuild-fec374317980ecfa8b6982b8d9980fdccdb4ed76.zip
linhes_pkgbuild-fec374317980ecfa8b6982b8d9980fdccdb4ed76.tar.gz
linhes_pkgbuild-fec374317980ecfa8b6982b8d9980fdccdb4ed76.tar.bz2
imagemagick: update to 7.0.7.24
Diffstat (limited to 'abs/core/imagemagick')
-rw-r--r--abs/core/imagemagick/PKGBUILD189
-rw-r--r--abs/core/imagemagick/arch-fonts.diff107
-rw-r--r--abs/core/imagemagick/perlmagick.rpath.patch11
3 files changed, 227 insertions, 80 deletions
diff --git a/abs/core/imagemagick/PKGBUILD b/abs/core/imagemagick/PKGBUILD
index 4080a3b..228f1fc 100644
--- a/abs/core/imagemagick/PKGBUILD
+++ b/abs/core/imagemagick/PKGBUILD
@@ -2,89 +2,140 @@
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgbase=imagemagick
-pkgname=('imagemagick' 'imagemagick-doc')
-pkgver=6.9.0.0
+pkgname=(libmagick imagemagick imagemagick-doc)
+pkgver=7.0.7.24
pkgrel=1
-arch=('i686' 'x86_64')
-url="http://www.imagemagick.org/"
-license=('custom')
-makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript'
- 'openexr' 'libwmf' 'librsvg' 'libxml2' 'liblqr' 'openjpeg2'
- 'opencl-headers' 'libcl' 'libwebp' 'subversion')
-#source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
-source=(ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
- perlmagick.rpath.patch)
-sha1sums=('6bf4263ceaeea61e00fe15a95db320d49bcc48c4'
- 'SKIP'
- 'e143cf9d530fabf3b58023899b5cc544ba93daec')
+pkgdesc="An image viewing/manipulation program"
+url="https://www.imagemagick.org/"
+arch=(x86_64)
+license=(custom)
+depends=(libltdl lcms2 fontconfig libxext liblqr libraqm libpng)
+makedepends=(ghostscript openexr libwmf librsvg libxml2 openjpeg2 libraw opencl-headers libwebp
+ chrpath ocl-icd glu ghostpcl ghostxps)
+checkdepends=(gsfonts ttf-dejavu)
+_relname=ImageMagick-${pkgver%%.*}
+_tarname=ImageMagick-${pkgver%.*}-${pkgver##*.}
+source=(https://www.imagemagick.org/download/$_tarname.tar.xz{,.asc}
+ arch-fonts.diff)
+sha256sums=('2f83f8a1b7725e9d96a6f4ddf8dd2e70d44bc039bdc32f056805ab4d0f7485fb'
+ 'SKIP'
+ 'a85b744c61b1b563743ecb7c7adad999d7ed9a8af816650e3ab9321b2b102e73')
+validpgpkeys=(D8272EF51DA223E4D05B466989AB63D48277377A) # Lexie Parsimoniae
+
+shopt -s extglob
prepare() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- sed '/AC_PATH_XTRA/d' -i configure.ac
- autoreconf --force --install
- patch -p0 -i "${srcdir}/perlmagick.rpath.patch"
+ mkdir -p binpkg/usr/lib/pkgconfig {binpkg,docpkg}/usr/share
+
+ cd $_tarname
+
+ # Fix up typemaps to match our packages, where possible
+ patch -Np1 -i ../arch-fonts.diff
+
+ # Don't run auto(re)conf; assumes use of git
}
build() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- [[ $CARCH = "i686" ]] && EXTRAOPTS="--with-gcc-arch=i686"
- [[ $CARCH = "x86_64" ]] && EXTRAOPTS="--with-gcc-arch=x86-64"
-
- ./configure --prefix=/usr --sysconfdir=/etc --with-modules \
- --enable-hdri --with-wmf --with-openexr --with-xml --with-lcms2 \
- --with-webp --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
- --with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr --with-rsvg \
- --enable-opencl --with-openjp2 --without-gvc --without-djvu --without-autotrace \
- --without-jbig --without-fpx --without-dps --without-fftw $EXTRAOPTS
+ cd $_tarname
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-dejavu-font-dir=/usr/share/fonts/TTF \
+ --with-gs-font-dir=/usr/share/fonts/gsfonts \
+ PSDelegate=/usr/bin/gs \
+ XPSDelegate=/usr/bin/gxps \
+ PCLDelegate=/usr/bin/gpcl6 \
+ --enable-hdri \
+ --enable-opencl \
+ --with-gslib \
+ --with-lqr \
+ --with-modules \
+ --with-openexr \
+ --with-openjp2 \
+ --with-perl \
+ --with-perl-options=INSTALLDIRS=vendor \
+ --with-rsvg \
+ --with-webp \
+ --with-wmf \
+ --with-xml \
+ --without-autotrace \
+ --without-djvu \
+ --without-dps \
+ --without-fftw \
+ --without-fpx \
+ --without-gcc-arch \
+ --without-gvc \
+ --without-jbig
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
-check() {
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
-# make check
+check() (
+ cd $_tarname
+ ulimit -n 4096
+ make check
+)
+
+package_libmagick() {
+ pkgdesc+=" (library)"
+ optdepends=('ghostscript: PS/PDF support'
+ 'libraw: DNG support'
+ 'librsvg: SVG support'
+ 'libwebp: WEBP support'
+ 'libwmf: WMF support'
+ 'libxml2: Magick Scripting Language'
+ 'ocl-icd: OpenCL support'
+ 'openexr: OpenEXR support'
+ 'openjpeg2: JPEG2000 support'
+ 'pango: Text rendering')
+ backup=(etc/$_relname/{coder,colors,delegates,log,magic,mime,policy,quantization-table,thresholds,type,type-{dejavu,ghostscript}}.xml)
+ options=('!emptydirs' libtool)
+
+ cd $_tarname
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir"/etc/$_relname/type-{apple,urw-base35,windows}.xml
+ rm "$pkgdir"/usr/lib/*.la
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE NOTICE
+
+# Split 'imagemagick'
+ cd ../binpkg
+ mv "$pkgdir/usr/bin" usr/
+ mv "$pkgdir/usr/lib/perl5" usr/lib/
+ mv "$pkgdir/usr/share/man" usr/share/
+
+# Split docs
+ mv "$pkgdir/usr/share/doc" "$srcdir/docpkg/usr/share/"
}
package_imagemagick() {
- pkgdesc="An image viewing/manipulation program"
- depends=('perl' 'libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr' 'libcl')
- optdepends=('imagemagick-doc: for additional information'
- 'ghostscript: for Ghostscript support'
- 'openexr: for OpenEXR support'
- 'openjpeg2: for JP2 support'
- 'libwmf: for WMF support'
- 'librsvg: for SVG support'
- 'libxml2: for XML support'
- 'libpng: for PNG support'
- 'libwebp: for WEBP support')
- backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
- "etc/ImageMagick-${pkgver%%.*}/colors.xml"
- "etc/ImageMagick-${pkgver%%.*}/delegates.xml"
- "etc/ImageMagick-${pkgver%%.*}/log.xml"
- "etc/ImageMagick-${pkgver%%.*}/magic.xml"
- "etc/ImageMagick-${pkgver%%.*}/mime.xml"
- "etc/ImageMagick-${pkgver%%.*}/policy.xml"
- "etc/ImageMagick-${pkgver%%.*}/quantization-table.xml"
- "etc/ImageMagick-${pkgver%%.*}/thresholds.xml"
- "etc/ImageMagick-${pkgver%%.*}/type.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-dejavu.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
- "etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
- options=('!docs' 'libtool' '!emptydirs')
-
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- make -j1 DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick/LICENSE"
- install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick/NOTICE"
-
-#Cleaning
- rm -f "${pkgdir}"/usr/lib/*.la
+ depends=("libmagick=$pkgver-$pkgrel")
+ optdepends=('imagemagick-doc: manual and API docs')
+ options=('!emptydirs')
+
+ mv binpkg/* "$pkgdir"
+
+ find "$pkgdir/usr/lib/perl5" -name '*.so' -exec chrpath -d {} +
+
+# template start; name=perl-binary-module-dependency; version=1;
+if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+ _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+ _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+ depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+fi
+# template end;
+
+ cd $_tarname
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE NOTICE
}
package_imagemagick-doc() {
- pkgdesc="The ImageMagick documentation (utilities manuals and libraries API)"
+ pkgdesc+=" (manual and API docs)"
+ depends=()
+
+ mv docpkg/* "$pkgdir"
- cd ImageMagick-${pkgver%.*}-${pkgver##*.}
- make DESTDIR="${pkgdir}" install-data-html
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick-doc/LICENSE"
- install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick-doc/NOTICE"
+ cd $_tarname
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 LICENSE NOTICE
}
diff --git a/abs/core/imagemagick/arch-fonts.diff b/abs/core/imagemagick/arch-fonts.diff
new file mode 100644
index 0000000..63a547c
--- /dev/null
+++ b/abs/core/imagemagick/arch-fonts.diff
@@ -0,0 +1,107 @@
+diff -u -r ImageMagick-6.9.9-25/config/type-dejavu.xml.in ImageMagick-6.9.9-25-archfonts/config/type-dejavu.xml.in
+--- ImageMagick-6.9.9-25/config/type-dejavu.xml.in 2017-11-30 19:24:05.000000000 +0100
++++ ImageMagick-6.9.9-25-archfonts/config/type-dejavu.xml.in 2017-12-02 18:44:53.410304554 +0100
+@@ -13,27 +13,6 @@
+ ImageMagick DejaVU font configuration.
+ -->
+ <typemap>
+- <type name="DejaVu-LGC-Sans-Bold" fullname="DejaVu LGC Sans Bold" family="DejaVuGC Sans" style="Normal" stretch="Normal" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSans-Bold.ttf"/>
+- <type name="DejaVu-LGC-Sans-Bold-Oblique" fullname="DejaVu LGC Sans Bold Oblique" family="DejaVuGC Sans" style="Oblique" stretch="Normal" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSans-BoldOblique.ttf"/>
+- <type name="DejaVu-LGC-Sans-Book" fullname="DejaVu LGC Sans Book" family="DejaVuGC Sans" style="Normal" stretch="Normal" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSans.ttf"/>
+- <type name="DejaVu-LGC-Sans-Condensed" fullname="DejaVu LGC Sans Condensed" family="DejaVuGC Sans" style="Normal" stretch="SemiCondensed" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSansCondensed.ttf"/>
+- <type name="DejaVu-LGC-Sans-Condensed-Bold" fullname="DejaVu LGC Sans Condensed Bold" family="DejaVuGC Sans" style="Normal" stretch="SemiCondensed" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSansCondensed-Bold.ttf"/>
+- <type name="DejaVu-LGC-Sans-Condensed-Bold-Oblique" fullname="DejaVu LGC Sans Condensed Bold Oblique" family="DejaVuGC Sans" style="Oblique" stretch="SemiCondensed" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSansCondensed-BoldOblique.ttf"/>
+- <type name="DejaVu-LGC-Sans-Condensed-Oblique" fullname="DejaVu LGC Sans Condensed Oblique" family="DejaVuGC Sans" style="Oblique" stretch="SemiCondensed" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSansCondensed-Oblique.ttf"/>
+- <type name="DejaVu-LGC-Sans-ExtraLight" fullname="DejaVu LGC Sans ExtraLight" family="DejaVuGC Sans" style="Normal" stretch="Normal" weight="200" glyphs="@dejavu_font_dir@DejaVuLGCSans-ExtraLight.ttf"/>
+- <type name="DejaVu-LGC-Sans-Mono-Bold" fullname="DejaVu LGC Sans Mono Bold" family="DejaVuGC Sans Mono" style="Normal" stretch="Normal" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSansMono-Bold.ttf"/>
+- <type name="DejaVu-LGC-Sans-Mono-Bold-Oblique" fullname="DejaVu LGC Sans Mono Bold Oblique" family="DejaVuGC Sans Mono" style="Oblique" stretch="Normal" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSansMono-BoldOblique.ttf"/>
+- <type name="DejaVu-LGC-Sans-Mono-Book" fullname="DejaVu LGC Sans Mono Book" family="DejaVuGC Sans Mono" style="Normal" stretch="Normal" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSansMono.ttf"/>
+- <type name="DejaVu-LGC-Sans-Mono-Oblique" fullname="DejaVu LGC Sans Mono Oblique" family="DejaVuGC Sans Mono" style="Oblique" stretch="Normal" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSansMono-Oblique.ttf"/>
+- <type name="DejaVu-LGC-Sans-Oblique" fullname="DejaVu LGC Sans Oblique" family="DejaVuGC Sans" style="Oblique" stretch="Normal" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSans-Oblique.ttf"/>
+- <type name="DejaVu-LGC-Serif-Bold" fullname="DejaVu LGC Serif Bold" family="DejaVuGC Serif" style="Normal" stretch="Normal" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSerif-Bold.ttf"/>
+- <type name="DejaVu-LGC-Serif-Bold-Italic" fullname="DejaVu LGC Serif Bold Italic" family="DejaVuGC Serif" style="Italic" stretch="Normal" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSerif-BoldItalic.ttf"/>
+- <type name="DejaVu-LGC-Serif-Book" fullname="DejaVu LGC Serif Book" family="DejaVuGC Serif" style="Normal" stretch="Normal" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSerif.ttf"/>
+- <type name="DejaVu-LGC-Serif-Condensed" fullname="DejaVu LGC Serif Condensed" family="DejaVuGC Serif" style="Normal" stretch="SemiCondensed" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSerifCondensed.ttf"/>
+- <type name="DejaVu-LGC-Serif-Condensed-Bold" fullname="DejaVu LGC Serif Condensed Bold" family="DejaVuGC Serif" style="Normal" stretch="SemiCondensed" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSerifCondensed-Bold.ttf"/>
+- <type name="DejaVu-LGC-Serif-Condensed-Bold-Italic" fullname="DejaVu LGC Serif Condensed Bold Italic" family="DejaVuGC Serif" style="Italic" stretch="SemiCondensed" weight="700" glyphs="@dejavu_font_dir@DejaVuLGCSerifCondensed-BoldItalic.ttf"/>
+- <type name="DejaVu-LGC-Serif-Condensed-Italic" fullname="DejaVu LGC Serif -Condensed Italic" family="DejaVuGC Serif" style="Italic" stretch="SemiCondensed" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSerifCondensed-Italic.ttf"/>
+- <type name="DejaVu-LGC-Serif-Italic" fullname="DejaVu LGC Serif Italic" family="DejaVuGC Serif" style="Italic" stretch="Normal" weight="400" glyphs="@dejavu_font_dir@DejaVuLGCSerif-Italic.ttf"/>
+ <type name="DejaVu-Sans-Bold" fullname="DejaVu Sans Bold" family="DejaVu Sans" style="Normal" stretch="Normal" weight="700" glyphs="@dejavu_font_dir@DejaVuSans-Bold.ttf"/>
+ <type name="DejaVu-Sans-Bold-Oblique" fullname="DejaVu Sans Bold Oblique" family="DejaVu Sans" style="Oblique" stretch="Normal" weight="700" glyphs="@dejavu_font_dir@DejaVuSans-BoldOblique.ttf"/>
+ <type name="DejaVu-Sans-Book" fullname="DejaVu Sans Book" family="DejaVu Sans" style="Normal" stretch="Normal" weight="400" glyphs="@dejavu_font_dir@DejaVuSans.ttf"/>
+diff -u -r ImageMagick-6.9.9-25/config/type-ghostscript.xml.in ImageMagick-6.9.9-25-archfonts/config/type-ghostscript.xml.in
+--- ImageMagick-6.9.9-25/config/type-ghostscript.xml.in 2017-11-30 19:24:05.000000000 +0100
++++ ImageMagick-6.9.9-25-archfonts/config/type-ghostscript.xml.in 2017-12-02 19:08:05.669243822 +0100
+@@ -13,38 +13,38 @@
+ ImageMagick Ghostscript font configuration.
+ -->
+ <typemap>
+- <type name="AvantGarde-Book" fullname="AvantGarde Book" family="AvantGarde" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@a010013l.afm" glyphs="@ghostscript_font_dir@a010013l.pfb"/>
+- <type name="AvantGarde-BookOblique" fullname="AvantGarde Book Oblique" family="AvantGarde" foundry="URW" weight="400" style="oblique" stretch="normal" format="type1" metrics="@ghostscript_font_dir@a010033l.afm" glyphs="@ghostscript_font_dir@a010033l.pfb"/>
+- <type name="AvantGarde-Demi" fullname="AvantGarde DemiBold" family="AvantGarde" foundry="URW" weight="600" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@a010015l.afm" glyphs="@ghostscript_font_dir@a010015l.pfb"/>
+- <type name="AvantGarde-DemiOblique" fullname="AvantGarde DemiOblique" family="AvantGarde" foundry="URW" weight="600" style="oblique" stretch="normal" format="type1" metrics="@ghostscript_font_dir@a010035l.afm" glyphs="@ghostscript_font_dir@a010035l.pfb"/>
+- <type name="Bookman-Demi" fullname="Bookman DemiBold" family="Bookman" foundry="URW" weight="600" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@b018015l.afm" glyphs="@ghostscript_font_dir@b018015l.pfb"/>
+- <type name="Bookman-DemiItalic" fullname="Bookman DemiBold Italic" family="Bookman" foundry="URW" weight="600" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@b018035l.afm" glyphs="@ghostscript_font_dir@b018035l.pfb"/>
+- <type name="Bookman-Light" fullname="Bookman Light" family="Bookman" foundry="URW" weight="300" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@b018012l.afm" glyphs="@ghostscript_font_dir@b018012l.pfb"/>
+- <type name="Bookman-LightItalic" fullname="Bookman Light Italic" family="Bookman" foundry="URW" weight="300" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@b018032l.afm" glyphs="@ghostscript_font_dir@b018032l.pfb"/>
+- <type name="Courier" fullname="Courier Regular" family="Courier" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n022003l.afm" glyphs="@ghostscript_font_dir@n022003l.pfb"/>
+- <type name="Courier-Bold" fullname="Courier Bold" family="Courier" foundry="URW" weight="700" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n022004l.afm" glyphs="@ghostscript_font_dir@n022004l.pfb"/>
+- <type name="Courier-Oblique" fullname="Courier Regular Oblique" family="Courier" foundry="URW" weight="400" style="oblique" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n022023l.afm" glyphs="@ghostscript_font_dir@n022023l.pfb"/>
+- <type name="Courier-BoldOblique" fullname="Courier Bold Oblique" family="Courier" foundry="URW" weight="700" style="oblique" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n022024l.afm" glyphs="@ghostscript_font_dir@n022024l.pfb"/>
+- <type name="fixed" fullname="Helvetica Regular" family="Helvetica" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n019003l.afm" glyphs="@ghostscript_font_dir@n019003l.pfb"/>
+- <type name="Helvetica" fullname="Helvetica Regular" family="Helvetica" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n019003l.afm" glyphs="@ghostscript_font_dir@n019003l.pfb"/>
+- <type name="Helvetica-Bold" fullname="Helvetica Bold" family="Helvetica" foundry="URW" weight="700" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n019004l.afm" glyphs="@ghostscript_font_dir@n019004l.pfb"/>
+- <type name="Helvetica-Oblique" fullname="Helvetica Regular Italic" family="Helvetica" foundry="URW" weight="400" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n019023l.afm" glyphs="@ghostscript_font_dir@n019023l.pfb"/>
+- <type name="Helvetica-BoldOblique" fullname="Helvetica Bold Italic" family="Helvetica" foundry="URW" weight="700" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n019024l.afm" glyphs="@ghostscript_font_dir@n019024l.pfb"/>
+- <type name="Helvetica-Narrow" fullname="Helvetica Narrow" family="Helvetica Narrow" foundry="URW" weight="400" style="normal" stretch="condensed" format="type1" metrics="@ghostscript_font_dir@n019043l.afm" glyphs="@ghostscript_font_dir@n019043l.pfb"/>
+- <type name="Helvetica-Narrow-Oblique" fullname="Helvetica Narrow Oblique" family="Helvetica Narrow" foundry="URW" weight="400" style="oblique" stretch="condensed" format="type1" metrics="@ghostscript_font_dir@n019063l.afm" glyphs="@ghostscript_font_dir@n019063l.pfb"/>
+- <type name="Helvetica-Narrow-Bold" fullname="Helvetica Narrow Bold" family="Helvetica Narrow" foundry="URW" weight="700" style="normal" stretch="condensed" format="type1" metrics="@ghostscript_font_dir@n019044l.afm" glyphs="@ghostscript_font_dir@n019044l.pfb"/>
+- <type name="Helvetica-Narrow-BoldOblique" fullname="Helvetica Narrow Bold Oblique" family="Helvetica Narrow" foundry="URW" weight="700" style="oblique" stretch="condensed" format="type1" metrics="@ghostscript_font_dir@n019064l.afm" glyphs="@ghostscript_font_dir@n019064l.pfb"/>
+- <type name="NewCenturySchlbk-Roman" fullname="New Century Schoolbook" family="NewCenturySchlbk" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@c059013l.afm" glyphs="@ghostscript_font_dir@c059013l.pfb"/>
+- <type name="NewCenturySchlbk-Italic" fullname="New Century Schoolbook Italic" family="NewCenturySchlbk" foundry="URW" weight="400" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@c059033l.afm" glyphs="@ghostscript_font_dir@c059033l.pfb"/>
+- <type name="NewCenturySchlbk-Bold" fullname="New Century Schoolbook Bold" family="NewCenturySchlbk" foundry="URW" weight="700" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@c059016l.afm" glyphs="@ghostscript_font_dir@c059016l.pfb"/>
+- <type name="NewCenturySchlbk-BoldItalic" fullname="New Century Schoolbook Bold Italic" family="NewCenturySchlbk" foundry="URW" weight="700" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@c059036l.afm" glyphs="@ghostscript_font_dir@c059036l.pfb"/>
+- <type name="Palatino-Roman" fullname="Palatino Regular" family="Palatino" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@p052003l.afm" glyphs="@ghostscript_font_dir@p052003l.pfb"/>
+- <type name="Palatino-Italic" fullname="Palatino Italic" family="Palatino" foundry="URW" weight="400" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@p052023l.afm" glyphs="@ghostscript_font_dir@p052023l.pfb"/>
+- <type name="Palatino-Bold" fullname="Palatino Bold" family="Palatino" foundry="URW" weight="700" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@p052004l.afm" glyphs="@ghostscript_font_dir@p052004l.pfb"/>
+- <type name="Palatino-BoldItalic" fullname="Palatino Bold Italic" family="Palatino" foundry="URW" weight="700" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@p052024l.afm" glyphs="@ghostscript_font_dir@p052024l.pfb"/>
+- <type name="Times-Roman" fullname="Times Regular" family="Times" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n021003l.afm" glyphs="@ghostscript_font_dir@n021003l.pfb"/>
+- <type name="Times-Bold" fullname="Times Medium" family="Times" foundry="URW" weight="700" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n021004l.afm" glyphs="@ghostscript_font_dir@n021004l.pfb"/>
+- <type name="Times-Italic" fullname="Times Regular Italic" family="Times" foundry="URW" weight="400" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n021023l.afm" glyphs="@ghostscript_font_dir@n021023l.pfb"/>
+- <type name="Times-BoldItalic" fullname="Times Medium Italic" family="Times" foundry="URW" weight="700" style="italic" stretch="normal" format="type1" metrics="@ghostscript_font_dir@n021024l.afm" glyphs="@ghostscript_font_dir@n021024l.pfb"/>
+- <type name="Symbol" fullname="Symbol" family="Symbol" foundry="URW" weight="400" style="normal" stretch="normal" format="type1" metrics="@ghostscript_font_dir@s050000l.afm" glyphs="@ghostscript_font_dir@s050000l.pfb" version="0.1" encoding="AdobeCustom"/>
++ <type name="AvantGarde-Book" fullname="AvantGarde Book" family="AvantGarde" foundry="URW" weight="400" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@URWGothic-Book.otf"/>
++ <type name="AvantGarde-BookOblique" fullname="AvantGarde Book Oblique" family="AvantGarde" foundry="URW" weight="400" style="oblique" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@URWGothic-BookOblique.otf"/>
++ <type name="AvantGarde-Demi" fullname="AvantGarde DemiBold" family="AvantGarde" foundry="URW" weight="600" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@URWGothic-Demi.otf"/>
++ <type name="AvantGarde-DemiOblique" fullname="AvantGarde DemiOblique" family="AvantGarde" foundry="URW" weight="600" style="oblique" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@URWGothic-DemiOblique.otf"/>
++ <type name="Bookman-Demi" fullname="Bookman DemiBold" family="Bookman" foundry="URW" weight="600" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@URWBookman-Demi.otf"/>
++ <type name="Bookman-DemiItalic" fullname="Bookman DemiBold Italic" family="Bookman" foundry="URW" weight="600" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@URWBookman-DemiItalic.otf"/>
++ <type name="Bookman-Light" fullname="Bookman Light" family="Bookman" foundry="URW" weight="300" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@URWBookman-Light.otf"/>
++ <type name="Bookman-LightItalic" fullname="Bookman Light Italic" family="Bookman" foundry="URW" weight="300" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@URWBookman-LightItalic.otf"/>
++ <type name="Courier" fullname="Courier Regular" family="Courier" foundry="URW" weight="400" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusMonoPS-Regular.otf"/>
++ <type name="Courier-Bold" fullname="Courier Bold" family="Courier" foundry="URW" weight="700" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusMonoPS-Bold.otf"/>
++ <type name="Courier-Oblique" fullname="Courier Regular Oblique" family="Courier" foundry="URW" weight="400" style="oblique" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusMonoPS-Italic.otf"/>
++ <type name="Courier-BoldOblique" fullname="Courier Bold Oblique" family="Courier" foundry="URW" weight="700" style="oblique" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusMonoPS-BoldItalic.otf"/>
++ <type name="fixed" fullname="Helvetica Regular" family="Helvetica" foundry="URW" weight="400" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusSans-Regular.otf"/>
++ <type name="Helvetica" fullname="Helvetica Regular" family="Helvetica" foundry="URW" weight="400" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusSans-Regular.otf"/>
++ <type name="Helvetica-Bold" fullname="Helvetica Bold" family="Helvetica" foundry="URW" weight="700" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusSans-Bold.otf"/>
++ <type name="Helvetica-Oblique" fullname="Helvetica Regular Italic" family="Helvetica" foundry="URW" weight="400" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusSans-Italic.otf"/>
++ <type name="Helvetica-BoldOblique" fullname="Helvetica Bold Italic" family="Helvetica" foundry="URW" weight="700" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusSans-BoldItalic.otf"/>
++ <type name="Helvetica-Narrow" fullname="Helvetica Narrow" family="Helvetica Narrow" foundry="URW" weight="400" style="normal" stretch="condensed" format="cff" glyphs="@ghostscript_font_dir@NimbusSansNarrow-Regular.otf"/>
++ <type name="Helvetica-Narrow-Oblique" fullname="Helvetica Narrow Oblique" family="Helvetica Narrow" foundry="URW" weight="400" style="oblique" stretch="condensed" format="cff" glyphs="@ghostscript_font_dir@NimbusSansNarrow-Oblique.otf"/>
++ <type name="Helvetica-Narrow-Bold" fullname="Helvetica Narrow Bold" family="Helvetica Narrow" foundry="URW" weight="700" style="normal" stretch="condensed" format="cff" glyphs="@ghostscript_font_dir@NimbusSansNarrow-Bold.otf"/>
++ <type name="Helvetica-Narrow-BoldOblique" fullname="Helvetica Narrow Bold Oblique" family="Helvetica Narrow" foundry="URW" weight="700" style="oblique" stretch="condensed" format="cff" glyphs="@ghostscript_font_dir@NimbusSansNarrow-BdOblique.otf"/>
++ <type name="NewCenturySchlbk-Roman" fullname="New Century Schoolbook" family="NewCenturySchlbk" foundry="URW" weight="400" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@C059-Roman.otf"/>
++ <type name="NewCenturySchlbk-Italic" fullname="New Century Schoolbook Italic" family="NewCenturySchlbk" foundry="URW" weight="400" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@C059-Italic.otf"/>
++ <type name="NewCenturySchlbk-Bold" fullname="New Century Schoolbook Bold" family="NewCenturySchlbk" foundry="URW" weight="700" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@C059-Bold.otf"/>
++ <type name="NewCenturySchlbk-BoldItalic" fullname="New Century Schoolbook Bold Italic" family="NewCenturySchlbk" foundry="URW" weight="700" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@C059-BdIta.otf"/>
++ <type name="Palatino-Roman" fullname="Palatino Regular" family="Palatino" foundry="URW" weight="400" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@P052-Roman.otf"/>
++ <type name="Palatino-Italic" fullname="Palatino Italic" family="Palatino" foundry="URW" weight="400" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@P052-Italic.otf"/>
++ <type name="Palatino-Bold" fullname="Palatino Bold" family="Palatino" foundry="URW" weight="700" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@P052-Bold.otf"/>
++ <type name="Palatino-BoldItalic" fullname="Palatino Bold Italic" family="Palatino" foundry="URW" weight="700" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@P052-BoldItalic.otf"/>
++ <type name="Times-Roman" fullname="Times Regular" family="Times" foundry="URW" weight="400" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusRoman-Regular.otf"/>
++ <type name="Times-Bold" fullname="Times Medium" family="Times" foundry="URW" weight="700" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusRoman-Bold.otf"/>
++ <type name="Times-Italic" fullname="Times Regular Italic" family="Times" foundry="URW" weight="400" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusRoman-Italic.otf"/>
++ <type name="Times-BoldItalic" fullname="Times Medium Italic" family="Times" foundry="URW" weight="700" style="italic" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@NimbusRoman-BoldItalic.otf"/>
++ <type name="Symbol" fullname="Symbol" family="Symbol" foundry="URW" weight="400" style="normal" stretch="normal" format="cff" glyphs="@ghostscript_font_dir@StandardSymbolsPS.otf" version="2.0" encoding="AdobeCustom"/>
+ </typemap>
diff --git a/abs/core/imagemagick/perlmagick.rpath.patch b/abs/core/imagemagick/perlmagick.rpath.patch
deleted file mode 100644
index a5b1a82..0000000
--- a/abs/core/imagemagick/perlmagick.rpath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2013-02-21 03:26:56.785156600 -0500
-+++ Makefile.in 2013-02-21 03:39:03.102411457 -0500
-@@ -10469,6 +10469,8 @@
-
- @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@$(PERLMAKEFILE): perl-sources $(MAGICKCORE_LIBS) $(MAGICKWAND_LIBS) $(PERLMAKEMAKER)
- @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @PERL@ Makefile.PL $(PERL_MAKE_OPTIONS)
-+@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @SED@ -i 's|LD_RUN_PATH|DIE_LD_RUN_PATH_DIE|g' Makefile
-+@WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ cd $(PERLMAGICK) && @SED@ -i 's|LD_RUN_PATH|DIE_LD_RUN_PATH_DIE|g' quantum/Makefile
-
- @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@install-exec-perl: $(PERLMAKEFILE)
- @WITH_PERL_DYNAMIC_TRUE@@WITH_PERL_TRUE@ ( cd $(PERLMAGICK) && $(MAKE) CC='@CC@' && \