summaryrefslogtreecommitdiffstats
path: root/abs/core/imake
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 02:42:29 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 02:42:29 (GMT)
commita24f012acee35490add2d43c57e0f6edb785e4d1 (patch)
treecd4ed7cd96a730c00df7b865aa147882621c7648 /abs/core/imake
parent5bb0c04f864f2bec06fb7f570e787a4311e1e688 (diff)
downloadlinhes_pkgbuild-a24f012acee35490add2d43c57e0f6edb785e4d1.zip
linhes_pkgbuild-a24f012acee35490add2d43c57e0f6edb785e4d1.tar.gz
linhes_pkgbuild-a24f012acee35490add2d43c57e0f6edb785e4d1.tar.bz2
imake 1.0.5
Diffstat (limited to 'abs/core/imake')
-rw-r--r--abs/core/imake/PKGBUILD65
-rw-r--r--abs/core/imake/xorg-cf-files-1.0.2-xprint.patch39
2 files changed, 36 insertions, 68 deletions
diff --git a/abs/core/imake/PKGBUILD b/abs/core/imake/PKGBUILD
index 9a879d8..74a7527 100644
--- a/abs/core/imake/PKGBUILD
+++ b/abs/core/imake/PKGBUILD
@@ -1,46 +1,53 @@
-# $Id: PKGBUILD 87585 2010-08-17 07:28:34Z jgc $
+# $Id: PKGBUILD 152805 2012-03-09 17:06:42Z andyrtr $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=imake
-pkgver=1.0.3
-pkgrel=2
+pkgver=1.0.5
+pkgrel=1
pkgdesc="X.Org imake program and related utilities"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://xorg.freedesktop.org/"
license=('custom')
-depends=(glibc)
-makedepends=(pkgconfig xproto perl)
+depends=('glibc')
+makedepends=('pkgconfig' 'xproto' 'perl')
optdepends=('perl: for mkhtmlindex')
-source=(http://xorg.freedesktop.org/releases/individual/util/imake-1.0.3.tar.bz2
- http://xorg.freedesktop.org/releases/individual/util/gccmakedep-1.0.2.tar.bz2
- http://xorg.freedesktop.org/releases/individual/util/lndir-1.0.2.tar.bz2
- http://xorg.freedesktop.org/releases/individual/util/makedepend-1.0.2.tar.bz2
- http://xorg.freedesktop.org/releases/individual/util/xorg-cf-files-1.0.3.tar.bz2
- linuxconfig.patch
- xorg-cf-files-1.0.2-xprint.patch
- LICENSE)
-md5sums=('ff553c4646edcc9e76b7308991ad421a'
- 'b533c0771dbbaf9b041ff35bb941d3a2'
- '619acbb2ed766d7762f02328513b1f72'
- '62e58330fe8d1e3e28c7a45779833a48'
- '10546b5ddda3cdda7950bb56bf98e0ea'
- 'b3385d8efbbe7c7fc50ed3a96ce37a16'
- '82356cfc8a761c85b0b37736fc91f604'
- 'f5767133ef7a98a0bfa15139e0e3d32e')
+source=("http://xorg.freedesktop.org/releases/individual/util/imake-${pkgver}.tar.bz2"
+ 'http://xorg.freedesktop.org/releases/individual/util/gccmakedep-1.0.2.tar.bz2'
+ 'http://xorg.freedesktop.org/releases/individual/util/lndir-1.0.3.tar.bz2'
+ 'http://xorg.freedesktop.org/releases/individual/util/makedepend-1.0.4.tar.bz2'
+ 'http://xorg.freedesktop.org/releases/individual/util/xorg-cf-files-1.0.4.tar.bz2'
+ 'linuxconfig.patch'
+ 'LICENSE')
+sha1sums=('1fd3dca267d125ad86583d7f9663b6ff532cddd1'
+ 'a3d971a507a460233afd8ed46e9f06135fed634d'
+ 'fc71a6ff2cc0a1065cfb608796ffd6b4f0ce76fe'
+ '1f0f8aea1526c6c022f2cf16f7a6c67118c68336'
+ 'c58b7252df481572ec1ccd77b9f1ab561ed89e45'
+ '72f2d4cc4d4cc5f85ba6982718ae1bbb7e56e0d0'
+ 'c5ecffb25ad079ba3858e3aec047d046df603a89')
build() {
- cd ${srcdir}/xorg-cf-files-1.0.3*
- patch -Np1 -i "${srcdir}/linuxconfig.patch" || return 1
- patch -Np1 -i "${srcdir}/xorg-cf-files-1.0.2-xprint.patch" || return 1
+ cd ${srcdir}/xorg-cf-files-1.0.4
+ patch -p1 -i "${srcdir}/linuxconfig.patch"
cd "${srcdir}"
for i in *; do
if [ -d "${i}" ]; then
pushd "${i}"
- ./configure --prefix=/usr --mandir=/usr/share/man || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
popd
fi
done
- install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
+}
+
+package() {
+ cd "${srcdir}"
+ for i in *; do
+ if [ -d "${i}" ]; then
+ pushd "${i}"
+ make DESTDIR="${pkgdir}" install
+ popd
+ fi
+ done
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/abs/core/imake/xorg-cf-files-1.0.2-xprint.patch b/abs/core/imake/xorg-cf-files-1.0.2-xprint.patch
deleted file mode 100644
index 3926d72..0000000
--- a/abs/core/imake/xorg-cf-files-1.0.2-xprint.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- xorg-cf-files-1.0.3/X11.tmpl.xprint 2005-10-01 12:45:48.000000000 -0400
-+++ xorg-cf-files-1.0.3/X11.tmpl 2006-04-25 20:24:02.000000000 -0400
-@@ -3920,21 +3920,13 @@
- #endif
-
- #ifndef ExtraXawReqs
--# if BuildXaw
--# define ExtraXawReqs $(XPLIB)
--# else
--# define ExtraXawReqs /**/
--# endif
-+# define ExtraXawReqs /**/
- #endif
-
- EXTRAXAWREQS = ExtraXawReqs
-
- #ifndef ExtraXawClientDepLibs
--# if BuildXaw
--# define ExtraXawClientDepLibs $(DEPXPLIB)
--# else
--# define ExtraXawClientDepLibs /**/
--# endif
-+# define ExtraXawClientDepLibs /**/
- #endif
-
- EXTRAXAWCLIENTDEPLIBS = ExtraXawClientDepLibs
-@@ -3944,11 +3936,7 @@
- #endif
-
- #ifndef ExtraXawClientLibs
--# if BuildXaw
--# define ExtraXawClientLibs $(XPLIB)
--# else
--# define ExtraXawClientLibs /**/
--# endif
-+# define ExtraXawClientLibs /**/
- #endif
-
- EXTRAXAWCLIENTLIBS = ExtraXawClientLibs